summaryrefslogtreecommitdiffstats
path: root/abs/core/libxcursor
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-13 02:19:33 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-13 02:19:33 (GMT)
commitee66a417b448c74df51683e005f9e99ed11b5f9c (patch)
tree868f764409abc1244752a8bd10e5b1616ab3c834 /abs/core/libxcursor
parent84402d097a6fbf201fc55eb082c7bf0104092f26 (diff)
downloadlinhes_pkgbuild-ee66a417b448c74df51683e005f9e99ed11b5f9c.zip
linhes_pkgbuild-ee66a417b448c74df51683e005f9e99ed11b5f9c.tar.gz
linhes_pkgbuild-ee66a417b448c74df51683e005f9e99ed11b5f9c.tar.bz2
libxcursor: up to latest
Diffstat (limited to 'abs/core/libxcursor')
-rw-r--r--abs/core/libxcursor/PKGBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/abs/core/libxcursor/PKGBUILD b/abs/core/libxcursor/PKGBUILD
index 673585e..9e37fa7 100644
--- a/abs/core/libxcursor/PKGBUILD
+++ b/abs/core/libxcursor/PKGBUILD
@@ -1,22 +1,29 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: Alexander Baldeck <alexander@archlinux.org>
-# Contributor: Jan de Groot <jgc@archlinux.org>
+# $Id: PKGBUILD 97807 2010-11-01 22:23:46Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Alexander Baldeck <alexander@archlinux.org>
pkgname=libxcursor
-pkgver=1.1.9
+pkgver=1.1.11
pkgrel=1
pkgdesc="X cursor management library"
arch=(i686 x86_64)
url="http://xorg.freedesktop.org/"
+license=('custom')
depends=('libxfixes' 'libxrender')
-makedepends=('pkgconfig')
+makedepends=('xorg-util-macros')
options=('!libtool')
source=(${url}/releases/individual/lib/libXcursor-${pkgver}.tar.bz2)
+sha1sums=('35491bd17cbcdda712e1a064c67ccbc523e2702c')
build() {
- cd ${startdir}/src/libXcursor-${pkgver}
- ./configure --prefix=/usr --sysconfdir=/etc \
- --build=${CHOST} --host=${CHOST}
+ cd "${srcdir}/libXcursor-${pkgver}"
+ ./configure --prefix=/usr --sysconfdir=/etc --disable-static
make || return 1
- make DESTDIR=${startdir}/pkg install || return 1
}
-md5sums=('99b7554037a92b260891091e81815a0a')
+package() {
+ cd "${srcdir}/libXcursor-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
+
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+