summaryrefslogtreecommitdiffstats
path: root/abs/core/libxkbui
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-26 15:14:04 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-26 15:14:04 (GMT)
commit1df3bfdbd4074544ef9b570554ec9c9f35a83d1b (patch)
tree3398ba8d2ada9bf98257352968eee814946b4137 /abs/core/libxkbui
parent30e6aa85c083f60c27e36b52d4b960a44aaeb32a (diff)
downloadlinhes_pkgbuild-1df3bfdbd4074544ef9b570554ec9c9f35a83d1b.zip
linhes_pkgbuild-1df3bfdbd4074544ef9b570554ec9c9f35a83d1b.tar.gz
linhes_pkgbuild-1df3bfdbd4074544ef9b570554ec9c9f35a83d1b.tar.bz2
libxkbui: 1.0.2
Diffstat (limited to 'abs/core/libxkbui')
-rw-r--r--abs/core/libxkbui/LICENSE25
-rw-r--r--abs/core/libxkbui/PKGBUILD34
2 files changed, 45 insertions, 14 deletions
diff --git a/abs/core/libxkbui/LICENSE b/abs/core/libxkbui/LICENSE
new file mode 100644
index 0000000..abe6f4d
--- /dev/null
+++ b/abs/core/libxkbui/LICENSE
@@ -0,0 +1,25 @@
+/************************************************************
+ Copyright (c) 1996 by Silicon Graphics Computer Systems, Inc.
+
+ Permission to use, copy, modify, and distribute this
+ software and its documentation for any purpose and without
+ fee is hereby granted, provided that the above copyright
+ notice appear in all copies and that both that copyright
+ notice and this permission notice appear in supporting
+ documentation, and that the name of Silicon Graphics not be
+ used in advertising or publicity pertaining to distribution
+ of the software without specific prior written permission.
+ Silicon Graphics makes no representation about the suitability
+ of this software for any purpose. It is provided "as is"
+ without any express or implied warranty.
+
+ SILICON GRAPHICS DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS
+ SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY
+ AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL SILICON
+ GRAPHICS BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL
+ DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+ DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE
+ OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH
+ THE USE OR PERFORMANCE OF THIS SOFTWARE.
+
+ ********************************************************/
diff --git a/abs/core/libxkbui/PKGBUILD b/abs/core/libxkbui/PKGBUILD
index 52c20a0..83b0318 100644
--- a/abs/core/libxkbui/PKGBUILD
+++ b/abs/core/libxkbui/PKGBUILD
@@ -1,23 +1,29 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-#Maintainer: Jan de Groot <jgc@archlinux.org>
+# $Id: PKGBUILD 151385 2012-02-25 23:56:14Z pierre $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=libxkbui
pkgver=1.0.2
-pkgrel=1
+pkgrel=4
pkgdesc="X11 keyboard UI presentation library"
-url="http://xorg.freedesktop.org/"
-depends=(libxt libxkbfile)
-makedepends=(pkgconfig)
-options=(!libtool)
arch=('i686' 'x86_64')
-source=(${url}/releases/individual/lib/${pkgname}-${pkgver}.tar.bz2)
-md5sums=(1143e456f7429e18e88f2eadb2f2b6b1)
+url="http://xorg.freedesktop.org/"
+license=('custom')
+depends=('libxt' 'libxkbfile')
+makedepends=('pkgconfig')
+options=('!libtool')
+source=("${url}/releases/individual/lib/${pkgname}-${pkgver}.tar.bz2"
+ 'LICENSE')
+md5sums=('1143e456f7429e18e88f2eadb2f2b6b1'
+ 'd1efaa1271fc028cd5bec33f836ee9ef')
build() {
- cd ${startdir}/src/${pkgname}-${pkgver}
- ./configure --prefix=/usr \
- --host=${CHOST} --build=${CHOST}
- make || return 1
- make DESTDIR=${startdir}/pkg install || return 1
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
}
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}