summaryrefslogtreecommitdiffstats
path: root/abs/core/libxml2
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-20 18:58:57 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-20 18:58:57 (GMT)
commit7d170562cfb13aaf5a122cda079f186634ab5e09 (patch)
tree363125f157044d6de8967d63c1842bb2c78542bc /abs/core/libxml2
parent5a289b2c00bb7df836e945162cb693eea02c1e62 (diff)
downloadlinhes_pkgbuild-7d170562cfb13aaf5a122cda079f186634ab5e09.zip
linhes_pkgbuild-7d170562cfb13aaf5a122cda079f186634ab5e09.tar.gz
linhes_pkgbuild-7d170562cfb13aaf5a122cda079f186634ab5e09.tar.bz2
libxml2: update to 2.9.8
Diffstat (limited to 'abs/core/libxml2')
-rw-r--r--abs/core/libxml2/PKGBUILD66
1 files changed, 31 insertions, 35 deletions
diff --git a/abs/core/libxml2/PKGBUILD b/abs/core/libxml2/PKGBUILD
index 6f18bc1..2ab74b4 100644
--- a/abs/core/libxml2/PKGBUILD
+++ b/abs/core/libxml2/PKGBUILD
@@ -1,65 +1,61 @@
# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>
-# Maintainer: Tom Gundersen <teg@jklm.no>
+# Contributor: Tom Gundersen <teg@jklm.no>
# Contributor: John Proctor <jproctor@prium.net>
pkgname=libxml2
-pkgver=2.9.7+4+g72182550
-pkgrel=2
+pkgver=2.9.8
+pkgrel=1
pkgdesc="XML parsing library, version 2"
-arch=(x86_64)
-license=('MIT')
-depends=('zlib' 'readline' 'ncurses' 'xz' 'icu')
-options=(!makeflags)
-makedepends=('python2' 'python' 'git')
url="http://www.xmlsoft.org/"
-_commit=72182550926d31ad17357bd3ed69e49d7e69df02 # master~7
+arch=(x86_64)
+license=(MIT)
+depends=(zlib readline ncurses xz icu)
+makedepends=(python2 python git)
+_commit=18890f471c420411aa3c989e104d090966ec9dbf # tags/v2.9.8^0
source=(git+https://git.gnome.org/browse/libxml2#commit=$_commit
- https://www.w3.org/XML/Test/xmlts20130923.tar.gz
- libxml2-2.9.4-remove-pyverify_fd.patch)
+ https://www.w3.org/XML/Test/xmlts20130923.tar.gz)
sha256sums=('SKIP'
- '9b61db9f5dbffa545f4b8d78422167083a8568c59bd1129f94138f936cf6fc1f'
- 'c9cebff010bd99c5453847e87b9fa8fdd7f744f415bf680b3650877789460ca9')
+ '9b61db9f5dbffa545f4b8d78422167083a8568c59bd1129f94138f936cf6fc1f')
pkgver() {
cd $pkgname
- git describe --long | sed -e 's/-rc/rc/' -e 's/-/+/g' -e 's/^v//'
+ git describe --tags | sed 's/-rc/rc/;s/^v//;s/-/+/g'
}
prepare() {
- mkdir build-py3
- mkdir build-py2
- mv xmlconf build-py2/
- cd $pkgname
+ mkdir build-py{2,3}
- patch -Np1 -i ../libxml2-2.9.4-remove-pyverify_fd.patch
+ cd $pkgname
NOCONFIGURE=1 ./autogen.sh
}
-build() {
- cd build-py2
- ../$pkgname/configure --prefix=/usr --with-threads --with-history --with-python=/usr/bin/python2 --with-icu
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' libtool
- make
-
- cd ../build-py3
- ../$pkgname/configure --prefix=/usr --with-threads --with-history --with-python=/usr/bin/python --with-icu
+_build() (
+ cd build-py$1
+ ../$pkgname/configure \
+ --prefix=/usr \
+ --with-threads \
+ --with-history \
+ --with-python=/usr/bin/python$1 \
+ --with-icu
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' libtool
PYTHONHASHSEED=0 make
+ find doc -type f -exec chmod 0644 {} +
+)
+
+build() {
+ _build 2
+ _build 3
}
check() {
cd build-py2
+ ln -s ../xmlconf
make check
}
package() {
- cd build-py2
- find doc -type f -exec chmod 0644 {} \;
-
- make DESTDIR="${pkgdir}" install
- install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
-
- cd ../build-py3/python
- PYTHONHASHSEED=0 make DESTDIR="${pkgdir}" install
+ make -C build-py2 DESTDIR="$pkgdir" install
+ make -C build-py3/python DESTDIR="$pkgdir" install
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 build-py2/COPYING
}