summaryrefslogtreecommitdiffstats
path: root/abs/core/libxvmc
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/libxvmc
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/libxvmc')
-rw-r--r--abs/core/libxvmc/LICENSE23
-rw-r--r--abs/core/libxvmc/PKGBUILD20
2 files changed, 34 insertions, 9 deletions
diff --git a/abs/core/libxvmc/LICENSE b/abs/core/libxvmc/LICENSE
new file mode 100644
index 0000000..e423bcb
--- /dev/null
+++ b/abs/core/libxvmc/LICENSE
@@ -0,0 +1,23 @@
+Copyright (c) 1995, 1996 The XFree86 Project, Inc
+XvMCWrapper.c - Copyright (c) 2004 The Unichrome project. All rights reserved.
+XvMCWrapper.c - Author: Thomas Hellström (2004)
+
+All Rights Reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the "Software"),
+to deal in the Software without restriction, including without limitation
+the rights to use, copy, modify, merge, publish, distribute, sublicense,
+and/or sell copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHOR(S) OR COPYRIGHT HOLDER(S) BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/abs/core/libxvmc/PKGBUILD b/abs/core/libxvmc/PKGBUILD
index 49c76b7..c22aeb4 100644
--- a/abs/core/libxvmc/PKGBUILD
+++ b/abs/core/libxvmc/PKGBUILD
@@ -1,23 +1,25 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id: PKGBUILD 55272 2009-10-12 16:22:20Z andyrtr $
#Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=libxvmc
-pkgver=1.0.4
+pkgver=1.0.5
pkgrel=1
pkgdesc="X11 Video Motion Compensation extension library"
arch=(i686 x86_64)
url="http://xorg.freedesktop.org/"
-depends=('libxv>=1.0.3')
+license=('custom')
+depends=('libxv>=1.0.5')
makedepends=('pkgconfig')
options=('!libtool')
-source=(${url}/releases/individual/lib/libXvMC-${pkgver}.tar.bz2)
-md5sums=('b54600573daf9d1a29b952e8d35b389e')
+source=(${url}/releases/individual/lib/libXvMC-${pkgver}.tar.bz2 LICENSE)
+md5sums=('16c3a11add14979beb7510e44623cac6'
+ 'ca9d908b0fa487a213802ff38336259d')
build() {
- cd ${startdir}/src/libXvMC-${pkgver}
- ./configure --prefix=/usr --sysconfdir=/etc \
+ cd ${srcdir}/libXvMC-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc --disable-static \
--build=${CHOST} --host=${CHOST}
make || return 1
- make DESTDIR=${startdir}/pkg install || return 1
+ make DESTDIR=${pkgdir} install || return 1
+ install -D -m644 ../LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
-