summaryrefslogtreecommitdiffstats
path: root/abs/core/lighttpd/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-03-14 23:36:27 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-03-14 23:36:27 (GMT)
commit33f20b64e15104c46c46f801b7d148c500046107 (patch)
tree1f69981d3067f8289caf041cd8a6c006b4fb7f07 /abs/core/lighttpd/PKGBUILD
parent2e9a78e69206e284e2e8411bc455d52b8dd9ca74 (diff)
downloadlinhes_pkgbuild-33f20b64e15104c46c46f801b7d148c500046107.zip
linhes_pkgbuild-33f20b64e15104c46c46f801b7d148c500046107.tar.gz
linhes_pkgbuild-33f20b64e15104c46c46f801b7d148c500046107.tar.bz2
lighttpd: sync testing to core
bugfix
Diffstat (limited to 'abs/core/lighttpd/PKGBUILD')
-rw-r--r--abs/core/lighttpd/PKGBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/abs/core/lighttpd/PKGBUILD b/abs/core/lighttpd/PKGBUILD
index d0811ae..cec41d4 100644
--- a/abs/core/lighttpd/PKGBUILD
+++ b/abs/core/lighttpd/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Pierre Schmitz <pierre@archlinux.de>
pkgname=lighttpd
-pkgver=1.4.20
-pkgrel=35
+pkgver=1.4.26
+pkgrel=7
pkgdesc='a secure, fast, compliant and very flexible web-server'
license=('custom')
arch=('i686' 'x86_64')
@@ -18,16 +18,16 @@ optdepends=('libxml2: mod_webdav' \
)
backup=('etc/lighttpd/lighttpd.conf' 'etc/logrotate.d/lighttpd' 'etc/lighttpd/auth-inc.conf')
options=('!libtool' 'emptydirs')
-source=("http://www.lighttpd.net/download/lighttpd-${pkgver}.tar.bz2" \
- 'lighttpd.rc.d' 'lighttpd.logrotate.d' 'lighttpd.conf' auth-inc.conf)
-
-md5sums=('ed6ee0bb714f393219a32768d86984d8'
- 'bd690eee0d9e51857448770a151023b0'
- '857e174643fd7761a2f0d8431a679f6c'
- 'db6b8b8f144125cf249e97c4b13f3f18')
-
+source=("http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${pkgver}.tar.bz2" \
+ 'lighttpd.rc.d' 'lighttpd.logrotate.d' 'lighttpd.conf' 'auth-inc.conf' \
+ 'openssl-0.9.8m.patch')
+install='lighttpd.install'
build() {
cd $srcdir/$pkgname-$pkgver
+
+ # fixed in 1.4.27
+ patch -p2 -i ${srcdir}/openssl-0.9.8m.patch || return 1
+
./configure --prefix=/usr \
--libexecdir=/usr/lib/lighttpd/modules \
--sysconfdir=/etc/lighttpd \
@@ -64,7 +64,14 @@ build() {
-e 's|#server.groupname = "wwwrun"|server.groupname = "http"|' \
-e 's|#server.pid-file = "/var/run/lighttpd.pid"|server.pid-file = "/var/run/lighttpd/lighttpd.pid"|' \
-e 's|/usr/local/bin/php-cgi|/usr/bin/php-cgi|' \
+ -e 's|"^/mythweb|"^/{1,2}mythweb|' \
-i ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
}
+md5sums=('a682c8efce47a2f4263a247ba0813c9b'
+ 'bd690eee0d9e51857448770a151023b0'
+ '857e174643fd7761a2f0d8431a679f6c'
+ 'fe078f9b8ee701ed21278789cad90acf'
+ 'c6e361131000ceec085f40b310ef4a2c'
+ '84c884b8dadd724afe2bc6529e9d4485')