summaryrefslogtreecommitdiffstats
path: root/abs/core/lighttpd
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-01-14 23:45:41 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-01-14 23:45:41 (GMT)
commit2a67b29320c4c371098f519fe36bc8babb59aa29 (patch)
tree19081383d60be821cc9fa559676a569fae4511c5 /abs/core/lighttpd
parent2334df224e7782a4d74e9306f367bb09d4d2cd17 (diff)
downloadlinhes_pkgbuild-2a67b29320c4c371098f519fe36bc8babb59aa29.zip
linhes_pkgbuild-2a67b29320c4c371098f519fe36bc8babb59aa29.tar.gz
linhes_pkgbuild-2a67b29320c4c371098f519fe36bc8babb59aa29.tar.bz2
lighttpd: SSL now defaults to on. The startup script will create the ssl cert if needed.
refs #896
Diffstat (limited to 'abs/core/lighttpd')
-rw-r--r--abs/core/lighttpd/PKGBUILD8
-rw-r--r--abs/core/lighttpd/ssl-inc.conf4
2 files changed, 9 insertions, 3 deletions
diff --git a/abs/core/lighttpd/PKGBUILD b/abs/core/lighttpd/PKGBUILD
index 48c93b0..a936235 100644
--- a/abs/core/lighttpd/PKGBUILD
+++ b/abs/core/lighttpd/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=lighttpd
pkgver=1.4.28
-pkgrel=6
+pkgrel=7
pkgdesc='A secure, fast, compliant and very flexible web-server'
license=('custom')
arch=('i686' 'x86_64')
@@ -18,7 +18,7 @@ optdepends=('libxml2: mod_webdav' \
backup=(etc/lighttpd/lighttpd.conf etc/logrotate.d/lighttpd etc/lighttpd/auth-inc.conf etc/lighttpd/conf.include etc/lighttpd/html.include)
options=('!libtool' 'emptydirs')
source=("http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${pkgver}.tar.bz2" \
- 'lighttpd.rc.d' 'lighttpd.logrotate.d' 'lighttpd.conf' 'auth-inc.conf')
+ 'lighttpd.rc.d' 'lighttpd.logrotate.d' 'lighttpd.conf' 'auth-inc.conf' 'ssl-inc.conf')
#install='lighttpd.install'
build() {
cd ${srcdir}/${pkgname}-${pkgver}
@@ -55,6 +55,7 @@ package() {
install -D -m644 ../lighttpd.conf ${pkgdir}/etc/lighttpd/lighttpd.conf
install -D -m644 ../auth-inc.conf ${pkgdir}/etc/lighttpd/auth-inc.conf
+ install -D -m644 ../ssl-inc.conf ${pkgdir}/etc/lighttpd/ssl-inc.conf
# set sane defaults
sed -e 's|/srv/www/htdocs/|/srv/http/|' \
@@ -79,4 +80,5 @@ md5sums=('586eb535d31ac299652495b058dd87c4'
'bd690eee0d9e51857448770a151023b0'
'e17a29ebcdac82a853389c3df468c980'
'8c1b42c878461f1529433c35d691f519'
- 'c6e361131000ceec085f40b310ef4a2c')
+ '62779511e3f1127c3cc9b94c49f99c29'
+ 'ef64c496602b182a551416a8ba6b3d43')
diff --git a/abs/core/lighttpd/ssl-inc.conf b/abs/core/lighttpd/ssl-inc.conf
new file mode 100644
index 0000000..d545336
--- /dev/null
+++ b/abs/core/lighttpd/ssl-inc.conf
@@ -0,0 +1,4 @@
+$SERVER["socket"] == ":443" {
+ ssl.engine = "enable"
+ ssl.pemfile = "/etc/lighttpd/linhes.pem"
+ }