summaryrefslogtreecommitdiffstats
path: root/abs/core/lighttpd
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
commitc4bd4457b5d640e1c8f5afbca7cd54c53691e5fc (patch)
treef4e4f7a91e1d9d90033fd99d89e5e26a2c144528 /abs/core/lighttpd
parent0e7b327a1ae444233f1308a95420f70540ad74a3 (diff)
downloadlinhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.zip
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.gz
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.bz2
RSYNC CORE:
resync core-testing -> core Signed-off-by: James Meyer <james.meyer@operamail.com>
Diffstat (limited to 'abs/core/lighttpd')
-rw-r--r--abs/core/lighttpd/PKGBUILD17
-rw-r--r--abs/core/lighttpd/__changelog8
-rw-r--r--abs/core/lighttpd/lighttpd.conf4
-rwxr-xr-xabs/core/lighttpd/lighttpd.install2
4 files changed, 23 insertions, 8 deletions
diff --git a/abs/core/lighttpd/PKGBUILD b/abs/core/lighttpd/PKGBUILD
index cec41d4..ed6d01e 100644
--- a/abs/core/lighttpd/PKGBUILD
+++ b/abs/core/lighttpd/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=lighttpd
pkgver=1.4.26
-pkgrel=7
-pkgdesc='a secure, fast, compliant and very flexible web-server'
+pkgrel=16
+pkgdesc='A secure, fast, compliant and very flexible web-server'
license=('custom')
arch=('i686' 'x86_64')
url="http://www.lighttpd.net/"
@@ -16,12 +16,12 @@ optdepends=('libxml2: mod_webdav' \
'sqlite3: mod_webdav' \
'gdbm: mod_trigger_b4_dl' \
)
-backup=('etc/lighttpd/lighttpd.conf' 'etc/logrotate.d/lighttpd' 'etc/lighttpd/auth-inc.conf')
+backup=(etc/lighttpd/lighttpd.conf etc/logrotate.d/lighttpd etc/lighttpd/auth-inc.conf etc/lighttpd/conf.include etc/lighttpd/html.include)
options=('!libtool' 'emptydirs')
source=("http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${pkgver}.tar.bz2" \
'lighttpd.rc.d' 'lighttpd.logrotate.d' 'lighttpd.conf' 'auth-inc.conf' \
'openssl-0.9.8m.patch')
-install='lighttpd.install'
+#install='lighttpd.install'
build() {
cd $srcdir/$pkgname-$pkgver
@@ -65,13 +65,20 @@ build() {
-e 's|#server.pid-file = "/var/run/lighttpd.pid"|server.pid-file = "/var/run/lighttpd/lighttpd.pid"|' \
-e 's|/usr/local/bin/php-cgi|/usr/bin/php-cgi|' \
-e 's|"^/mythweb|"^/{1,2}mythweb|' \
+ -e 's|# "mod_proxy",| "mod_proxy",|' \
+ -e 's|# "mod_ssi",| "mod_ssi",|' \
+ -e 's|#ssi.extension = ( ".shtml" )|ssi.extension = ( ".shtml" )|' \
-i ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
+ /bin/touch $pkgdir/etc/lighttpd/{conf,html}.include || return 1
+ /bin/echo 'include "/etc/lighttpd/conf.include"' >> $pkgdir/etc/lighttpd/lighttpd.conf || return 1
+ /bin/echo 'include "/etc/lighttpd/html.include"' >> $pkgdir/etc/lighttpd/lighttpd.conf || return 1
+
install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
}
md5sums=('a682c8efce47a2f4263a247ba0813c9b'
'bd690eee0d9e51857448770a151023b0'
'857e174643fd7761a2f0d8431a679f6c'
- 'fe078f9b8ee701ed21278789cad90acf'
+ '11fbec7ff7ca1b0d5575445681e8f60e'
'c6e361131000ceec085f40b310ef4a2c'
'84c884b8dadd724afe2bc6529e9d4485')
diff --git a/abs/core/lighttpd/__changelog b/abs/core/lighttpd/__changelog
index a96d942..0fe6415 100644
--- a/abs/core/lighttpd/__changelog
+++ b/abs/core/lighttpd/__changelog
@@ -4,3 +4,11 @@ modified auth to require valid user (include auth-inc.conf)
# by mihanson:
upgraded to 1.4.26 to address http://linhes.org/flyspray/index.php?do=details&task_id=624
Added -e 's|"^/mythweb|"^/{1,2}mythweb|' \ to the sed command to work around lighttpd no longer honoring // in a url and/or to work around mythweb producing url's with a // for streaming and downloading.
+
+changed lightttpd.conf to user perl for .cgi (needed for monx)_
+added 404 page
+
+bummped to version 13 to test redmine #690
+
+# by mihanson
+Added etc/lighttpd/conf.include and etc/lighttpd/html.include to backup array
diff --git a/abs/core/lighttpd/lighttpd.conf b/abs/core/lighttpd/lighttpd.conf
index 0c55f52..f437484 100644
--- a/abs/core/lighttpd/lighttpd.conf
+++ b/abs/core/lighttpd/lighttpd.conf
@@ -145,7 +145,7 @@ static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )
#server.bind = "127.0.0.1"
## error-handler for status 404
-#server.error-handler-404 = "/error-handler.html"
+server.error-handler-404 = "/404.html"
#server.error-handler-404 = "/error-handler.php"
## to help the rc.scripts
@@ -235,7 +235,7 @@ server.groupname = "http"
)
#### CGI module
cgi.assign = ( ".pl" => "/usr/bin/perl",
- ".cgi" => "/bin/bash" )
+ ".cgi" => "/usr/bin/perl" )
url.rewrite-once = (
"^/mythweb/(css|data|images|js|themes|skins|[a-z_]+\.(php|pl)).*" => "$0",
diff --git a/abs/core/lighttpd/lighttpd.install b/abs/core/lighttpd/lighttpd.install
index 0e32a66..a921b0f 100755
--- a/abs/core/lighttpd/lighttpd.install
+++ b/abs/core/lighttpd/lighttpd.install
@@ -2,6 +2,6 @@ pre_upgrade() {
mv /etc/lighttpd/lighttpd.conf /etc/lighttpd/lighttpd.conf.old
}
post_upgrade() {
- sed -i 's|"^/mythweb|"/{1,2}mythweb|g' /etc/lighttpd/lighttpd.conf
+ sed -i 's|"^/mythweb|"^/{1,2}mythweb|g' /etc/lighttpd/lighttpd.conf
touch /etc/lighttpd/lighttpd.user
}