summaryrefslogtreecommitdiffstats
path: root/abs/core/lighttpd
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-02 22:23:26 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-02 22:23:26 (GMT)
commitef9499bac6cd2664a8ab6269f2419e7e9207a82a (patch)
tree0a6f64d150bace6e5a5a6fba10d7e55d2a7268c0 /abs/core/lighttpd
parent7a0af293fd1a81fb643acbb954d319786035e44e (diff)
downloadlinhes_pkgbuild-ef9499bac6cd2664a8ab6269f2419e7e9207a82a.zip
linhes_pkgbuild-ef9499bac6cd2664a8ab6269f2419e7e9207a82a.tar.gz
linhes_pkgbuild-ef9499bac6cd2664a8ab6269f2419e7e9207a82a.tar.bz2
move mythweb bits out of lighttpd.conf.
The mythweb package now includes it's own include files and will add/remove as required to the lighttpd configuration refs #862 refs #861
Diffstat (limited to 'abs/core/lighttpd')
-rw-r--r--abs/core/lighttpd/PKGBUILD2
-rw-r--r--abs/core/lighttpd/lighttpd.conf95
2 files changed, 2 insertions, 95 deletions
diff --git a/abs/core/lighttpd/PKGBUILD b/abs/core/lighttpd/PKGBUILD
index 1b1316a..2759138 100644
--- a/abs/core/lighttpd/PKGBUILD
+++ b/abs/core/lighttpd/PKGBUILD
@@ -78,5 +78,5 @@ package() {
md5sums=('586eb535d31ac299652495b058dd87c4'
'bd690eee0d9e51857448770a151023b0'
'e17a29ebcdac82a853389c3df468c980'
- '836bc37bb1c59478052026ade7a959bb'
+ 'a690eb8cf0f579cba0b0440ef0f4f6ec'
'c6e361131000ceec085f40b310ef4a2c')
diff --git a/abs/core/lighttpd/lighttpd.conf b/abs/core/lighttpd/lighttpd.conf
index ccc0403..99e493c 100644
--- a/abs/core/lighttpd/lighttpd.conf
+++ b/abs/core/lighttpd/lighttpd.conf
@@ -88,6 +88,7 @@ mimetype.assign = (
".xwd" => "image/x-xwindowdump",
".css" => "text/css",
".html" => "text/html",
+".shtml" => "text/html",
".htm" => "text/html",
".js" => "text/javascript",
".asc" => "text/plain",
@@ -134,8 +135,6 @@ url.access-deny = ( "~", ".inc" )
$HTTP["url"] =~ "\.pdf$" {
server.range-requests = "disable"
}
-#first alias
-
##
# which extensions should not be handle via static-file transfer
#
@@ -249,106 +248,14 @@ $HTTP["url"] =~ "^/cgi-bin" {
cgi.assign = ( "" => "" )
}
-url.rewrite-once = (
- "^/mythweb/(css|data|images|js|themes|skins|[a-z_]+\.(php|pl)).*" => "$0",
- "^/mythweb/(pl(/.*)?)$" => "/mythweb/mythweb.pl/$1",
- "^/mythweb/(.+)$" => "/mythweb/mythweb.php/$1",
- "^/mythweb/(.*)$" => "/mythweb/mythweb.php"
-)
-
-
-
-#### SSL engine
-#ssl.engine = "enable"
-#ssl.pemfile = "/etc/ssl/private/lighttpd.pem"
-
-#### status module
-#status.status-url = "/server-status"
-#status.config-url = "/server-config"
-
-#### auth module
-## read authentication.txt for more info
-#auth.backend = "plain"
-#auth.backend.plain.userfile = "lighttpd.user"
-#auth.backend.plain.groupfile = "lighttpd.group"
-
-#auth.backend.ldap.hostname = "localhost"
-#auth.backend.ldap.base-dn = "dc=my-domain,dc=com"
-#auth.backend.ldap.filter = "(uid=$)"
-
-#auth.require = ( "/mythweb =>
-# (
-# "method" => "plain",
-# "realm" => "download archiv",
-# "require" => "valid-user"
-# )
-# "/server-config" =>
-# (
-# "method" => "digest",
-# "realm" => "download archiv",
-# "require" => "valid-user"
-# )
-# )
-
#### url handling modules (rewrite, redirect, access)
#url.rewrite = ( "^/$" => "/server-status" )
#url.redirect = ( "^/wishlist/(.+)" => "http://www.123.org/$1" )
-#### both rewrite/redirect support back reference to regex conditional using %n
-#$HTTP["host"] =~ "^www\.(.*)" {
-# url.redirect = ( "^/(.*)" => "http://%1/$1" )
-#}
-
-#
-# define a pattern for the host url finding
-# %% => % sign
-# %0 => domain name + tld
-# %1 => tld
-# %2 => domain name without tld
-# %3 => subdomain 1 name
-# %4 => subdomain 2 name
-#
-#evhost.path-pattern = "/srv/http/vhosts/%3/htdocs/"
-
-#### expire module
-#expire.url = ( "/buggy/" => "access 2 hours", "/asdhas/" => "access plus 1 seconds 2 minutes")
-
-#### ssi
-#ssi.extension = ( ".shtml" )
-
-#### rrdtool
-#rrdtool.binary = "/usr/bin/rrdtool"
-#rrdtool.db-name = "/var/lib/lighttpd/lighttpd.rrd"
#### setenv
#setenv.add-request-header = ( "TRAV_ENV" => "mysql://user@host/db" )
#setenv.add-response-header = ( "X-Secret-Message" => "42" )
-## for mod_trigger_b4_dl
-# trigger-before-download.gdbm-filename = "/var/lib/lighttpd/trigger.db"
-# trigger-before-download.memcache-hosts = ( "127.0.0.1:11211" )
-# trigger-before-download.trigger-url = "^/trigger/"
-# trigger-before-download.download-url = "^/download/"
-# trigger-before-download.deny-url = "http://127.0.0.1/index.html"
-# trigger-before-download.trigger-timeout = 10
-
-## for mod_cml
-## don't forget to add index.cml to server.indexfiles
-# cml.extension = ".cml"
-# cml.memcache-hosts = ( "127.0.0.1:11211" )
-
-#### variable usage:
-## variable name without "." is auto prefixed by "var." and becomes "var.bar"
-#bar = 1
-#var.mystring = "foo"
-
-## integer add
-#bar += 1
-## string concat, with integer cast as string, result: "www.foo1.com"
-#server.name = "www." + mystring + var.bar + ".com"
-## array merge
-#index-file.names = (foo + ".php") + index-file.names
-#index-file.names += (foo + ".php")
-
#### include
#include "/etc/lighttpd/auth-inc.conf"
## same as above if you run: "lighttpd -f /etc/lighttpd/lighttpd.conf"