summaryrefslogtreecommitdiffstats
path: root/abs/core/linhes-scripts
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-09-14 21:41:47 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-09-14 21:41:47 (GMT)
commit3c36d806034f2c63d48bf0d7c577969be4155fb7 (patch)
treef30ff13460e4191261642ca94d7dd84d0a5c931d /abs/core/linhes-scripts
parentb96431e7ef2e564879dc1de554d9e36c48f42584 (diff)
downloadlinhes_pkgbuild-3c36d806034f2c63d48bf0d7c577969be4155fb7.zip
linhes_pkgbuild-3c36d806034f2c63d48bf0d7c577969be4155fb7.tar.gz
linhes_pkgbuild-3c36d806034f2c63d48bf0d7c577969be4155fb7.tar.bz2
LinHES-system, linhes-scripts: move idle.sh and xwin_find.sh to LinHES-system.
LinHES-system: add gnu-netcat as dep for idle.sh.
Diffstat (limited to 'abs/core/linhes-scripts')
-rw-r--r--abs/core/linhes-scripts/PKGBUILD8
-rwxr-xr-xabs/core/linhes-scripts/idle.sh147
-rw-r--r--abs/core/linhes-scripts/xwin_find.sh72
3 files changed, 2 insertions, 225 deletions
diff --git a/abs/core/linhes-scripts/PKGBUILD b/abs/core/linhes-scripts/PKGBUILD
index d376bbb..5ccc91a 100644
--- a/abs/core/linhes-scripts/PKGBUILD
+++ b/abs/core/linhes-scripts/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=linhes-scripts
pkgver=7
-pkgrel=52
+pkgrel=53
pkgdesc="Various scripts that help to make LinHES, LinHES."
arch=('i686' 'x86_64')
license=('GPL2')
depends=('xosd' 'cpulimit' 'screen' 'mencoder' 'tablet-encode' 'mplayer'
- 'normalize' 'handbrake-cli' 'mkvtoolnix' 'perl' 'perl-shell' 'gnu-netcat')
+ 'normalize' 'handbrake-cli' 'mkvtoolnix' 'perl' 'perl-shell')
url="http://linhes.org/"
install="linhes-scripts.install"
source=(
@@ -29,7 +29,6 @@ mythwelcome-config.py
pause_mythcommflag
limit-mythcommflag.sh
vdpau-detector
-idle.sh
screenshooter.sh
run-limit-mythcommflag
linhes_update.sh
@@ -44,7 +43,6 @@ myth2fuze
dct700-cc.sh
qip7100-cc.sh
dtheme.sh
-xwin_find.sh
upgrade_screen_rc
upgrade_linhes_script.sh
acl_fix_fstab.py
@@ -87,7 +85,6 @@ md5sums=('47a66238d95259d75c9c5cbcbb6da19f'
'3b776bbff68906ddc2f62b7e0dde3fe4'
'a57641fb63d7bb6d92a438f1ea779a57'
'3d0adf26280cde55a0c47188fff34826'
- 'c3ada01d3a739abe3f920b02d4ea3f6e'
'b2c3dd48a4abb976eda2d5fbf22a173a'
'b527b01d119d3bc33b8fa69bdf1082bb'
'9d077c24d102fa02e4f417d639d8b00a'
@@ -102,7 +99,6 @@ md5sums=('47a66238d95259d75c9c5cbcbb6da19f'
'df727c98350a64e2171c950bbefc9c5d'
'7b890e7044db38e8d439f67e398af206'
'35693f50939d5827aeabfce8c5dce589'
- 'a94fe6d980f4b810f2e2ae5352084b39'
'974c137d3fcb85942ba8945a1bc815fe'
'f454faeabfa153b10389a9a3bfd51c4a'
'cc9cdabcdfc969c2829b58c0e513488c'
diff --git a/abs/core/linhes-scripts/idle.sh b/abs/core/linhes-scripts/idle.sh
deleted file mode 100755
index 4f6174c..0000000
--- a/abs/core/linhes-scripts/idle.sh
+++ /dev/null
@@ -1,147 +0,0 @@
-#!/bin/bash
-
-usage () {
- echo "Usage: $0 [-h] [-s] [-t <minutes_needed>] [-l] [-w] [-m] [-r] [-v]"
- echo
- echo "-h - Print this help/usage message and quit"
- echo "-s - Run silently (default is verbose)"
- echo "-t - Minutes of idle time needed (default is 20)"
- echo "-l - Check for user logins (default: false - do not check)"
- echo "-w - Check for open windows (default: false - do not check)"
- echo "-m - Include mythshutdown daily wake, locked, & about to start wake in system busy"
- echo " (default: daily wake, locked & about to start wake is system idle)"
- echo "-r - Check if mythfrontends are running (default: false - do not check)"
- echo "-v - Be more verbose for debugging"
- echo
- echo "Silent mode is recommended for use in cron jobs or scripts."
- exit $1
-}
-
-msg () { # A status reporting function
- [ "$VERBOSE" -ne 0 ] && echo "$*"
-}
-
-mysql_cmd () {
- /usr/bin/mysql -u root mythconverg -sBe "$*"
-}
-
-# Command line argument handling
-VERBOSE=1
-LOGINS=0
-WINDOWS=0
-DAILY=0
-RUNNING=0
-TIME_BEFORE=20
-TIME_AFTER=5 # Only adjustable by editing here
-
-while getopts "hslwmrt:v" OPT ; do
- case $OPT in
- h) usage 0 ;;
- s) VERBOSE=0 ;;
- t) TIME_BEFORE=$OPTARG ;;
- l) LOGINS=1 ;;
- w) WINDOWS=1 ;;
- m) DAILY=1 ;;
- r) RUNNING=1 ;;
- v) VERBOSE=2 ;;
- *) usage 1 ;;
- esac
-done
-# Check for extra cruft on the command line...
-shift $(($OPTIND - 1))
-[ -n "$*" ] && usage 1
-
-msg "Checking what MythTV is doing now or plans to within $TIME_BEFORE minutes..."
-msg
-
-/usr/bin/mythshutdown --status
-BUSY="$?"
-msg "mythshutdown returned $BUSY"
-if [ "$DAILY" -eq 0 ] ; then
- msg " including daily wake, locked, and about to start wake as system idle"
- # Ignore daily wake, locked and about to start wake flag values
- BUSY=$(($BUSY & 0x2F))
- msg " mythshutdown returned $BUSY"
-fi
-
-SCHEMALOCK=$(mysql_cmd "select count(*) from schemalock")
-msg "schemalock $SCHEMALOCK"
-
-JOBS=$(mysql_cmd "select count(*) from jobqueue where status = 4")
-msg "running jobs $JOBS"
-
-INUSE=$(mysql_cmd "select count(*) from inuseprograms")
-msg "inuse programs $INUSE"
-
-UPCOMING=$(timeout 3 misc_upcoming_recordings.pl --plain_text --text_format "%rs " --heading "" --minutes $TIME_BEFORE --recordings -1 | wc -w)
-msg "planned recordings $UPCOMING"
-if [ "$VERBOSE" -ge 2 ] ; then
- msg
- timeout 3 /usr/LH/bin/misc_upcoming_recordings.pl --plain_text --minutes $TIME_BEFORE --recordings -1
-fi
-
-# Check all host's mythfrontends if they are running and playing
-HOSTNAMES=$(mysql_cmd "select hostname from settings where value = 'FrontendIdleTimeout'")
-FERUNNING=0
-PLAYING=0
-for HOST in $HOSTNAMES
-do
- if [ "$VERBOSE" -ge 2 ]; then
- msg "Checking $HOST's mythfrontend status..."
- fi
-ncOUTPUT=$(timeout 2 nc $HOST 6546 << EOF
-query location
-quit
-EOF
-)
- if [ "$RUNNING" -ge 1 ] ; then
- if [[ "$ncOUTPUT" == *"# "* ]]; then
- FERUNNING=$(( $FERUNNING + 1 ))
- msg "$HOST's mythfrontend is running $FERUNNING"
- else
- msg "$HOST's mythfrontend is NOT running $FERUNNING"
- fi
- fi
- if [[ "$ncOUTPUT" == *"# Playback "* ]]; then
- PLAYING=$(( $PLAYING + 1 ))
- msg "$HOST is playing a recording or video $PLAYING"
- else
- msg "$HOST is NOT playing a recording or video $PLAYING"
- fi
-done
-
-# Check for users logged in
-if [ "$LOGINS" -ge 1 ] ; then
- USERS=`/usr/bin/last | /bin/grep "still logged in" | awk '{ print $1 }'`
- if [ -n "$USERS" ] ; then
- LOGINS=1
- msg "The following user(s) are still logged in:"
- msg "${USERS}"
- else
- LOGINS=0
- msg "No users are logged in $LOGINS"
- fi
-fi
-
-# Check for open windows
-FOUNDWINDOWS=0
-if [ "$WINDOWS" -ge 1 ] ; then
- /usr/LH/bin/xwin_find.sh -q '.*(mythtv@|xterm|Firefox|Namoroka|Opera|Chromium).*'
- FOUNDWINDOWS="$?"
- FOUNDWINDOWS=$(($FOUNDWINDOWS == 0))
- if [ "$FOUNDWINDOWS" -eq 0 ] ; then
- msg "no application windows open $FOUNDWINDOWS"
- else
- msg "one or more application windows open $FOUNDWINDOWS"
- fi
-fi
-
-activities=$(($BUSY + $SCHEMALOCK + $JOBS + $INUSE + $UPCOMING + $FERUNNING + $PLAYING + $LOGINS + $FOUNDWINDOWS))
-msg
-if [ "$activities" -eq 0 ] ; then
- msg "System is idle"
- exit 0
-else
- msg "System is busy"
- exit 1
-fi
diff --git a/abs/core/linhes-scripts/xwin_find.sh b/abs/core/linhes-scripts/xwin_find.sh
deleted file mode 100644
index 35309dd..0000000
--- a/abs/core/linhes-scripts/xwin_find.sh
+++ /dev/null
@@ -1,72 +0,0 @@
-#!/bin/sh
-#
-# xwin_find [-v|-q] [timeout] window_name_regex
-#
-# Look for a window of the windows full name given by a awk regular
-# expression, and print the windows xwindow ID.
-#
-# If a timeout is given (in seconds)continue to look for the windows ID
-# for this amount of time before returning. (EG default a single search)
-#
-# If no such window is found output nothing, just exit
-#
-# OPTIONS
-# -v verbose, print the full matching xwininfo line on stderr
-# -q do not print windows ID on stdout
-#
-####
-# Anthony Thyssen September 2005
-#
-PROGNAME=`type $0 | awk '{print $3}'` # search for executable on path
-PROGDIR=`dirname $PROGNAME` # extract directory of program
-PROGNAME=`basename $PROGNAME` # base name of program
-Usage() {
- echo >&2 "$PROGNAME:" "$@"
- sed >&2 -n '/^###/q; s/^#$/# /; 3s/^#/# Usage:/; 3,$s/^# //p;' \
- "$PROGDIR/$PROGNAME"
- exit 10;
-}
-
-timeout=0
-
-while [ $# -gt 0 ]; do
- case "$1" in
- [0-9]*) timeout=`date +%s`
- timeout=`expr $timeout + $1 + 1` || Usage
- ;;
- -q) QUIET=true ;; # don't print the final window ID, just status
- -v) VERBOSE=true ;; # output the full xwininfo line on stderr
-
- --) shift; break ;; # end of user options
- -*) Usage "Unknown option \"$1\"" ;;
- *) break ;; # end of user options
- esac
- shift # next option
-done
-
-[ $# -lt 1 ] && Usage "Missing window search regex"
-[ $# -gt 1 ] && Usage "Too many arguments."
-
-
-find_win() {
- # nice added to let it give way to starting processes
- if [ "$VERBOSE" ]; then
- line=`nice xwininfo -root -tree | awk '/"'"$1"'":/ {print; exit}'`
- echo >&2 $line # VERBOSE - xwininfo output
- echo "$line" | sed 's/ .*//'
- else
- nice xwininfo -root -tree | awk '/"'"$1"'":/ {print $1; exit}'
- fi
-}
-
-while :; do
- id=`find_win "$1"`
- if [ "$id" ]; then
- [ -z "$QUIET" ] && echo $id # the window ID found
- exit 0;
- fi
- [ `date +%s` -ge $timeout ] && break
-done
-
-exit 1 # window was not found
-