summaryrefslogtreecommitdiffstats
path: root/abs/core/linhes-scripts
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-09-05 15:25:34 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-09-05 15:25:34 (GMT)
commitc33585a62669e9f87553ba090b4714b22d4f220c (patch)
tree65c6cce9c2199fc331ba151f4848b43e29ceb55c /abs/core/linhes-scripts
parentfd2661b53ae89eeaccb92a13917ce3d572474ebf (diff)
downloadlinhes_pkgbuild-c33585a62669e9f87553ba090b4714b22d4f220c.zip
linhes_pkgbuild-c33585a62669e9f87553ba090b4714b22d4f220c.tar.gz
linhes_pkgbuild-c33585a62669e9f87553ba090b4714b22d4f220c.tar.bz2
Merge remote-tracking branch 'origin/testing' into testing
# By Britney Fransen (15) and others # Via Britney Fransen * origin/testing: (22 commits) LinHES-system: mythfrontend-start: revert fork of startcmd LinHES-system: misc_status_config.py: add SystemType check and only update db for Standalone and masterbackend LinHES-system: mythfrontend-start: fork start command so that mythfrontend-start will exit. closes #847 mythtv: fixed and cleaned some menus. Closes #846 v4l-dvb: fix conflicting kernel modules. refs #844 mythdb-initial: add MiscStatusScript value to initial db. refs #845. LinHES-system: remove dup .install keylaunch: update .keylaunchrc to run mythtv-setup as user rsyslog: increase log retention to 2 weeks runit-scripts: enable cron logging to syslog premake:initial inclusion. closes #801 libaacs-git:initial inclusion. closes #801 aacskeys:initial inclusion. closes #801 LinHES-system: Add scripts for misc status in MythWeb. closes #845. linhes-scripts: tweak myth2mkv. Update version to 0.25-004 dvb-firmware: add xc5000c firmware. change xc5000 modprobe options. closes #844 v4l-dvb: update to snapshot from 20120828. refs #844 LinHES-system: update myth_status.py to work with tuners in error. closes #843 curlftpfs: Initial Inclusion. linhes-scripts: minor changes to myth2mkv ... Conflicts: abs/core/LinHES-config/LinHES-release abs/core/LinHES-config/PKGBUILD abs/core/LinHES-system/PKGBUILD abs/core/LinHES-system/mythfrontend-start abs/core/keylaunch/PKGBUILD abs/core/linhes-scripts/PKGBUILD abs/core/mythdb-initial/PKGBUILD abs/core/mythdb-initial/mc.sql abs/core/mythtv/stable-0.25/mythtv/PKGBUILD abs/core/rsyslog/PKGBUILD abs/core/runit-scripts/PKGBUILD
Diffstat (limited to 'abs/core/linhes-scripts')
-rwxr-xr-xabs/core/linhes-scripts/limit-mythcommflag.sh4
-rwxr-xr-xabs/core/linhes-scripts/pause-mythcommflag.sh2
2 files changed, 3 insertions, 3 deletions
diff --git a/abs/core/linhes-scripts/limit-mythcommflag.sh b/abs/core/linhes-scripts/limit-mythcommflag.sh
index 5cd81bb..63a2872 100755
--- a/abs/core/linhes-scripts/limit-mythcommflag.sh
+++ b/abs/core/linhes-scripts/limit-mythcommflag.sh
@@ -48,8 +48,8 @@ cpulimit_pid=0
while true; do
PROCCOMMFLAG=`pidof mythcommflag`
if [ -n "${PROCCOMMFLAG}" ]; then
- BACKENDCPU=`top -bn1u mythtv | grep -m 1 mythbackend | awk '{ print $9 }'`
- FRONTENDCPU=`top -bn1u mythtv | grep -m 1 mythfrontend | awk '{ print $9 }'`
+ BACKENDCPU=`top -bn1u mythtv | grep -m 1 'mythbackend ' | awk '{ print $9 }'`
+ FRONTENDCPU=`top -bn1u mythtv | grep -m 1 'mythfrontend ' | awk '{ print $9 }'`
if [ "$FRONTENDCPU" = "" ]; then
FRONTENDCPU=0
fi
diff --git a/abs/core/linhes-scripts/pause-mythcommflag.sh b/abs/core/linhes-scripts/pause-mythcommflag.sh
index 4da808b..1db6db6 100755
--- a/abs/core/linhes-scripts/pause-mythcommflag.sh
+++ b/abs/core/linhes-scripts/pause-mythcommflag.sh
@@ -29,7 +29,7 @@ while true; do
PROCCOMMFLAG=`pidof mythcommflag`
if [ -n "${PROCCOMMFLAG}" ]
then
- FRONTENDCPU=`top -bn1u mythtv | grep mythfrontend | awk '{ print $9 }'`
+ FRONTENDCPU=`top -bn1u mythtv | grep -m 1 'mythfrontend ' | awk '{ print $9 }'`
if [ $COMMFLAGSTATE -eq 1 ]
then
CPUTHRESHOLD1=$CPUTHRESHOLD