summaryrefslogtreecommitdiffstats
path: root/abs/core/linhes-scripts
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-02-01 01:51:25 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-02-01 01:51:25 (GMT)
commitf5e4d5cd76772c52fe652d4a6472266109298bdd (patch)
tree6506ee810bdec8199445e053529af0a15d38b9ab /abs/core/linhes-scripts
parent5211b30fbeab9533f21e3d320ca1d8494d50a86b (diff)
downloadlinhes_pkgbuild-f5e4d5cd76772c52fe652d4a6472266109298bdd.zip
linhes_pkgbuild-f5e4d5cd76772c52fe652d4a6472266109298bdd.tar.gz
linhes_pkgbuild-f5e4d5cd76772c52fe652d4a6472266109298bdd.tar.bz2
linhes-scripts: myth2mp3, myth2x264, myth2xvid: use mythutil to get cutlist
In mythtv .25 mythcommflag --getcutlist is depreciated Conflicts: abs/core/linhes-scripts/PKGBUILD
Diffstat (limited to 'abs/core/linhes-scripts')
-rw-r--r--abs/core/linhes-scripts/PKGBUILD8
-rwxr-xr-xabs/core/linhes-scripts/myth2mp34
-rwxr-xr-xabs/core/linhes-scripts/myth2x2645
-rwxr-xr-xabs/core/linhes-scripts/myth2xvid7
4 files changed, 13 insertions, 11 deletions
diff --git a/abs/core/linhes-scripts/PKGBUILD b/abs/core/linhes-scripts/PKGBUILD
index 8de4c88..c325101 100644
--- a/abs/core/linhes-scripts/PKGBUILD
+++ b/abs/core/linhes-scripts/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=linhes-scripts
pkgver=7
-pkgrel=49
+pkgrel=50
pkgdesc="Various scripts that help to make LinHES, LinHES."
arch=('i686' 'x86_64')
license=('GPL2')
@@ -71,17 +71,17 @@ build() {
install -m644 -D pause_mythcommflag $startdir/pkg/etc/logrotate.d/pause_mythcommflag
}
-md5sums=('f56985b2d602e11dc1e10d3e7848b2a5'
+md5sums=('47a66238d95259d75c9c5cbcbb6da19f'
'10ad1a4da669adccd01e0be6e5e4a3ed'
'9ae2cd7a0c42d57ad8b5f515d7d60196'
'1274bad3fb7296f00acd2d44804bad14'
'47225fa9b6c953d56f6ede84d921a300'
'6b6e7d34a4bda6d608d150039adefd07'
- 'f8df7665903ddf822f5148bc8a074e4a'
+ '4a1fda884dcd7d65fb2690fbdbd92a83'
'18263972b6326e140bbef0bb7dfa2da9'
'410795ef9039e4c6c0484e706ecfd567'
'ad98d51e79f83df7c03f828dbeaea7f4'
- 'ac2a4a6b4100f4d7bfb9ecd9356c8c6e'
+ '3b1c44a0818b35b6939c3cb2b723ce9e'
'd2b475821f902c5e081e7da43a35e6ac'
'95c092f67036a361ef7a57436f44332e'
'92950f0ffb1faf1ed64c6be2b8fbc3f6'
diff --git a/abs/core/linhes-scripts/myth2mp3 b/abs/core/linhes-scripts/myth2mp3
index 5ce72c1..69d5d3f 100755
--- a/abs/core/linhes-scripts/myth2mp3
+++ b/abs/core/linhes-scripts/myth2mp3
@@ -1,6 +1,6 @@
#!/bin/sh
# convert recordings to as mp3 audio only
-# version 1.1.2
+# version 1.1.3
# usage:
# first parameter must be %DIR%/%FILE% of the recording
@@ -37,7 +37,7 @@ beforetime="$(date +%s)"
# check if using cutlist
if [ $USECUTLIST = Y ];then
- MYTHCOMMFRAMES=`mythcommflag --getcutlist -f "$FFINPUTFILE" | grep 'Cutlist:' | cut -d \ -f 2`
+ MYTHCOMMFRAMES=`mythutil --getcutlist --chanid "$3" --starttime "$4" | grep 'Cutlist:' | cut -d \ -f 2`
if [ -n "$MYTHCOMMFRAMES" ]; then
echo "Extracting Cutlist..." >> $LOGFILE
/usr/bin/nice -n19 /usr/bin/mythtranscode --chanid "$3" --starttime "$4" --outfile "$TMPCUTFILE" --mpeg2 --honorcutlist
diff --git a/abs/core/linhes-scripts/myth2x264 b/abs/core/linhes-scripts/myth2x264
index 014fcbe..4c234d5 100755
--- a/abs/core/linhes-scripts/myth2x264
+++ b/abs/core/linhes-scripts/myth2x264
@@ -1,6 +1,7 @@
#!/bin/sh
# convert recording to x264 encoded avi
-# version 0.6
+# version 0.7
+# consider using myth2mkv instead of this script
# usage:
# first parameter must be %DIR%/%FILE% of the recording
@@ -154,7 +155,7 @@ check_myth_jobcmds
# check if using cutlist
if [ $USECUTLIST = Y ]; then
- MYTHCOMMFRAMES=`mythcommflag --getcutlist -f $MENINPUTFILE | grep 'Cutlist:' | cut -d \ -f 2`
+ MYTHCOMMFRAMES=`mythutil --getcutlist --chanid "$3" --starttime "$4" | grep 'Cutlist:' | cut -d \ -f 2`
if [ -n "$MYTHCOMMFRAMES" ]; then
echo "Extracting Cutlist..." >> $LOGFILE
update_comment "Extracting Cutlist"
diff --git a/abs/core/linhes-scripts/myth2xvid b/abs/core/linhes-scripts/myth2xvid
index d0fcb42..033026d 100755
--- a/abs/core/linhes-scripts/myth2xvid
+++ b/abs/core/linhes-scripts/myth2xvid
@@ -1,6 +1,7 @@
#!/bin/sh
# convert recording to xvid encoded avi
-# version 1.3
+# version 1.4
+# consider using myth2mkv instead of this script
# usage:
# first parameter must be %DIR%/%FILE% of the recording
@@ -154,7 +155,7 @@ check_myth_jobcmds
# check if using cutlist
if [ $USECUTLIST = Y ]; then
- MYTHCOMMFRAMES=`mythcommflag --getcutlist -f $MENINPUTFILE | grep 'Cutlist:' | cut -d \ -f 2`
+ MYTHCOMMFRAMES=`mythutil --getcutlist --chanid "$3" --starttime "$4" | grep 'Cutlist:' | cut -d \ -f 2`
if [ -n "$MYTHCOMMFRAMES" ]; then
echo "Extracting Cutlist..." >> $LOGFILE
update_comment "Extracting Cutlist"
@@ -220,4 +221,4 @@ else
echo "ERROR: $ERROR" >> $LOGFILE
fi
-clean_up_files \ No newline at end of file
+clean_up_files