summaryrefslogtreecommitdiffstats
path: root/abs/core/linhes-theme
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-09-23 18:25:05 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-09-23 18:25:05 (GMT)
commitc448687a1bb25b3bec0f424c8dc0ab1a41d12681 (patch)
treef4dec53d794ca9e4970e0ab6ce456cfbb0c902dc /abs/core/linhes-theme
parent91fbd154061ff8b53cc7eb647e64b72a67c562b2 (diff)
downloadlinhes_pkgbuild-c448687a1bb25b3bec0f424c8dc0ab1a41d12681.zip
linhes_pkgbuild-c448687a1bb25b3bec0f424c8dc0ab1a41d12681.tar.gz
linhes_pkgbuild-c448687a1bb25b3bec0f424c8dc0ab1a41d12681.tar.bz2
linhes-theme: change all corner radius to macth selected buttons
show channel icon when there is no coverart.
Diffstat (limited to 'abs/core/linhes-theme')
-rw-r--r--abs/core/linhes-theme/PKGBUILD6
-rw-r--r--abs/core/linhes-theme/base.xml.patch76
-rw-r--r--abs/core/linhes-theme/osd.xml.patch31
3 files changed, 105 insertions, 8 deletions
diff --git a/abs/core/linhes-theme/PKGBUILD b/abs/core/linhes-theme/PKGBUILD
index 33e2c49..cb85af5 100644
--- a/abs/core/linhes-theme/PKGBUILD
+++ b/abs/core/linhes-theme/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=linhes-theme
pkgver=8.2
-pkgrel=3
+pkgrel=4
pkgdesc="Default LinHES MythTV theme"
arch=('i686' 'x86_64')
license=('GPL2')
@@ -77,8 +77,8 @@ package() {
sed -i "s/MIN_VER/${array[1]}${pkgrel}/" $pkgdir/$THEMEROOT/LinHES/themeinfo.xml
}
md5sums=('2dca856c2a4d1f959473512c94e43b60'
- 'ed4f8baf431e20babc345e4e2602426f'
- 'cb8c0d63392f6c8c2d8219243fbf47c6'
+ '51e11c48dc73467f7c94644b6db1b840'
+ '71f4fa39d7fefe5443ef0f7bd6820ccd'
'c75c83b90969fb07755062113f858e88'
'9fe3371a8b964a7028126405cfaa330b'
'5a8fb2a5f0e657d52be6f0a6a006ce72'
diff --git a/abs/core/linhes-theme/base.xml.patch b/abs/core/linhes-theme/base.xml.patch
index 588ce42..13aba27 100644
--- a/abs/core/linhes-theme/base.xml.patch
+++ b/abs/core/linhes-theme/base.xml.patch
@@ -1,5 +1,14 @@
---- base.xml.orig 2014-01-02 20:11:41.055260777 +0000
-+++ base.xml 2014-01-22 01:11:14.443221510 +0000
+--- base.xml.orig 2014-09-23 18:09:09.984607409 +0000
++++ base.xml 2014-09-23 18:09:22.626356280 +0000
+@@ -411,7 +411,7 @@
+ <area>283,436,50,11</area>
+ <type>roundbox</type>
+ <fill color="#000000" alpha="200" />
+- <cornerradius>90</cornerradius>
++ <cornerradius>5</cornerradius>
+ </shape>
+
+ <shape name="base_backdrop_line">
@@ -424,7 +424,7 @@
<!-- Base definition of a base popup backdrop -->
@@ -9,3 +18,66 @@
</shape>
<!-- Base definition of a heading group -->
+@@ -863,7 +863,7 @@
+ <type>roundbox</type>
+ <fill color="#1a1a1a" alpha="175" />
+ <line color="#454545" alpha="180" width="2" />
+- <cornerradius>90</cornerradius>
++ <cornerradius>5</cornerradius>
+ </shape>
+ <shape name="select_bar_top_highlight">
+ <area>0,0,100%,2</area>
+@@ -956,7 +956,7 @@
+ <type>roundbox</type>
+ <fill color="#333333" alpha="175" />
+ <line color="#454545" alpha="180" width="2" />
+- <cornerradius>90</cornerradius>
++ <cornerradius>5</cornerradius>
+ </shape>
+ </group>
+
+@@ -967,7 +967,7 @@
+ <type>roundbox</type>
+ <fill color="#1a1a1a" alpha="175" />
+ <line color="#454545" alpha="180" width="2" />
+- <cornerradius>90</cornerradius>
++ <cornerradius>5</cornerradius>
+ </shape>
+ <shape name="select_bar_top_highlight">
+ <area>0,0,100%,2</area>
+@@ -1060,7 +1060,7 @@
+ <type>roundbox</type>
+ <fill color="#333333" alpha="175" />
+ <line color="#454545" alpha="180" width="2" />
+- <cornerradius>90</cornerradius>
++ <cornerradius>5</cornerradius>
+ </shape>
+ </group>
+
+@@ -1071,7 +1071,7 @@
+ <type>roundbox</type>
+ <fill color="#1a1a1a" alpha="175" />
+ <line color="#454545" alpha="180" width="2" />
+- <cornerradius>90</cornerradius>
++ <cornerradius>5</cornerradius>
+ </shape>
+ <shape name="select_bar_top_highlight">
+ <area>0,0,100%,2</area>
+@@ -1164,7 +1164,7 @@
+ <type>roundbox</type>
+ <fill color="#1a1a1a" alpha="175" />
+ <line color="#454545" alpha="180" width="2" />
+- <cornerradius>90</cornerradius>
++ <cornerradius>5</cornerradius>
+ </shape>
+ </group>
+
+@@ -1233,7 +1233,7 @@
+ <type>roundbox</type>
+ <fill color="#333333" alpha="175" />
+ <line color="#454545" alpha="180" width="2" />
+- <cornerradius>90</cornerradius>
++ <cornerradius>5</cornerradius>
+ </shape>
+ </group>
+
diff --git a/abs/core/linhes-theme/osd.xml.patch b/abs/core/linhes-theme/osd.xml.patch
index 67748f7..b6cb761 100644
--- a/abs/core/linhes-theme/osd.xml.patch
+++ b/abs/core/linhes-theme/osd.xml.patch
@@ -1,6 +1,29 @@
---- osd.xml.orig 2014-01-02 19:56:57.605092545 +0000
-+++ osd.xml 2014-01-02 20:02:34.958563960 +0000
-@@ -996,12 +996,12 @@
+--- osd.xml.orig 2014-09-23 17:43:57.630552593 +0000
++++ osd.xml 2014-09-23 17:46:50.325639736 +0000
+@@ -975,19 +975,19 @@
+ <template>%LONGREPEAT% Size: %FILESIZE_STR%</template>
+ </textarea>
+
+- <textarea name="channum">
++ <textarea name="channum" depends="!coverart">
+ <font>large</font>
+ <area>68,490,162,46</area>
+ <align>allcenter</align>
+ </textarea>
+
+- <textarea name="callsign">
++ <textarea name="callsign" depends="!coverart">
+ <font>large</font>
+ <area>68,634,162,46</area>
+ <align>allcenter</align>
+ </textarea>
+
+- <imagetype name="iconpath">
++ <imagetype name="iconpath" depends="!coverart">
+ <area>84,536,130,98</area>
+ <preserveaspect>true</preserveaspect>
+ <mask>images/osd/masks/osd_program_icon_mask.png</mask>
+@@ -996,12 +996,14 @@
<!-- Commit 6216029d2 makes this show up in both recordings and video. -->
<!-- Since I only want it in video and there is no way to control it. I have no choice but to disable it. -->
@@ -8,6 +31,8 @@
+
<imagetype name="coverart">
<area>70,492,158,186</area>
++ <preserveaspect>true</preserveaspect>
++ <mask>images/masks/watchrecordings_coverart_mask.png</mask>
<alpha>255</alpha>
</imagetype>
--->