summaryrefslogtreecommitdiffstats
path: root/abs/core/linhes-theme
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-10-10 20:53:25 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-10-10 20:53:25 (GMT)
commitd4b8c5c7d1c30c71c85d0e36251e9af14c78879e (patch)
tree5c36455395d447bcc0cb43410d4a5ed261979a52 /abs/core/linhes-theme
parentc7c8f1084db0c6fd7fd517562b24090823a0f73f (diff)
downloadlinhes_pkgbuild-d4b8c5c7d1c30c71c85d0e36251e9af14c78879e.zip
linhes_pkgbuild-d4b8c5c7d1c30c71c85d0e36251e9af14c78879e.tar.gz
linhes_pkgbuild-d4b8c5c7d1c30c71c85d0e36251e9af14c78879e.tar.bz2
linhes-theme: modify notifications
add channel to osd when coverart is shown add recording input to info
Diffstat (limited to 'abs/core/linhes-theme')
-rwxr-xr-xabs/core/linhes-theme/PKGBUILD25
-rwxr-xr-xabs/core/linhes-theme/checkmark.pngbin0 -> 24628 bytes
-rwxr-xr-xabs/core/linhes-theme/error.pngbin0 -> 16172 bytes
-rwxr-xr-xabs/core/linhes-theme/gears.pngbin0 -> 24505 bytes
-rw-r--r--abs/core/linhes-theme/notification-ui.xml.patch361
-rw-r--r--abs/core/linhes-theme/osd.xml.patch69
-rw-r--r--abs/core/linhes-theme/progdetails_page1.html.patch10
-rw-r--r--abs/core/linhes-theme/progdetails_page2.html.patch10
-rwxr-xr-xabs/core/linhes-theme/question.pngbin0 -> 25883 bytes
-rwxr-xr-xabs/core/linhes-theme/warning.pngbin0 -> 5436 bytes
10 files changed, 452 insertions, 23 deletions
diff --git a/abs/core/linhes-theme/PKGBUILD b/abs/core/linhes-theme/PKGBUILD
index 7b0506c..d317765 100755
--- a/abs/core/linhes-theme/PKGBUILD
+++ b/abs/core/linhes-theme/PKGBUILD
@@ -1,18 +1,21 @@
pkgname=linhes-theme
pkgver=8.4
-pkgrel=7
+pkgrel=8
pkgdesc="Default LinHES MythTV theme"
arch=('i686' 'x86_64')
license=('GPL2')
url="http://linhes.org/"
patches=('readme.txt.patch' 'osd.xml.patch' 'base.xml.patch'
- 'menu-ui-vert.xml.patch' 'schedule-ui.xml.patch' 'qtlook.txt.patch'
+ 'menu-ui-vert.xml.patch' 'notification-ui.xml.patch'
+ 'schedule-ui.xml.patch' 'qtlook.txt.patch'
'recordings-ui.xml.patch' 'video-ui.xml.patch')
#The LinHES theme is based on TintedGlass 4.56 by Harley Peters
source=(`echo ${patches[@]:0}` 'themeinfo.xml' 'install-ui.xml' 'osd_subtitle.xml'
'bubble_background.png' 'preview.png' 'blank_coverart.png'
+ 'checkmark.png' 'error.png' 'gears.png' 'question.png' 'warning.png'
+ 'progdetails_page1.html.patch' 'progdetails_page2.html.patch'
'LHLogo.png' 'LHLogoAndText.png')
install=$pkgname.install
@@ -49,6 +52,9 @@ package() {
patch -N -i ${srcdir}/$i || return 1
echo "-----------------------------"
done
+ cd $pkgdir/$THEMEROOT/LinHES/htmls/
+ patch -N -i ${srcdir}/progdetails_page1.html.patch || return 1
+ patch -N -i ${srcdir}/progdetails_page2.html.patch || return 1
cd $startdir
msg "--------------------------done applying patches-------------------------"
@@ -57,6 +63,11 @@ package() {
rm -r $pkgdir/$THEMEROOT/LinHES/images/backgrounds/*
rsync -pL $srcdir/bubble_background.png $pkgdir/$THEMEROOT/LinHES/images/backgrounds/background.png
rsync -pL $srcdir/blank_coverart.png $pkgdir/$THEMEROOT/LinHES/images/
+ rsync -pL $srcdir/checkmark.png $pkgdir/$THEMEROOT/LinHES/images/
+ rsync -pL $srcdir/error.png $pkgdir/$THEMEROOT/LinHES/images/
+ rsync -pL $srcdir/gears.png $pkgdir/$THEMEROOT/LinHES/images/
+ rsync -pL $srcdir/question.png $pkgdir/$THEMEROOT/LinHES/images/
+ rsync -pL $srcdir/warning.png $pkgdir/$THEMEROOT/LinHES/images/
rsync -pL $srcdir/preview.png $pkgdir/$THEMEROOT/LinHES/
#tux_thoughts.png is the thought bubble for the menu descriptions
@@ -84,9 +95,10 @@ package() {
sed -i "s/MIN_VER/${array[1]}${pkgrel}/" $pkgdir/$THEMEROOT/LinHES/themeinfo.xml
}
md5sums=('2dca856c2a4d1f959473512c94e43b60'
- '985f76e26a526e0727ec7afc44cf9b8c'
+ '0d95c596b460de777e12b89da0bf2e19'
'f2b9c85519e80843294315a42870e582'
'43b1f213fd392fb07aac503e775e27bc'
+ '80bb72994eca59ca6dc9034ac185e7cc'
'22ff4044c8c29560451fb51dcbf4d44e'
'9fe3371a8b964a7028126405cfaa330b'
'e88dc1587a164aaa15b280cb66f6a82b'
@@ -97,5 +109,12 @@ md5sums=('2dca856c2a4d1f959473512c94e43b60'
'326a71eb795b322a9ea26f116d890c87'
'8fcd0acc11f4db33a9442949fb1a293d'
'699e3abe05523f454db3561bfc08b4b2'
+ '60cb915909c477dbc2e18233ee6424d9'
+ '30ea7d2001b8562177b8f85f34f050a2'
+ 'e8dee86a10ce7c4423a97305b38b4668'
+ 'e8ac15e38b3dc99c9e889e439ba356de'
+ 'e8cf0d3a55ba3be47deae55c05432141'
+ '759c9f34ecc6b9039e00fc12b384dd7b'
+ 'd331710be0dab8cbec77c70278f92146'
'b51ef0cbf8ed2d3a8c1a8257a89aceff'
'09ad14842f828b7a8d24070ec8214fe5')
diff --git a/abs/core/linhes-theme/checkmark.png b/abs/core/linhes-theme/checkmark.png
new file mode 100755
index 0000000..0c8ba2d
--- /dev/null
+++ b/abs/core/linhes-theme/checkmark.png
Binary files differ
diff --git a/abs/core/linhes-theme/error.png b/abs/core/linhes-theme/error.png
new file mode 100755
index 0000000..d5ccc2d
--- /dev/null
+++ b/abs/core/linhes-theme/error.png
Binary files differ
diff --git a/abs/core/linhes-theme/gears.png b/abs/core/linhes-theme/gears.png
new file mode 100755
index 0000000..b2f78d6
--- /dev/null
+++ b/abs/core/linhes-theme/gears.png
Binary files differ
diff --git a/abs/core/linhes-theme/notification-ui.xml.patch b/abs/core/linhes-theme/notification-ui.xml.patch
new file mode 100644
index 0000000..98b1287
--- /dev/null
+++ b/abs/core/linhes-theme/notification-ui.xml.patch
@@ -0,0 +1,361 @@
+--- notification-ui.xml.orig 2016-10-10 19:55:20.796354375 +0000
++++ notification-ui.xml 2016-10-10 19:40:05.992756927 +0000
+@@ -3,11 +3,9 @@
+
+ <mythuitheme>
+
+- <baseres>1280x720</baseres>
+-
+ <window name="notification">
+
+- <area>-1,36,780,180</area>
++ <area>800,24,470,136</area>
+
+ <animation trigger="AboutToShow">
+ <section>
+@@ -24,83 +22,79 @@
+ </animation>
+
+ <shape name="notification-backdrop" from="base_popup_backdrop">
+- <area>0,0,780,180</area>
++ <area>0,0,470,122</area>
+ </shape>
+
+ <shape name="notification-backdrop-line" from="base_backdrop_line">
+- <area>1,1,778,178</area>
++ <area>1,1,468,120</area>
+ </shape>
+
+ <shape name="notification-top-line" from="base_highlight_line">
+- <area>2,2,776,2</area>
++ <area>2,2,466,2</area>
+ </shape>
+
+ <shape name="notification-bottom-line" from="base_highlight_line">
+- <area>1,176,776,2</area>
++ <area>1,118,466,2</area>
+ </shape>
+
+ <shape name="notification-left-line" from="base_highlight_vertical_line">
+- <area>2,4,2,170</area>
++ <area>2,4,2,112</area>
+ </shape>
+
+ <shape name="notification-right-line" from="base_highlight_vertical_line">
+- <area>776,4,2,170</area>
++ <area>466,4,2,112</area>
+ </shape>
+
+ <textarea name="title" from="basetextarea" depends="progress">
+- <area>14,18,752,35</area>
+- <font>basemediumlargerbold</font>
++ <area>14,11,438,35</area>
++ <font>basemediumlargeryellow</font>
++ <scroll direction="left" startdelay="1"/>
+ </textarea>
+
+ <textarea name="title_noprogress" from="basetextarea" depends="!progress">
+- <area>14,11,752,35</area>
+- <font>basemediumlargerbold</font>
++ <area>14,11,438,35</area>
++ <font>basemediumlargeryellow</font>
+ <template>%TITLE%</template>
++ <scroll direction="left" startdelay="1"/>
+ </textarea>
+
+ <textarea name="origin" from="basetextarea" depends="progress">
+- <area>14,53,752,30</area>
++ <area>14,46,438,30</area>
+ <font>basesomewhatsmaller</font>
++ <scroll direction="left" startdelay="1"/>
++ <template>[%ORIGIN%] %DESCRIPTION%</template>
+ </textarea>
+
+ <textarea name="origin_noprogress" from="basetextarea" depends="!progress">
+- <area>14,46,752,30</area>
+- <font>basesomewhatsmaller</font>
+- <template>%ORIGIN%</template>
+- </textarea>
+-
+- <textarea name="description" from="basetextarea" depends="progress">
+- <area>14,83,752,30</area>
++ <area>14,46,438,30</area>
+ <font>basesomewhatsmaller</font>
++ <scroll direction="left" startdelay="1"/>
++ <template>[%ORIGIN%]</template>
+ </textarea>
+
+ <textarea name="description_noprogress" from="basetextarea" depends="!progress">
+- <area>14,76,752,90</area>
++ <area>14,76,438,30</area>
+ <font>basesomewhatsmaller</font>
+- <multiline>yes</multiline>
+ <align>left,top</align>
++ <scroll direction="left" startdelay="1"/>
+ <template>%DESCRIPTION%</template>
+ </textarea>
+
+- <textarea name="extra" from="basetextarea" depends="progress">
+- <area>14,113,300,30</area>
+- <font>basesomewhatsmaller</font>
+- </textarea>
+-
+ <textarea name="progress_text" from="basetextarea" depends="progress">
+- <area>370,113,396,30</area>
++ <area>14,80,206,30</area>
+ <font>basesomewhatsmaller</font>
+ <align>right</align>
++ <scroll direction="left" startdelay="1"/>
+ </textarea>
+
+ <progressbar name="progress" from="baseprogressbar">
+- <position>14,148</position>
++ <position>230,90</position>
+ <imagetype name="background">
+- <area>0,0,752,10</area>
++ <area>0,0,226,10</area>
+ <filename>images/progressbar/progressbar_background.png</filename>
+ </imagetype>
+ <imagetype name="progressimage">
+- <area>0,0,752,10</area>
++ <area>0,0,220,10</area>
+ <filename>images/progressbar/progressbar_fill.png</filename>
+ </imagetype>
+ </progressbar>
+@@ -109,7 +103,7 @@
+
+ <window name="notification-image">
+
+- <area>-1,36,780,180</area>
++ <area>800,24,470,136</area>
+
+ <animation trigger="AboutToShow">
+ <section>
+@@ -126,31 +120,31 @@
+ </animation>
+
+ <shape name="notification-image-backdrop" from="base_popup_backdrop">
+- <area>0,0,780,180</area>
++ <area>0,0,470,122</area>
+ </shape>
+
+ <shape name="notification-image-backdrop-line" from="base_backdrop_line">
+- <area>1,1,778,178</area>
++ <area>1,1,468,120</area>
+ </shape>
+
+ <shape name="notification-image-top-line" from="base_highlight_line">
+- <area>2,2,776,2</area>
++ <area>2,2,466,2</area>
+ </shape>
+
+ <shape name="notification-image-bottom-line" from="base_highlight_line">
+- <area>1,176,776,2</area>
++ <area>1,118,466,2</area>
+ </shape>
+
+ <shape name="notification-image-left-line" from="base_highlight_vertical_line">
+- <area>2,4,2,170</area>
++ <area>2,4,2,112</area>
+ </shape>
+
+ <shape name="notification-image-right-line" from="base_highlight_vertical_line">
+- <area>776,4,2,170</area>
++ <area>466,4,2,112</area>
+ </shape>
+
+ <shape name="image-border">
+- <area>14,14,152,152</area>
++ <area>352,4,114,114</area>
+ <type>roundbox</type>
+ <fill color="#000000" alpha="0" />
+ <line color="#AAAAAA" alpha="100" width="2" />
+@@ -163,9 +157,9 @@
+ <state name="noartwork">
+ <area>0,0,100%,100%</area>
+ <imagetype name="imageartwork">
+- <filename>images/no_artwork.png</filename>
++ <filename>images/question.png</filename>
+ <mask>images/masks/notification_image_mask.png</mask>
+- <area>18,18,144,144</area>
++ <area>356,8,106,106</area>
+ </imagetype>
+ </state>
+ </statetype>
+@@ -178,15 +172,15 @@
+ <imagetype name="imageerror">
+ <filename>images/error.png</filename>
+ <mask>images/masks/notification_image_mask.png</mask>
+- <area>18,18,144,144</area>
++ <area>356,8,106,106</area>
+ </imagetype>
+ </state>
+ <state name="check">
+ <area>0,0,100%,100%</area>
+ <imagetype name="imageerror">
+- <filename>images/check.png</filename>
++ <filename>images/checkmark.png</filename>
+ <mask>images/masks/notification_image_mask.png</mask>
+- <area>18,18,144,144</area>
++ <area>356,8,106,106</area>
+ </imagetype>
+ </state>
+ <state name="warning">
+@@ -194,65 +188,60 @@
+ <imagetype name="imageerror">
+ <filename>images/warning.png</filename>
+ <mask>images/masks/notification_image_mask.png</mask>
+- <area>18,18,144,144</area>
++ <area>356,8,106,106</area>
+ </imagetype>
+ </state>
+ <state name="busy">
+ <area>0,0,100%,100%</area>
+ <imagetype name="imagebusy">
+- <filename>images/busy.png</filename>
++ <filename>images/gears.png</filename>
+ <mask>images/masks/notification_image_mask.png</mask>
+- <area>18,18,144,144</area>
++ <area>356,8,106,106</area>
+ </imagetype>
+ </state>
+ </statetype>
+
+ <imagetype name="image" depends="!mediastate&amp;!errorstate">
+- <filename>images/damaged.png</filename>
++ <filename>images/error.png</filename>
+ <mask>images/masks/notification_image_mask.png</mask>
+- <area>18,18,144,144</area>
++ <area>356,8,106,106</area>
+ </imagetype>
+
+ <textarea name="title" from="basetextarea" depends="progress">
+- <area>170,18,598,35</area>
+- <font>basemediumlargerbold</font>
++ <area>14,11,324,35</area>
++ <font>basemediumlargeryellow</font>
++ <scroll direction="left" startdelay="1"/>
+ </textarea>
+
+ <textarea name="title_noprogress" from="basetextarea" depends="!progress">
+- <area>170,11,598,35</area>
+- <font>basemediumlargerbold</font>
++ <area>14,11,324,35</area>
++ <font>basemediumlargeryellow</font>
++ <scroll direction="left" startdelay="1"/>
+ <template>%TITLE%</template>
+ </textarea>
+
+ <textarea name="origin" from="basetextarea" depends="progress">
+- <area>170,53,598,30</area>
++ <area>14,46,324,30</area>
+ <font>basesomewhatsmaller</font>
++ <scroll direction="left" startdelay="1"/>
++ <template>[%ORIGIN%] %DESCRIPTION%</template>
+ </textarea>
+
+ <textarea name="origin_noprogress" from="basetextarea" depends="!progress">
+- <area>170,46,598,30</area>
++ <area>14,46,324,30</area>
+ <font>basesomewhatsmaller</font>
+- <template>%ORIGIN%</template>
++ <scroll direction="left" startdelay="1"/>
++ <template>[%ORIGIN%]</template>
+ </textarea>
+
+- <textarea name="description" from="basetextarea" depends="progress">
+- <area>170,83,598,30</area>
+- <font>basesomewhatsmaller</font>
+- </textarea>
+-
+ <textarea name="description_noprogress" from="basetextarea" depends="!progress">
+- <area>170,76,598,90</area>
++ <area>14,76,324,30</area>
+ <font>basesomewhatsmaller</font>
+- <multiline>yes</multiline>
+ <align>left,top</align>
++ <scroll direction="left" startdelay="1"/>
+ <template>%DESCRIPTION%</template>
+ </textarea>
+
+- <textarea name="extra" from="basetextarea" depends="progress">
+- <area>170,113,300,30</area>
+- <font>basesomewhatsmaller</font>
+- </textarea>
+-
+ <textarea name="progress_text" from="basetextarea" depends="progress">
+ <area>370,113,398,30</area>
+ <font>basesomewhatsmaller</font>
+@@ -283,12 +272,12 @@
+ </shape>
+
+ <statetype name="mediastate">
+- <area>0,0,100%,100%</area>
++ <area>0,0,100%,65%</area>
+ <state name="ok"/>
+ <state name="noartwork">
+ <area>0,0,100%,100%</area>
+ <imagetype name="imageartwork">
+- <filename>images/no_artwork_fullscreen.png</filename>
++ <filename>images/question.png</filename>
+ <area>0,0,100%,100%</area>
+ <preserveaspect>true</preserveaspect>
+ </imagetype>
+@@ -296,12 +285,12 @@
+ </statetype>
+
+ <statetype name="errorstate">
+- <area>0,0,100%,100%</area>
++ <area>0,0,100%,65%</area>
+ <state name="ok"/>
+ <state name="error">
+ <area>0,0,100%,100%</area>
+ <imagetype name="imageerror">
+- <filename>images/error_fullscreen.png</filename>
++ <filename>images/error.png</filename>
+ <area>0,0,100%,100%</area>
+ <preserveaspect>true</preserveaspect>
+ </imagetype>
+@@ -309,7 +298,7 @@
+ <state name="check">
+ <area>0,0,100%,100%</area>
+ <imagetype name="imageerror">
+- <filename>images/check_fullscreen.png</filename>
++ <filename>images/checkmark.png</filename>
+ <area>0,0,100%,100%</area>
+ <preserveaspect>true</preserveaspect>
+ </imagetype>
+@@ -317,7 +306,7 @@
+ <state name="warning">
+ <area>0,0,100%,100%</area>
+ <imagetype name="imageerror">
+- <filename>images/warning_fullscreen.png</filename>
++ <filename>images/warning.png</filename>
+ <area>0,0,100%,100%</area>
+ <preserveaspect>true</preserveaspect>
+ </imagetype>
+@@ -325,22 +314,16 @@
+ <state name="busy">
+ <area>0,0,100%,100%</area>
+ <imagetype name="imagebusy">
+- <filename>images/busy_fullscreen.png</filename>
++ <filename>images/gears.png</filename>
+ <area>0,0,100%,100%</area>
+ <preserveaspect>true</preserveaspect>
+ </imagetype>
+ </state>
+ </statetype>
+
+- <imagetype name="image" depends="!mediastate&amp;!errorstate">
+- <filename>images/damaged_fullscreen.png</filename>
+- <area>0,0,100%,100%</area>
+- <preserveaspect>true</preserveaspect>
+- </imagetype>
+-
+ <textarea name="title" from="basetextarea">
+ <area>170,475,940,45</area>
+- <font>baseextralargebold</font>
++ <font>baseextralargeyellow</font>
+ </textarea>
+
+ <textarea name="origin" from="basetextarea">
diff --git a/abs/core/linhes-theme/osd.xml.patch b/abs/core/linhes-theme/osd.xml.patch
index cf0dfa9..efe4838 100644
--- a/abs/core/linhes-theme/osd.xml.patch
+++ b/abs/core/linhes-theme/osd.xml.patch
@@ -1,5 +1,5 @@
---- osd.xml.orig 2016-04-13 19:13:53.605408871 +0000
-+++ osd.xml 2016-04-14 22:00:37.243291623 +0000
+--- osd.xml.orig 2016-10-10 19:48:08.091427236 +0000
++++ osd.xml 2016-10-10 19:40:05.992756927 +0000
@@ -7,13 +7,13 @@
<window name="osd_debug">
<area>0,0,1280,720</area>
@@ -186,17 +186,17 @@
- <area>90,658,1100,24</area>
+ <textarea name="value">
+ <area>90,657,1100,24</area>
- <font>small</font>
- <align>allcenter</align>
-- <template>%DESCRIPTION%
-- %(|REMAININGTIME|)%%(|BEHINDTIME|)%%VALUE%%UNITS%</template>
++ <font>small</font>
++ <align>allcenter</align>
+ <template>%VALUE%%UNITS%</template>
+ </textarea>
+
+ <textarea name="playedtime" depends="!value">
+ <area>90,657,1100,24</area>
-+ <font>small</font>
-+ <align>allcenter</align>
+ <font>small</font>
+ <align>allcenter</align>
+- <template>%DESCRIPTION%
+- %(|REMAININGTIME|)%%(|BEHINDTIME|)%%VALUE%%UNITS%</template>
+ <template>%PLAYEDTIME% of %TOTALTIME%
+ %(|REMAININGTIME| remains)%%(|BEHINDTIME| behind)%</template>
</textarea>
@@ -252,7 +252,36 @@
</fontdef>
<shape name="program-info-backdrop">
-@@ -1015,25 +1022,30 @@
+@@ -988,7 +995,7 @@
+ <alpha>255</alpha>
+ </imagetype>
+
+- <textarea name="category">
++ <textarea name="category">
+ <font>supersmallblue</font>
+ <area>284,490,912,28</area>
+ <align>allcenter</align>
+@@ -1003,37 +1010,49 @@
+ <template>%"|SUBTITLE|" %%YEARSTARS| %%DESCRIPTION%</template>
+ </textarea>
+
+- <textarea name="programid">
++ <textarea name="programid" depends="iconpath&amp;!coverart">
+ <font>supersmallblue</font>
+ <area>284,653,912,27</area>
+ <align>allcenter</align>
+ <template>Season/Episode: %s00e00% ProgramID: %PROGRAMID% SeriesID: %SERIESID%</template>
+ </textarea>
+
++ <textarea name="channame" depends="iconpath&amp;coverart">
++ <font>supersmallblue</font>
++ <area>284,653,912,27</area>
++ <align>allcenter</align>
++ <template>Channel: %channum% - %channame% - %callsign% Season/Episode: %s00e00% ProgramID: %PROGRAMID% SeriesID: %SERIESID%</template>
++ </textarea>
++
+ </window>
+
<window name="browse_info">
<area>0,0,1280,720</area>
@@ -289,7 +318,7 @@
</fontdef>
<shape name="browse-info-backdrop">
-@@ -1084,7 +1096,7 @@
+@@ -1084,7 +1103,7 @@
</shape>
<shape name="title-backdrop-line">
@@ -298,7 +327,7 @@
<type>roundbox</type>
<fill color="#000000" alpha="0" />
<line color="#ffffff" alpha="45" width="2" />
-@@ -1092,11 +1104,11 @@
+@@ -1092,11 +1111,11 @@
</shape>
<shape name="title-top-line" from="channel-top-line">
@@ -312,7 +341,7 @@
</shape>
<shape name="title-left-line" from="channel-left-line">
-@@ -1104,30 +1116,6 @@
+@@ -1104,30 +1123,6 @@
</shape>
<shape name="title-right-line" from="channel-left-line">
@@ -343,7 +372,7 @@
<area>1212,492,2,62</area>
</shape>
-@@ -1175,30 +1163,30 @@
+@@ -1175,30 +1170,30 @@
</textarea>
<textarea name="title">
@@ -381,7 +410,7 @@
</clock>
<textarea name="description">
-@@ -1214,9 +1202,9 @@
+@@ -1214,9 +1209,9 @@
<window name="ChannelEditor">
<area>0,0,1280,720</area>
@@ -393,7 +422,7 @@
</fontdef>
<fontdef name="smallblack" from="small">
-@@ -1224,7 +1212,7 @@
+@@ -1224,7 +1219,7 @@
</fontdef>
<fontdef name="smallblue" from="small">
@@ -402,7 +431,7 @@
</fontdef>
<fontdef name="smallgrey" from="small">
-@@ -1232,7 +1220,7 @@
+@@ -1232,7 +1227,7 @@
</fontdef>
<fontdef name="medium" from="small">
@@ -411,7 +440,7 @@
</fontdef>
<shape name="channel-editor-backdrop">
-@@ -1610,9 +1598,9 @@
+@@ -1610,9 +1605,9 @@
<window name="osd_program_editor">
<area>0,0,1280,720</area>
@@ -423,7 +452,7 @@
</fontdef>
<shape name="osd-program-editor-backdrop">
-@@ -1663,13 +1651,17 @@
+@@ -1663,13 +1658,17 @@
</shape>
<textarea name="title">
@@ -444,7 +473,7 @@
<align>right,vcenter</align>
</textarea>
-@@ -1749,9 +1741,9 @@
+@@ -1749,9 +1748,9 @@
<window name="MythPopupBox">
<area>0,0,1280,720</area>
@@ -456,7 +485,7 @@
</fontdef>
<fontdef name="smallgrey" from="small">
-@@ -1759,7 +1751,7 @@
+@@ -1759,7 +1758,7 @@
</fontdef>
<fontdef name="smallyellow" from="small">
diff --git a/abs/core/linhes-theme/progdetails_page1.html.patch b/abs/core/linhes-theme/progdetails_page1.html.patch
new file mode 100644
index 0000000..1098733
--- /dev/null
+++ b/abs/core/linhes-theme/progdetails_page1.html.patch
@@ -0,0 +1,10 @@
+--- progdetails_page1.html.orig 2016-10-10 19:58:30.445542674 +0000
++++ progdetails_page1.html 2016-10-10 19:59:13.280088646 +0000
+@@ -42,6 +42,7 @@
+ <h2>%WATCH_LIST_STATUS_LABEL%</h2> <p>%WATCH_LIST_STATUS%</p>
+ <h2>%FINDID_LABEL%</h2> <p>%FINDID%</p>
+ <h2>%RECORDING_HOST_LABEL%</h2> <p>%RECORDING_HOST%</p>
++ <h2>%RECORDING_INPUT_LABEL%</h2> <p>%RECORDING_INPUT%</p>
+ </div>
+ <div class="col">
+ <h2>%ACTORS_LABEL%</h2> <p>%ACTORS%</p>
diff --git a/abs/core/linhes-theme/progdetails_page2.html.patch b/abs/core/linhes-theme/progdetails_page2.html.patch
new file mode 100644
index 0000000..bd1703d
--- /dev/null
+++ b/abs/core/linhes-theme/progdetails_page2.html.patch
@@ -0,0 +1,10 @@
+--- htmls/progdetails_page2.html.orig 2016-10-10 19:59:43.816200423 +0000
++++ htmls/progdetails_page2.html 2016-10-10 19:59:22.072302460 +0000
+@@ -42,6 +42,7 @@
+ <h2>%WATCH_LIST_STATUS_LABEL%</h2> <p>%WATCH_LIST_STATUS%</p>
+ <h2>%FINDID_LABEL%</h2> <p>%FINDID%</p>
+ <h2>%RECORDING_HOST_LABEL%</h2> <p>%RECORDING_HOST%</p>
++ <h2>%RECORDING_INPUT_LABEL%</h2> <p>%RECORDING_INPUT%</p>
+ </div>
+ <div class="col">
+ <h2>%ACTORS_LABEL%</h2> <p>%ACTORS%</p>
diff --git a/abs/core/linhes-theme/question.png b/abs/core/linhes-theme/question.png
new file mode 100755
index 0000000..1eda678
--- /dev/null
+++ b/abs/core/linhes-theme/question.png
Binary files differ
diff --git a/abs/core/linhes-theme/warning.png b/abs/core/linhes-theme/warning.png
new file mode 100755
index 0000000..047cac5
--- /dev/null
+++ b/abs/core/linhes-theme/warning.png
Binary files differ