summaryrefslogtreecommitdiffstats
path: root/abs/core/linux-atm
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/linux-atm
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/linux-atm')
-rw-r--r--abs/core/linux-atm/PKGBUILD25
-rw-r--r--abs/core/linux-atm/linux-atm-2.5.0-glibc28.patch11
2 files changed, 36 insertions, 0 deletions
diff --git a/abs/core/linux-atm/PKGBUILD b/abs/core/linux-atm/PKGBUILD
new file mode 100644
index 0000000..18cd3c8
--- /dev/null
+++ b/abs/core/linux-atm/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 13520 2008-09-27 14:40:44Z tpowa $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: Surain Mallawa Arachchi <mas@crc32.net>
+
+pkgname=linux-atm
+pkgver=2.5.0
+pkgrel=1
+pkgdesc="Drivers and tools to support ATM networking under Linux."
+arch=('i686' 'x86_64')
+depends=('glibc')
+source=(http://heanet.dl.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz \
+ linux-atm-2.5.0-glibc28.patch)
+url="http://linux-atm.sourceforge.net/"
+license=(GPL)
+options=(!libtool)
+md5sums=('0b45a0e801fac7093ce4b0cadf419965'
+ '2e195df66995d2feb9ccc602cbf399b2')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ patch -Np1 -i ../linux-atm-2.5.0-glibc28.patch || return 1
+ ./configure --prefix=/usr --sysconfdir=/etc || return 1
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+}
diff --git a/abs/core/linux-atm/linux-atm-2.5.0-glibc28.patch b/abs/core/linux-atm/linux-atm-2.5.0-glibc28.patch
new file mode 100644
index 0000000..692f316
--- /dev/null
+++ b/abs/core/linux-atm/linux-atm-2.5.0-glibc28.patch
@@ -0,0 +1,11 @@
+diff -up linux-atm-2.5.0/src/led/main.c.path_max linux-atm-2.5.0/src/led/main.c
+--- linux-atm-2.5.0/src/led/main.c.path_max 2008-05-19 02:47:40.000000000 +0900
++++ linux-atm-2.5.0/src/led/main.c 2008-05-19 02:47:52.000000000 +0900
+@@ -41,6 +41,7 @@
+ #include <getopt.h>
+ #include <errno.h>
+ #include <fcntl.h>
++#include <linux/limits.h>
+
+ #include <atm.h>
+ #include <atmd.h>