summaryrefslogtreecommitdiffstats
path: root/abs/core/linux/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-03-01 15:11:57 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-03-01 15:11:57 (GMT)
commit58d3a94bb072ffed302555ef674ba2f0794e398c (patch)
tree1cf1bca8c8b5b89134fd45e40a571bce3418dc5c /abs/core/linux/PKGBUILD
parentc69233b362d5957604fc63edd56d717641c8518d (diff)
downloadlinhes_pkgbuild-58d3a94bb072ffed302555ef674ba2f0794e398c.zip
linhes_pkgbuild-58d3a94bb072ffed302555ef674ba2f0794e398c.tar.gz
linhes_pkgbuild-58d3a94bb072ffed302555ef674ba2f0794e398c.tar.bz2
linux: update to 4.4.3
Diffstat (limited to 'abs/core/linux/PKGBUILD')
-rw-r--r--abs/core/linux/PKGBUILD40
1 files changed, 14 insertions, 26 deletions
diff --git a/abs/core/linux/PKGBUILD b/abs/core/linux/PKGBUILD
index d54233d..f69c7f1 100644
--- a/abs/core/linux/PKGBUILD
+++ b/abs/core/linux/PKGBUILD
@@ -5,8 +5,8 @@
pkgbase=linux # Build stock -ARCH kernel
#pkgbase=linux-custom # Build kernel with a different name
_srcname=linux-4.4
-pkgver=4.4
-pkgrel=5
+pkgver=4.4.3
+pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
@@ -14,17 +14,14 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
- #"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
- #"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
+ "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
+ "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
# the main kernel config files
'config' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
'linux.preset'
'change-default-console-loglevel.patch'
- '0001-sdhci-revert.patch'
- 'tpmdd-devel-v3-base-platform-fix-binding-for-drivers-without-probe-callback.patch'
- 'CVE-2016-0728.patch'
- 'suspend-xfs.patch')
+ '0001-sdhci-revert.patch')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -37,7 +34,7 @@ prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
- #patch -p1 -i "${srcdir}/patch-${pkgver}"
+ patch -p1 -i "${srcdir}/patch-${pkgver}"
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
@@ -47,22 +44,11 @@ prepare() {
# https://bugzilla.kernel.org/show_bug.cgi?id=106541
patch -Rp1 -i "${srcdir}/0001-sdhci-revert.patch"
- # fixes #47805 kernel panics on platform modules
- # https://bugzilla.kernel.org/show_bug.cgi?id=110751
- patch -Np1 -i "${srcdir}/tpmdd-devel-v3-base-platform-fix-binding-for-drivers-without-probe-callback.patch"
-
- # fixes #47820 CVE-2016-0728.patch
- patch -Np1 -i "${srcdir}/CVE-2016-0728.patch"
-
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -p1 -i "${srcdir}/change-default-console-loglevel.patch"
- # fix suspend with xfs
- # http://oss.sgi.com/pipermail/xfs/2016-January/046036.html
- patch -Np1 --ignore-whitespace -i "${srcdir}/suspend-xfs.patch"
-
if [ "${CARCH}" = "x86_64" ]; then
cat "${srcdir}/config.x86_64" > ./.config
else
@@ -156,6 +142,9 @@ _package() {
mkdir -p "${pkgdir}/usr"
mv "${pkgdir}/lib" "${pkgdir}/usr/"
+ #remove nouveau
+ find $pkgdir/usr/lib -name "nouvea*" -exec rm -f {} \;
+
# add vmlinux
install -D -m644 vmlinux "${pkgdir}/usr/lib/modules/${_kernver}/build/vmlinux"
}
@@ -307,11 +296,10 @@ done
# vim:set ts=8 sts=2 sw=2 et:
md5sums=('9a78fa2eb6c68ca5a40ed5af08142599'
'SKIP'
- '11117629de25c921ad42f949c5133b96'
- '8afd1ad1a2454a4daed71fc91a7a3fbc'
+ '078427483ee96f3e072e7b5409b5a117'
+ 'SKIP'
+ 'be50f82adaeb685d41eb55acd1b09134'
+ 'd254ffa0b91d459529ec23a1cdeceb35'
'eb14dcfd80c00852ef81ded6e826826a'
'df7fceae6ee5d7e7be7b60ecd7f6bb35'
- 'e1093d9bc718f362344ab56b85d4fb76'
- 'a00ad770d2a49a282a8bbf951852c2a1'
- 'c018da62d8f3a48e8a8985a1af43185d'
- '0e3f4e1ec0ae38a30852e4b7af9de693')
+ 'e1093d9bc718f362344ab56b85d4fb76')