summaryrefslogtreecommitdiffstats
path: root/abs/core/linux
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-03-30 16:47:22 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-03-30 16:47:22 (GMT)
commit2b006c4a34629b3bcc50b78a920c94cf88a6459a (patch)
treef6448ad5f0f287c0d46cb462eebad5e971651aee /abs/core/linux
parent58140b41ba67ea9929d17493c7b76c508d8fe9c1 (diff)
downloadlinhes_pkgbuild-2b006c4a34629b3bcc50b78a920c94cf88a6459a.zip
linhes_pkgbuild-2b006c4a34629b3bcc50b78a920c94cf88a6459a.tar.gz
linhes_pkgbuild-2b006c4a34629b3bcc50b78a920c94cf88a6459a.tar.bz2
linux: update to 4.4.58
Diffstat (limited to 'abs/core/linux')
-rw-r--r--abs/core/linux/99-linux.hook11
-rw-r--r--abs/core/linux/PKGBUILD67
-rw-r--r--abs/core/linux/linux.install4
-rw-r--r--abs/core/linux/linux.install.pkg6
4 files changed, 44 insertions, 44 deletions
diff --git a/abs/core/linux/99-linux.hook b/abs/core/linux/99-linux.hook
new file mode 100644
index 0000000..9851151
--- /dev/null
+++ b/abs/core/linux/99-linux.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Target = boot/vmlinuz-%PKGBASE%
+Target = usr/lib/initcpio/*
+
+[Action]
+Description = Updating %PKGBASE% initcpios
+When = PostTransaction
+Exec = /usr/bin/mkinitcpio -p %PKGBASE%
diff --git a/abs/core/linux/PKGBUILD b/abs/core/linux/PKGBUILD
index 5b8d3ae..65d831a 100644
--- a/abs/core/linux/PKGBUILD
+++ b/abs/core/linux/PKGBUILD
@@ -1,43 +1,30 @@
# $Id$
-# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
-# Maintainer: Thomas Baechler <thomas@archlinux.org>
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
-pkgbase=linux # Build stock -ARCH kernel
-#pkgbase=linux-custom # Build kernel with a different name
+pkgbase=linux
+#pkgbase=linux-custom
_srcname=linux-4.4
-pkgver=4.4.39
+pkgver=4.4.58
pkgrel=1
arch=('i686' 'x86_64')
-url="http://www.kernel.org/"
+url="https://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
-source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
- "https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
- "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
- "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
+source=(https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.{xz,sign}
+ https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.{xz,sign}
# the main kernel config files
'config' 'config.x86_64'
+ # pacman hook for initramfs regeneration
+ '99-linux.hook'
# standard config files for mkinitcpio ramdisk
- 'linux.preset'
- 'change-default-console-loglevel.patch'
- '0001-sdhci-revert.patch')
-
-sha256sums=('401d7c8fef594999a460d10c72c5a94e9c2e1022f16795ec51746b0d165418b2'
- 'SKIP'
- 'fc2b60d221aeaf3eafec4f36f299e4002be81da85117c3f59963fdcb6facb929'
- 'SKIP'
- 'fbbae1d873900e84d1b7ef00593fbb94fc79f078a34b22ee824bab8b0a92be64'
- '756a168bbc3bb582f0df45b977c32af53658f21d62fe15171c9ac85f52d8852a'
- 'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
- '1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
- '5313df7cb5b4d005422bd4cd0dae956b2dadba8f3db904275aaf99ac53894375')
-
-validpgpkeys=(
- 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
- '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
+ linux.preset
+ change-default-console-loglevel.patch
+ 0001-sdhci-revert.patch)
+# https://www.kernel.org/pub/linux/kernel/v4.x/sha256sums.asc
+validpgpkeys=('ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds <torvalds@linux-foundation.org>
+ '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman (Linux kernel stable release signing key) <greg@kroah.com>
)
-
_kernelname=${pkgbase#linux}
prepare() {
@@ -48,7 +35,7 @@ prepare() {
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
-
+
# revert http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9faac7b95ea4f9e83b7a914084cc81ef1632fd91
# fixes #47778 sdhci broken on some boards
# https://bugzilla.kernel.org/show_bug.cgi?id=106541
@@ -135,6 +122,10 @@ _package() {
-e "s|fallback_image=.*|fallback_image=\"/boot/initramfs-${pkgbase}-fallback.img\"|" \
-i "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
+ # install pacman hook for initramfs regeneration
+ sed "s|%PKGBASE%|${pkgbase}|g" "${srcdir}/99-linux.hook" |
+ install -D -m644 /dev/stdin "${pkgdir}/usr/share/libalpm/hooks/99-${pkgbase}.hook"
+
# remove build and source links
rm -f "${pkgdir}"/lib/modules/${_kernver}/{source,build}
# remove the firmware
@@ -156,7 +147,7 @@ _package() {
find $pkgdir/usr/lib -name "nouvea*" -exec rm -f {} \;
# add vmlinux
- install -D -m644 vmlinux "${pkgdir}/usr/lib/modules/${_kernver}/build/vmlinux"
+ install -D -m644 vmlinux "${pkgdir}/usr/lib/modules/${_kernver}/build/vmlinux"
}
_package-headers() {
@@ -248,8 +239,6 @@ _package-headers() {
# add xfs and shmem for aufs building
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/fs/xfs"
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/mm"
- # removed in 3.17 series
- # cp fs/xfs/xfs_sb.h "${pkgdir}/usr/lib/modules/${_kernver}/build/fs/xfs/xfs_sb.h"
# copy in Kconfig files
for i in $(find . -name "Kconfig*"); do
@@ -275,7 +264,7 @@ _package-headers() {
# remove unneeded architectures
rm -rf "${pkgdir}"/usr/lib/modules/${_kernver}/build/arch/{alpha,arc,arm,arm26,arm64,avr32,blackfin,c6x,cris,frv,h8300,hexagon,ia64,m32r,m68k,m68knommu,metag,mips,microblaze,mn10300,openrisc,parisc,powerpc,ppc,s390,score,sh,sh64,sparc,sparc64,tile,unicore32,um,v850,xtensa}
- # remove a files already in linux-docs package
+ # remove files already in linux-docs package
rm -f "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/kbuild/Kconfig.recursion-issue-01"
rm -f "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/kbuild/Kconfig.recursion-issue-02"
rm -f "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/kbuild/Kconfig.select-break"
@@ -302,5 +291,13 @@ for _p in ${pkgname[@]}; do
_package${_p#${pkgbase}}
}"
done
-
-# vim:set ts=8 sts=2 sw=2 et:
+md5sums=('9a78fa2eb6c68ca5a40ed5af08142599'
+ 'SKIP'
+ '152561e51e76089c5b045f8c0257f9d5'
+ 'SKIP'
+ 'be50f82adaeb685d41eb55acd1b09134'
+ 'd254ffa0b91d459529ec23a1cdeceb35'
+ '90cd68710e3064d9b65f5549570f7821'
+ 'eb14dcfd80c00852ef81ded6e826826a'
+ 'df7fceae6ee5d7e7be7b60ecd7f6bb35'
+ 'e1093d9bc718f362344ab56b85d4fb76')
diff --git a/abs/core/linux/linux.install b/abs/core/linux/linux.install
index dd2fa5c..15dc8b6 100644
--- a/abs/core/linux/linux.install
+++ b/abs/core/linux/linux.install
@@ -8,8 +8,6 @@ post_install () {
# updating module dependencies
echo ">>> Updating module dependencies. Please wait ..."
depmod ${KERNEL_VERSION}
- echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
- mkinitcpio -p linux${KERNEL_NAME}
}
post_upgrade() {
@@ -20,8 +18,6 @@ post_upgrade() {
# updating module dependencies
echo ">>> Updating module dependencies. Please wait ..."
depmod ${KERNEL_VERSION}
- echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
- mkinitcpio -p linux${KERNEL_NAME}
if [ $(vercmp $2 3.13) -lt 0 ]; then
echo ">>> WARNING: AT keyboard support is no longer built into the kernel."
diff --git a/abs/core/linux/linux.install.pkg b/abs/core/linux/linux.install.pkg
index 90e9fbb..80ccf2c 100644
--- a/abs/core/linux/linux.install.pkg
+++ b/abs/core/linux/linux.install.pkg
@@ -2,14 +2,12 @@
# arg 2: the old package version
KERNEL_NAME=
-KERNEL_VERSION=4.4.39-1-ARCH
+KERNEL_VERSION=4.4.58-1-ARCH
post_install () {
# updating module dependencies
echo ">>> Updating module dependencies. Please wait ..."
depmod ${KERNEL_VERSION}
- echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
- mkinitcpio -p linux${KERNEL_NAME}
}
post_upgrade() {
@@ -20,8 +18,6 @@ post_upgrade() {
# updating module dependencies
echo ">>> Updating module dependencies. Please wait ..."
depmod ${KERNEL_VERSION}
- echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
- mkinitcpio -p linux${KERNEL_NAME}
if [ $(vercmp $2 3.13) -lt 0 ]; then
echo ">>> WARNING: AT keyboard support is no longer built into the kernel."