summaryrefslogtreecommitdiffstats
path: root/abs/core/lirc
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
commit2648e999d277eac5c3d331a3609bcc73fafbea71 (patch)
tree40951fb8e7fdbe28a0baa324ae615055203f1e2e /abs/core/lirc
parentc759b5e0c4aa6fc37412b4dee2cf9ad993fd376d (diff)
parent7e6f7ca174e1af67178dc5293a312a4a733eb095 (diff)
downloadlinhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.zip
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.gz
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.bz2
Merge branch 'testing'
# By James Meyer (1091) and others # Via James Meyer (5) and others * testing: (1148 commits) LinHES-config: during install don't kill off lirc. This keeps the remote active all the way to the finish Change version numbers to 8.0 to match the release number. LinHES-conifg LinHES-system mythdb-initial runit-scripts supplemental-web LinHES-conifig: mv_install.py for the last partition don't go all the way to the end. Gotta leave room for gpt tables. xf86-video-ati: xorg ati driver. LinHES-config: timezip.py add syncing up of parental lvl passwords and starting level with MBE. LinHES-system: correct the logic for breaking out of the wmctrl loop. As written it would break out of the inner loop..but not the 60 iteration loop. e16_theme_settings: remove slide-in prop for new windows. For whatever reason this was preventing mplayer from being positioned correctly for appletrailers. LinHES-config, mythinstall: change case of hd_pvr and serial to all lower refs #902 zilog-firmware: firmware for TX support of the hdpvr and pvr-150 In general I can't recommend anybody using these transmitters but including the firmware just in case someone really wants to linhes-udev-rules: added hdprv_lirc rule. All of these lirc rules are limited to exactly one device. If more then one device is present then only the last device in init will get the symlink runit-scripts: fix logging for igdeamon, add support to remote init script so that the blaster is always the first device in the chain. added support specificly for hd_pvr LinHES-system: add lh_system_restore and lh_system_backup. These scripts are called from the mythmenu. refs #900 iguanair: rebuild with python 2.7 LinHES-system: msg_daemon.py fix init and nasty bug related to timeout. In a nutshell timeout wouldn't work unless a msg without a timeout was called first. linhes-udev-rules: add rules for mce,streamzap,serial lirc devices. mythinstall: recompile for matching libs mythtv: latest .25-fixes and change mythbackup/restore call lh_system_$op to replace mythbackup/mythrestore. mythbackup no longer works correctly with the new windowmanager linhes-scripts: myth2mp3, myth2x264, myth2xvid: use mythutil to get cutlist LinHES-config, supplimental-web: Fix proxy numbering for Ceton infiniTV linhes-system: add additional stuff to the system backup and also introduced an exclude file. The exclude/include files are locate in /home/mythtv/backup_config/ ...
Diffstat (limited to 'abs/core/lirc')
-rw-r--r--abs/core/lirc/PKGBUILD45
-rw-r--r--abs/core/lirc/__changelog2
-rw-r--r--abs/core/lirc/irexec.service11
-rw-r--r--abs/core/lirc/lirc-utils.install7
-rw-r--r--abs/core/lirc/lirc.install22
-rw-r--r--abs/core/lirc/lirc.lr6
-rw-r--r--abs/core/lirc/lirc.service11
-rw-r--r--abs/core/lirc/lirc.tmpfiles1
-rw-r--r--abs/core/lirc/lirc_imon.conf2
-rw-r--r--abs/core/lirc/lircm.service11
10 files changed, 71 insertions, 47 deletions
diff --git a/abs/core/lirc/PKGBUILD b/abs/core/lirc/PKGBUILD
index 0ce8b69..956b1e5 100644
--- a/abs/core/lirc/PKGBUILD
+++ b/abs/core/lirc/PKGBUILD
@@ -1,26 +1,30 @@
-# $Id: PKGBUILD 127217 2011-06-11 09:10:14Z ibiru $
+# $Id: PKGBUILD 170041 2012-10-31 07:25:00Z tpowa $
# Maintainer: Paul Mattal <paul@archlinux.org>
pkgbase=lirc
pkgname=('lirc' 'lirc-utils')
pkgver=0.9.0
-pkgrel=10
-#epoch=1
-_kernver=2.6.39-LinHES
+pkgrel=34
+epoch=1
+_extramodules=extramodules-3.6-ARCH
arch=('i686' 'x86_64')
url="http://www.lirc.org/"
license=('GPL')
-makedepends=('help2man' 'kernel26-headers>=2.6.39' 'kernel26-headers<2.6.40' 'alsa-lib' 'libx11' 'libftdi' 'libirman' 'python' )
+### NOTICE don't forget to bump version in depends in package_lirc
+makedepends=('help2man' 'linux-headers>=3.6' 'linux-headers<3.7' 'alsa-lib' 'libx11' 'libftdi' 'libirman' 'python2' 'iguanair')
options=('!makeflags' '!strip')
source=(http://prdownloads.sourceforge.net/${pkgbase}/${pkgbase}-${pkgver}.tar.bz2
lirc_wpc8769l.patch
lircd-handle-large-config.patch
lirc_atiusb-kfifo.patch
kernel-2.6.39.patch
- lircd lircmd lirc.lr lircd.conf irexec.conf irexecd
- lirc_imon.conf)
+ lircd lircmd lirc.logrotate lircd.conf irexec.conf irexecd
+ lirc.service lircm.service irexec.service
+ lirc.tmpfiles
+ )
build() {
+ _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
cd "${srcdir}/lirc-${pkgver}"
patch -Np1 -i "${srcdir}/lirc_wpc8769l.patch"
patch -Np1 -i "${srcdir}/lircd-handle-large-config.patch"
@@ -37,7 +41,7 @@ build() {
PYTHON=python2 ./configure --enable-sandboxed --prefix=/usr \
--with-driver=all --with-kerneldir=/usr/src/linux-${_kernver}/ \
- --with-moduledir=/lib/modules/${_kernver}/kernel/drivers/misc \
+ --with-moduledir=/usr/lib/modules/${_kernver}/kernel/drivers/misc \
--with-transmitter
# Remove drivers already in kernel
@@ -50,15 +54,15 @@ build() {
package_lirc() {
pkgdesc="Linux Infrared Remote Control kernel modules for stock arch kernel"
- depends=('lirc-utils' 'kernel26>=2.6.39' 'kernel26<2.6.40' 'iguanair')
+ depends=('lirc-utils' 'linux>=3.6' 'linux<3.7' 'iguanair')
replaces=('lirc+pctv')
install=lirc.install
cd "${srcdir}/lirc-${pkgver}/drivers"
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" moduledir="/usr/lib/modules/${_extramodules}" install
# set the kernel we've built for inside the install script
- sed -i -e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/g" "${startdir}/lirc.install"
+ sed -i -e "s/EXTRAMODULES=.*/EXTRAMODULES=${_extramodules}/g" "${startdir}/lirc.install"
# gzip -9 modules
find "${pkgdir}" -name '*.ko' -exec gzip -9 {} \;
}
@@ -69,16 +73,21 @@ package_lirc-utils() {
optdepends=('python2: pronto2lirc utility')
options=('strip' '!libtool')
backup=('etc/conf.d/lircd.conf' 'etc/conf.d/irexec.conf')
+ install=lirc-utils.install
cd "${srcdir}/lirc-${pkgver}"
make DESTDIR="${pkgdir}" install
install -d "${pkgdir}/usr/share/lirc" "${pkgdir}/etc/rc.d"
cp "${srcdir}"/{lircd,lircmd,irexecd} "${pkgdir}/etc/rc.d"
+ install -D -m644 "${srcdir}"/lirc.service "${pkgdir}"/usr/lib/systemd/system/lirc.service
+ install -D -m644 "${srcdir}"/lircm.service "${pkgdir}"/usr/lib/systemd/system/lircm.service
+ install -D -m644 "${srcdir}"/irexec.service "${pkgdir}"/usr/lib/systemd/system/irexec.service
+ install -D -m644 "${srcdir}"/lirc.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/lirc.conf
cp -rp remotes "${pkgdir}/usr/share/lirc"
chmod -R go-w "${pkgdir}/usr/share/lirc/"
# install the logrotate config
- install -Dm644 "${srcdir}/lirc.lr" "${pkgdir}/etc/logrotate.d/lirc"
+ install -Dm644 "${srcdir}/lirc.logrotate" "${pkgdir}/etc/logrotate.d/lirc"
# install conf.d file
install -Dm644 "${srcdir}/lircd.conf" "${pkgdir}/etc/conf.d/lircd.conf"
@@ -88,11 +97,8 @@ package_lirc-utils() {
install -d "${pkgdir}/etc/lirc"
- # install IMON VFD module options
- install -Dm644 ${srcdir}/lirc_imon.conf ${pkgdir}/etc/modprobe.d/lirc_imon.conf
-
# remove built modules
- rm -r "${pkgdir}/lib/"
+ rm -r "${pkgdir}/usr/lib/modules"
}
md5sums=('b232aef26f23fe33ea8305d276637086'
'1cce37e18e3f6f46044abab29016d18f'
@@ -101,8 +107,11 @@ md5sums=('b232aef26f23fe33ea8305d276637086'
'087a7d102e1c96bf1179f38db2b0b237'
'8d0e238dc0eda95e340fe570605da492'
'85f7fdac55e5256967241864049bf5e9'
- '33905430f163432d70e66e593dc4ca5a'
+ '3deb02604b37811d41816e9b4385fcc3'
'5b1f8c9cd788a39a6283f93302ce5c6e'
'f0c0ac930326168035f0c8e24357ae55'
'69d099e6deedfa3c1ee2b6e82d9b8bfb'
- '56f1d74bd20edd96c8e2f2687b124341')
+ 'dab8a73bcc5fd5479d8750493d8d97dc'
+ 'c2e20fe68b034df752dba2773db16ebe'
+ '07131d117fcfe9dcd50c453c3a5e9531'
+ 'febf25c154a7d36f01159e84f26c2d9a')
diff --git a/abs/core/lirc/__changelog b/abs/core/lirc/__changelog
index adf3fd6..19c9302 100644
--- a/abs/core/lirc/__changelog
+++ b/abs/core/lirc/__changelog
@@ -1 +1 @@
-Add iguanair to the list of depends
+added 'iguanair' to make depends and package depends
diff --git a/abs/core/lirc/irexec.service b/abs/core/lirc/irexec.service
new file mode 100644
index 0000000..5d7915b
--- /dev/null
+++ b/abs/core/lirc/irexec.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=IR Exec
+After=lirc.service
+Wants=lirc.service
+
+[Service]
+ExecStart=/usr/bin/irexec --daemon
+Type=forking
+
+[Install]
+WantedBy=multi-user.target
diff --git a/abs/core/lirc/lirc-utils.install b/abs/core/lirc/lirc-utils.install
new file mode 100644
index 0000000..293d1ed
--- /dev/null
+++ b/abs/core/lirc/lirc-utils.install
@@ -0,0 +1,7 @@
+post_install() {
+ systemd-tmpfiles --create lirc.conf
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/abs/core/lirc/lirc.install b/abs/core/lirc/lirc.install
index ba2c957..a9f1c5c 100644
--- a/abs/core/lirc/lirc.install
+++ b/abs/core/lirc/lirc.install
@@ -1,31 +1,13 @@
-KERNEL_VERSION=2.6.39-LinHES
+EXTRAMODULES=extramodules-3.6-ARCH
post_install() {
# updating module dependencies
echo ">>> Updating module dependencies. Please wait ..."
- depmod $KERNEL_VERSION > /dev/null 2>&1
+ depmod $(cat /usr/lib/modules/$EXTRAMODULES/version) > /dev/null 2>&1
}
post_upgrade() {
post_install
-
- . /etc/systemconfig
-
- # Fix LircSocket in mythtv database
- SOCKET=`mysql -u mythtv -pmythtv -B --skip-column-names -h "${dbhost}" -D mythconverg -e \
- "SELECT data FROM settings WHERE value = 'LircSocket' AND hostname = '${hostname}';"`
- if [ "${SOCKET}" != "/var/run/lirc/lircd" ]; then
- mysql -u mythtv -pmythtv -B --skip-column-names -h "${dbhost}" -D mythconverg -e \
- "UPDATE settings SET data = '/var/run/lirc/lircd' WHERE value = 'LircSocket' AND hostname = '${hostname}';"
- else
- echo ">>>"
- echo ">>> ATTENTION! ATTENTION! ATTENTION!"
- echo ">>> Unable to connect the the MySQL database to make needed"
- echo ">>> changes to the LIRC socket."
- echo ">>> LIRC now uses /var/run/lirc/lircd and /dev/lirc is now"
- echo ">>> obsolete. Update your MythTV settings to reflect this."
- echo ">>>"
- fi
}
# arg 1: the old package version
diff --git a/abs/core/lirc/lirc.lr b/abs/core/lirc/lirc.lr
deleted file mode 100644
index 44bbdbb..0000000
--- a/abs/core/lirc/lirc.lr
+++ /dev/null
@@ -1,6 +0,0 @@
-/var/log/lircd {
- missingok
- notifempty
- delaycompress
-}
-
diff --git a/abs/core/lirc/lirc.service b/abs/core/lirc/lirc.service
new file mode 100644
index 0000000..953601f
--- /dev/null
+++ b/abs/core/lirc/lirc.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Linux Infrared Remote Control
+
+[Service]
+ExecStartPre=/usr/bin/ln -sf /run/lirc/lircd /dev/lircd
+ExecStart=/usr/sbin/lircd --pidfile=/run/lirc/lircd.pid
+Type=forking
+PIDFile=/run/lirc/lircd.pid
+
+[Install]
+WantedBy=multi-user.target
diff --git a/abs/core/lirc/lirc.tmpfiles b/abs/core/lirc/lirc.tmpfiles
new file mode 100644
index 0000000..0b80e2e
--- /dev/null
+++ b/abs/core/lirc/lirc.tmpfiles
@@ -0,0 +1 @@
+d /run/lirc 0755 root root -
diff --git a/abs/core/lirc/lirc_imon.conf b/abs/core/lirc/lirc_imon.conf
deleted file mode 100644
index d3e0b8f..0000000
--- a/abs/core/lirc/lirc_imon.conf
+++ /dev/null
@@ -1,2 +0,0 @@
-# Module options for IMON VFD. usbid=15c2:ffdc Ref #596
-options lirc_imon display_type=1
diff --git a/abs/core/lirc/lircm.service b/abs/core/lirc/lircm.service
new file mode 100644
index 0000000..6b258e3
--- /dev/null
+++ b/abs/core/lirc/lircm.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=LIRC Mouse
+After=lirc.service
+Wants=lirc.service
+
+[Service]
+ExecStart=/usr/sbin/lircmd -u
+Type=forking
+
+[Install]
+WantedBy=multi-user.target