summaryrefslogtreecommitdiffstats
path: root/abs/core/local-website
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2011-08-03 21:50:49 (GMT)
committerBritney Fransen <brfransen@gmail.com>2011-08-03 21:50:49 (GMT)
commita9c47f145393b31d7f656b14a2952ab6fc6fec58 (patch)
tree94b7bb5ad11c7a98a53ecda3a4bcd2c63c6d934a /abs/core/local-website
parentedb5eaa42980f66e1c660d570d645d661c9072a4 (diff)
downloadlinhes_pkgbuild-a9c47f145393b31d7f656b14a2952ab6fc6fec58.zip
linhes_pkgbuild-a9c47f145393b31d7f656b14a2952ab6fc6fec58.tar.gz
linhes_pkgbuild-a9c47f145393b31d7f656b14a2952ab6fc6fec58.tar.bz2
local-website: Update for R7. refs #17
Diffstat (limited to 'abs/core/local-website')
-rw-r--r--abs/core/local-website/PKGBUILD3
-rwxr-xr-xabs/core/local-website/htdocs/404.html58
-rwxr-xr-xabs/core/local-website/htdocs/index.html28
-rw-r--r--abs/core/local-website/htdocs/remote/index.html93
4 files changed, 133 insertions, 49 deletions
diff --git a/abs/core/local-website/PKGBUILD b/abs/core/local-website/PKGBUILD
index 43a0964..2fd4e1a 100644
--- a/abs/core/local-website/PKGBUILD
+++ b/abs/core/local-website/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=local-website
pkgver=2
-pkgrel=25
+pkgrel=26
pkgdesc="Contents of http://localhost"
arch=(i686 x86_64)
license=('GPL')
@@ -19,3 +19,4 @@ build()
}
+md5sums=()
diff --git a/abs/core/local-website/htdocs/404.html b/abs/core/local-website/htdocs/404.html
index 41219b0..d97de98 100755
--- a/abs/core/local-website/htdocs/404.html
+++ b/abs/core/local-website/htdocs/404.html
@@ -1,25 +1,43 @@
-<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
+<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html>
<head>
- <meta content="text/html; charset=ISO-8859-1" http-equiv="content-type">
- <meta content="Cecil Watson" name="author">
- <title>LinHES 404</title>
- <!-- Generated by: /usr/local/bin/rrd_Configure.sh -->
- <link href="/KnoppMyth.css" rel="stylesheet" type="text/css" />
- <p align="center"><a href="http://www.mysettopbox.tv">
- <img src="/header.png" alt="Tux with a Remote" align="middle" border="0"></a>
- </p>
- <table align="center" border="0" cellpadding="5">
- <tbody>
- <tr>
- <td style="vertical-align: top;">
- <p class="headerimage" align="center"><b>The Linux Home Entertainment System Release 6</b></p>
- <p align=center>
-<font size="+2">OOPS</font><br>
-<font size="+1"> The page you requested is missing!<br>
+ <base href="/linhes/">
+ <title>LinHES - Page Not Found</title>
+
+ <meta http-equiv="content-type" content="text/html; charset=utf-8">
+ <meta name="robots" content="noindex, nofollow">
+
+ <link rel="stylesheet" type="text/css" href="/linhes/default/style.css">
+ <link rel="stylesheet" type="text/css" href="/linhes/default/header.css">
+ <link rel="stylesheet" type="text/css" href="/linhes/default/menus.css">
+ <link rel="stylesheet" type="text/css" href="/linhes/default/programming.css">
+ <link rel="stylesheet" type="text/css" href="/linhes/default/welcome.css">
+</head>
+
+<body>
+ <div id="page_header" style="position:relative; text-align:center;">
+ <div id="logo_box">
+ <a id="LinHES_logo" href="/">
+ <img src="/header.png" alt="Tux with a Remote" class="body">
+ </a>
+ </div>
+ </div>
+
+ <table width="100%" border="0" cellspacing="2" cellpadding="0">
+ <tr>
+ <td colspan="2" class="menu menu_border_t menu_border_b">
+ <table class="body" width="100%" border="0" cellspacing="2" cellpadding="2">
+ <td align="center">
+ <a href="http://linhes.org" <b>The Linux Home Entertainment System Release 7
+ </td>
+ </table>
</td>
- </tr>
- </tbody>
- </table>
+ </tr>
+ </table>
+
+ <p align=center>
+ <font size="+2">OOPS (404 Error)</font><br>
+ <font size="+1"> The page you requested is missing!<br>
+
</body>
</html>
diff --git a/abs/core/local-website/htdocs/index.html b/abs/core/local-website/htdocs/index.html
index 5e6ec81..2a69a64 100755
--- a/abs/core/local-website/htdocs/index.html
+++ b/abs/core/local-website/htdocs/index.html
@@ -26,7 +26,7 @@
<body>
<div id="page_header" style="position:relative; text-align:center;">
<div id="logo_box">
- <a id="LinHES_logo" href="http://linhes.org/">
+ <a id="LinHES_logo" href="/">
<img src="/header.png" alt="Tux with a Remote" class="body">
</a>
</div>
@@ -37,7 +37,7 @@
<td colspan="2" class="menu menu_border_t menu_border_b">
<table class="body" width="100%" border="0" cellspacing="2" cellpadding="2">
<td align="center">
- <a href="http://linhes.org" <b>The Linux Home Entertainment System Release 6</b></a>
+ <a href="http://linhes.org" <b>The Linux Home Entertainment System Release 7</b></a>
</td>
</table>
</td>
@@ -46,7 +46,7 @@
<script type="text/javascript">
-<!--
+//<!--
var visible_module = 'media';
function show_module_info(module) {
@@ -81,20 +81,16 @@
<div id="info_media">
<ul>
<li><a href="/mythweb/">MythWeb</a> - MythWeb provides a frontend for scheduling and managing recordings on your MythBox from a web browser.<br></li>
- <li><a href="/remote/index.html">MythTV Web Virtual Remote</a> - A web based virtual remote control for MythTV. For this to work, you must enable "Network Remote Control interface" in Service Menu -> MythTV Configuration -> Setup -> General -> Remote Control.<br></li>
- <li><a href="/ipodfeed/feed.php">iPod Feeds</a> - Transcodes ready for the iPod. If you have no recordings, you will see a warning issued from PHP.<br></li>
- <li><a href="/ipodfeed/m2iweb.php">Delete iPod Transcodes</a><br></li>
- <li><a href="/archive/feed.php">XviD Feeds</a> - Programs you have transcoded to XviD. If you have no recordings, you will see a warning issued from PHP.<br></li>
- <li><a href="/archive/archive.php">Delete XviD Transcodes</a><br></li>
- <li><a href="/fuppes.php">FUPPES</a> - Free UPnP Entertainment Service. A UPnP to be used inplace of the UPnP server that comes with MythTV. Install via the Service Menu.<br></li>
- <li><a href="/mediaserv.php">Mediaserv</a> - A on-demand transcoding server for videos. Mediaserv is designed to transcode video in a format playable on the Nokia Internet Tablets. However it works well at transcoding and streaming to any device that will playback AVIs (think streaming to any browser!). By default, we have it set to link to TV recordings (pretty) and your video directory. Additionally if you want it to stream contents from a network share, it will! ln -s /path/to/share /myth/mediaserv/media/<br></li>
- <li><a href="/mythweb/data/mp3player.html">Radio</a> - Music in MythMusic must be encoded as MP3s.<br></li>
+ <li><a href="/remote/index.html">MythTV Web Remote</a><br></li>
+<!-- not working right now <li><a href="/fuppes.php" target="_blank">FUPPES</a> - UPnP Media Server. Install via the Service Menu.<br></li> -->
+ <li><a href="/mediaserv.php" target="_blank">Mediaserv</a> - On-demand transcoding server for videos. Mediaserv is designed to transcode video in a format playable on the Nokia Internet Tablets. However it works well at transcoding and streaming to any device that will playback AVIs (think streaming to any browser!). By default, your TV recordings (pretty) and video directory are linked. If you want Mediaserv to stream contents from a network share: ln -s /path/to/share /myth/mediaserv/media/<br></li>
+<!-- not working right now <li><a href="/mythweb/data/mp3player.html">Radio</a> - Music in MythMusic must be encoded as MP3s.<br></li> -->
</ul>
</div>
<div id="info_status" class="hidden">
<ul>
- <li><a href="/rrd/index.html">RRDTool</a> - Hardware status graphs.</li>
- <li><a href="/monitorix/">Monitorix</a> - A system monitoring perl script that uses rrd databases to log system data.<br></li>
+ <li><a href="/rrd/index.html">RRDTool</a> - A system monitoring tool.</li>
+ <li><a href="/monitorix/">Monitorix</a> - A lightweight system monitoring tool.<br></li>
<li><a href="http://fah-web.stanford.edu/cgi-bin/main.py?qtype=teampage&amp;teamnum=50975">KnoppMyth Folding@home Team Status</a></li>
<li><a href="/foldingathome/">My Folding@home Status</a></li>
</ul>
@@ -105,14 +101,12 @@
<li><a href="/mythtv-doc/keys.txt">MythTV Default Keybindings</a></li>
<li><a href="http://www.mythtv.org/support">MythTV Support</a></li>
<li><a href="http://www.schedulesdirect.org/">Schedules Direct</a> - Provides U.S./Canadian TV listing data.<br></li>
- <li><a href="/linhes.html">LinHES</a> - Describes how "The Project Leader" setup multiple systems to form a <b>Lin</b>ux <b>H</b>ome <b>E</b>ntertainment <b>S</b>ystem.<br></li>
+ <li><a href="/linhes.html">LinHES</a> - Describes how "The Project Leader" setup multiple systems to form <b>Lin</b>ux <b>H</b>ome <b>E</b>ntertainment <b>S</b>ystem.<br></li>
<li><a href="http://linhes.org/phpBB2/">LinHES Forum</a></li>
- <li><a href="http://www.google.com/advanced_search?q=+site:mysettopbox.tv/phpBB2&hl=en&lr=&as_qdr=all">Search LinHES Forum</a></li>
- <li><a href="http://www.knoppmythwiki.org/">KnoppMyth Wiki</a></li>
<li><a href="http://linhes.org/bugs/projects/linhes/wiki">LinHES Wiki</a></li>
<li><a href="http://linhes.org/bugs">LinHES Bug Tracker</a></li>
</ul>
</div>
-
+ </div>
</body>
</html>
diff --git a/abs/core/local-website/htdocs/remote/index.html b/abs/core/local-website/htdocs/remote/index.html
index 35ff9e7..9ec9fe0 100644
--- a/abs/core/local-website/htdocs/remote/index.html
+++ b/abs/core/local-website/htdocs/remote/index.html
@@ -1,19 +1,90 @@
-<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
-<html xmlns="http://www.w3.org/1999/xhtml">
-
+<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
+<html>
<head>
- <meta content="text/html; charset=ISO-8859-1" http-equiv="content-type" />
+ <title>MythTV Web Remote</title>
+
+ <meta http-equiv="content-type" content="text/html; charset=utf-8">
+ <meta name="robots" content="noindex, nofollow">
+
+ <script type="text/javascript" src="/linhes/js/prototype.js"></script>
+ <script type="text/javascript" src="/linhes/js/prototip/prototip.js"></script>
+ <link rel="stylesheet" type="text/css" href="/linhes/js/prototip/prototip.css">
+
+ <script type="text/javascript" src="/linhes/js/utils.js"></script>
+ <script type="text/javascript" src="/linhes/js/AC_OETags.js"></script>
+ <script type="text/javascript" src="/linhes/js/table_sort.js"></script>
-
- <title>MythWeb Remote</title>
+ <link rel="stylesheet" type="text/css" href="/linhes/default/style.css">
+ <link rel="stylesheet" type="text/css" href="/linhes/default/header.css">
+ <link rel="stylesheet" type="text/css" href="/linhes/default/menus.css">
+ <link rel="stylesheet" type="text/css" href="/linhes/default/programming.css">
+ <link rel="stylesheet" type="text/css" href="/linhes/default/welcome.css">
</head>
<body>
-Please click through for the <a href="remote.html">vertical remote control</a>.<br /><br />
-Or click through for the <a href="remote-wide.html">horizontal remote control</a>.<br />
-<br />
-There is now an initial <a href="pda.php">PDA</a> version of the layout<br />
-</body>
+<div id="page_header" style="position:relative; text-align:center;">
+ <div id="logo_box">
+ <a id="LinHES_logo" href="/">
+ <img src="/header.png" alt="Tux with a Remote" class="body">
+ </a>
+ </div>
+</div>
+
+<table width="100%" border="0" cellspacing="2" cellpadding="0">
+<tr>
+ <td colspan="2" class="menu menu_border_t menu_border_b">
+ <table class="body" width="100%" border="0" cellspacing="2" cellpadding="2">
+ <td align="center">
+ <a href="http://linhes.org" <b>The Linux Home Entertainment System Release 7</b></a>
+ </td>
+ </table>
+ </td>
+</tr>
+</table>
+
+<script type="text/javascript">
+//<!--
+ var visible_module = 'media';
+ function show_module_info(module) {
+ if (visible_module == module)
+ return;
+ // Change the outline on the list item
+ $('module_'+ visible_module).removeClassName('selected');
+ $('module_'+ module).addClassName('selected');
+ // Show and hide the appropriate info boxes
+ $('info_' + visible_module).hide();
+ $('info_' + visible_module).addClassName('hidden');
+ $('info_' + module).show();
+ $('info_' + module).removeClassName('hidden');
+ // Keep track of what's visible now
+ visible_module = module;
+ }
+
+// -->
+</script>
+
+<div id="modules" class="clearfix">
+
+ <div id="module_names">
+ <ul>
+ <li id="module_media" class="selected" onmouseover="show_module_info('media')">Remote</li>
+ </ul>
+ </div>
+
+ <div id="module_info">
+ <div id="info_media">
+
+ <ul>
+ Before using one of the remotes you must enable "Network Remote Control interface" in Service Menu -> MythTV Configuration -> Setup -> General -> Remote Control.<br><br>
+ <li><a href="remote.html" target="_blank">Vertical Layout</a><br></li>
+ <li><a href="remote-wide.html" target="_blank">Horizontal Layout</a><br></li>
+ <li><a href="pda.php" target="_blank">PDA Layout</a><br></li>
+ </ul>
+ </div>
+ </div>
+
+</div>
+</body>
</html>