summaryrefslogtreecommitdiffstats
path: root/abs/core/lockdev
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 17:32:59 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 17:32:59 (GMT)
commit306ec2157cc51fd1bbf1b5b52b4cf9b2e5f17823 (patch)
tree05c0d0f5b92ebdaa41fd9eb787600d60fa8c2ab3 /abs/core/lockdev
parent07c218234e0b6afaf6e2c9b053e7d8217648fa9c (diff)
downloadlinhes_pkgbuild-306ec2157cc51fd1bbf1b5b52b4cf9b2e5f17823.zip
linhes_pkgbuild-306ec2157cc51fd1bbf1b5b52b4cf9b2e5f17823.tar.gz
linhes_pkgbuild-306ec2157cc51fd1bbf1b5b52b4cf9b2e5f17823.tar.bz2
lockdev 1.0.3
-new
Diffstat (limited to 'abs/core/lockdev')
-rw-r--r--abs/core/lockdev/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core/lockdev/PKGBUILD b/abs/core/lockdev/PKGBUILD
new file mode 100644
index 0000000..946f55d
--- /dev/null
+++ b/abs/core/lockdev/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=lockdev
+pkgver=1.0.3_1.5
+_pkgver=1.0.3
+pkgrel=3
+pkgdesc='Run-time shared library for locking devices, using _both_ FSSTND and SVr4 methods.'
+url='http://packages.qa.debian.org/l/lockdev.html'
+license=("GPL")
+arch=('i686' 'x86_64')
+source=("http://ftp.debian.org/debian/pool/main/l/${pkgname}/${pkgname}_${_pkgver}.orig.tar.gz"
+ "http://ftp.debian.org/debian/pool/main/l/${pkgname}/${pkgname}_${pkgver/_/-}.diff.gz")
+
+build() {
+ cd "${pkgname}-${_pkgver}"
+
+ patch -p1 -i "../${pkgname}_${pkgver/_/-}.diff"
+ sed -i "s|CFLAGS = -g|CFLAGS = -g -fPIC|" Makefile
+
+ make shared
+ make static
+}
+
+package() {
+ cd "${pkgname}-${_pkgver}"
+ make basedir="${pkgdir}/usr" install
+}
+md5sums=('64b9c1b87b125fc348e892e24625524a'
+ 'c4e8a5a2e46b76b48339c232b358f579')