summaryrefslogtreecommitdiffstats
path: root/abs/core/lockdev
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-20 00:34:21 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-20 00:34:21 (GMT)
commitfc82283b1f350150f2f9a91d53b975a364363fda (patch)
tree91e07b22b39ae0113b24a3f466162b7c81c98da1 /abs/core/lockdev
parent8eaf3a55d86a96ee70f0c0f7cc02c735c14a4e0d (diff)
downloadlinhes_pkgbuild-fc82283b1f350150f2f9a91d53b975a364363fda.zip
linhes_pkgbuild-fc82283b1f350150f2f9a91d53b975a364363fda.tar.gz
linhes_pkgbuild-fc82283b1f350150f2f9a91d53b975a364363fda.tar.bz2
lockdev: update to 1.0.3_1.6
Diffstat (limited to 'abs/core/lockdev')
-rw-r--r--abs/core/lockdev/PKGBUILD38
-rw-r--r--abs/core/lockdev/build.patch30
-rw-r--r--abs/core/lockdev/gcc-4.7.patch18
3 files changed, 76 insertions, 10 deletions
diff --git a/abs/core/lockdev/PKGBUILD b/abs/core/lockdev/PKGBUILD
index 946f55d..5398e7a 100644
--- a/abs/core/lockdev/PKGBUILD
+++ b/abs/core/lockdev/PKGBUILD
@@ -1,27 +1,45 @@
+# $Id$
+# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Andreas Wagner <a.wagner@stud.uni-frankfurt.de>
+
pkgname=lockdev
-pkgver=1.0.3_1.5
+pkgver=1.0.3_1.6
_pkgver=1.0.3
-pkgrel=3
+pkgrel=4
pkgdesc='Run-time shared library for locking devices, using _both_ FSSTND and SVr4 methods.'
url='http://packages.qa.debian.org/l/lockdev.html'
license=("GPL")
-arch=('i686' 'x86_64')
+arch=('x86_64')
+depends=('glibc' 'systemd')
source=("http://ftp.debian.org/debian/pool/main/l/${pkgname}/${pkgname}_${_pkgver}.orig.tar.gz"
- "http://ftp.debian.org/debian/pool/main/l/${pkgname}/${pkgname}_${pkgver/_/-}.diff.gz")
+ "http://ftp.debian.org/debian/pool/main/l/${pkgname}/${pkgname}_${pkgver/_/-}.diff.gz"
+ 'build.patch'
+ 'gcc-4.7.patch')
+md5sums=('64b9c1b87b125fc348e892e24625524a'
+ '5ef6267c42fca9145e0af006ccb6aff7'
+ '2db93cadf6670ddcd01de4bfc22a35e1'
+ 'e16faebfa2d162d40830ef6f2700b7ba')
-build() {
+prepare() {
cd "${pkgname}-${_pkgver}"
-
patch -p1 -i "../${pkgname}_${pkgver/_/-}.diff"
sed -i "s|CFLAGS = -g|CFLAGS = -g -fPIC|" Makefile
+ patch -p1 -i ../build.patch # FS#33280
+ patch -p1 -i ../gcc-4.7.patch # FS#34457
+}
- make shared
- make static
+build() {
+ cd "${pkgname}-${_pkgver}"
+ make CFLAGS="${CFLAGS} -D_PATH_LOCK=\\\"/run/lock/lockdev\\\" -fPIC"
}
package() {
cd "${pkgname}-${_pkgver}"
make basedir="${pkgdir}/usr" install
+
+ # Setup lock directory
+ install -dm755 "$pkgdir"/usr/lib/{sysusers,tmpfiles}.d
+ echo 'g lock - - -' > "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
+ echo 'd /run/lock/lockdev 0775 root lock -' > "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
}
-md5sums=('64b9c1b87b125fc348e892e24625524a'
- 'c4e8a5a2e46b76b48339c232b358f579')
diff --git a/abs/core/lockdev/build.patch b/abs/core/lockdev/build.patch
new file mode 100644
index 0000000..f1053d0
--- /dev/null
+++ b/abs/core/lockdev/build.patch
@@ -0,0 +1,30 @@
+commit 0dd47123655c52d68185f06b9da8fb0e1b925400
+Author: Ludwig Nussel <ludwig.nussel@suse.de>
+Date: Tue Feb 9 14:56:23 2010 +0100
+
+ RedHat patch 2
+
+ - change library file name
+ - install devel symlink
+
+diff --git a/Makefile b/Makefile
+index b7b4d1f..3b351dd 100644
+--- a/Makefile
++++ b/Makefile
+@@ -11,7 +11,7 @@ VER = $(shell expr `pwd` : '.*-\([0-9.]*\)')
+ MVER = ${shell expr `pwd` : '.*-\([0-9]*\).[0-9]*'}
+
+ static = ${libname}.a
+-shared = ${libname}.${VER}.so
++shared = ${libname}.so.${VER}
+ soname = ${libname}.so.${MVER}
+
+ # overwritten by caller (e.g.: debian/rules)
+@@ -76,6 +76,7 @@ install_doc: docs/lockdev.3
+ install_run: ${shared}
+ install -m755 -d ${libdir}
+ install -m644 ${shared} ${libdir}
++ ln -s ${shared} ${libdir}/liblockdev.so
+
+ .PHONY: clean distclean perl-clean mostyclean
+ perl-clean: clean
diff --git a/abs/core/lockdev/gcc-4.7.patch b/abs/core/lockdev/gcc-4.7.patch
new file mode 100644
index 0000000..3b11e0b
--- /dev/null
+++ b/abs/core/lockdev/gcc-4.7.patch
@@ -0,0 +1,18 @@
+diff -Naur lockdev-1.0.3.orig/src/ttylock.h lockdev-1.0.3/src/ttylock.h
+--- lockdev-1.0.3.orig/src/ttylock.h 2013-12-13 15:34:52.195877321 +0000
++++ lockdev-1.0.3/src/ttylock.h 2013-12-13 15:38:16.131190480 +0000
+@@ -36,10 +36,10 @@
+
+ /* API of the library */
+
+-int ttylock (char * devname);
+-int ttywait (char * devname);
+-int ttyunlock (char * devname);
+-int ttylocked (char * devname);
++static inline int ttylock (char * devname);
++static inline int ttywait (char * devname);
++static inline int ttyunlock (char * devname);
++static inline int ttylocked (char * devname);
+
+
+ static inline int