summaryrefslogtreecommitdiffstats
path: root/abs/core/logrotate
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/logrotate
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/logrotate')
-rw-r--r--abs/core/logrotate/PKGBUILD37
-rw-r--r--abs/core/logrotate/logrotate.conf28
-rwxr-xr-xabs/core/logrotate/logrotate.cron.daily3
3 files changed, 68 insertions, 0 deletions
diff --git a/abs/core/logrotate/PKGBUILD b/abs/core/logrotate/PKGBUILD
new file mode 100644
index 0000000..16a389a
--- /dev/null
+++ b/abs/core/logrotate/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Aaron Griffin <aaron@archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+
+pkgname=logrotate
+pkgver=3.7.5
+pkgrel=10
+pkgdesc="Rotates system logs automatically"
+url='http://rhlinux.redhat.com'
+arch=(i686 x86_64)
+license=('GPL')
+groups=('base')
+depends=('popt' 'cron' 'gzip')
+backup=('etc/logrotate.conf')
+
+# The source is apparently a CVS checkout only. Create the tarball like so:
+# cvs -d :pserver:anonymous@rhlinux.redhat.com:/usr/local/CVS co logrotate
+# cd logrotate/
+# make create-archive
+# Ensure this tarball is places in other/logrotate/
+
+source=(ftp://ftp.archlinux.org/other/logrotate/${pkgname}-${pkgver}.tar.gz
+ logrotate.conf logrotate.cron.daily)
+md5sums=('a1a3ea2f1d80e67e902c024bbdef616a'
+ 'c8b915903825befc401797b7620f249e'
+ '8e23d5d4cc29b1e055b24df87e355cdc')
+
+build() {
+ cd $startdir/src/${pkgname}-${pkgver}
+
+ sed -i 's|#define DEFAULT_MAIL_COMMAND .*|#define DEFAULT_MAIL_COMMAND "/usr/bin/mail"|'\
+ config.h
+ make || return 1
+ make PREFIX=$startdir/pkg install
+ install -D -m644 ../logrotate.conf $startdir/pkg/etc/logrotate.conf
+ install -D -m744 ../logrotate.cron.daily $startdir/pkg/etc/cron.daily/logrotate
+}
diff --git a/abs/core/logrotate/logrotate.conf b/abs/core/logrotate/logrotate.conf
new file mode 100644
index 0000000..fde947b
--- /dev/null
+++ b/abs/core/logrotate/logrotate.conf
@@ -0,0 +1,28 @@
+# see "man logrotate" for details
+# rotate log files weekly
+weekly
+
+# keep 4 weeks worth of backlogs
+rotate 4
+
+# create new (empty) log files after rotating old ones
+create
+
+# uncomment this if you want your log files compressed
+#compress
+
+# Logs are moved into directory for rotation
+# olddir /var/log/archive
+
+# Ignore pacman saved files
+tabooext + .pacorig .pacnew .pacsave
+
+# Arch packages drop log rotation information into this directory
+include /etc/logrotate.d
+
+/var/log/wtmp {
+ monthly
+ create 0664 root root
+ rotate 1
+}
+
diff --git a/abs/core/logrotate/logrotate.cron.daily b/abs/core/logrotate/logrotate.cron.daily
new file mode 100755
index 0000000..e8ab921
--- /dev/null
+++ b/abs/core/logrotate/logrotate.cron.daily
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+/usr/sbin/logrotate /etc/logrotate.conf