summaryrefslogtreecommitdiffstats
path: root/abs/core/lsdvd
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2012-07-24 06:56:55 (GMT)
committerCecil <knoppmyth@gmail.com>2012-07-24 06:56:55 (GMT)
commitc30bce893f57b62c0966278c5758ded160f4a98a (patch)
tree30bc17142afb8c746b71df088990b642c9d02d92 /abs/core/lsdvd
parent01ca135d1ebcdcfec78f68b58ad303508c3ed911 (diff)
downloadlinhes_pkgbuild-c30bce893f57b62c0966278c5758ded160f4a98a.zip
linhes_pkgbuild-c30bce893f57b62c0966278c5758ded160f4a98a.tar.gz
linhes_pkgbuild-c30bce893f57b62c0966278c5758ded160f4a98a.tar.bz2
lsdvd:initial inclusion. For use with ripD.
Diffstat (limited to 'abs/core/lsdvd')
-rw-r--r--abs/core/lsdvd/PKGBUILD28
-rw-r--r--abs/core/lsdvd/stdint_usage.patch22
2 files changed, 50 insertions, 0 deletions
diff --git a/abs/core/lsdvd/PKGBUILD b/abs/core/lsdvd/PKGBUILD
new file mode 100644
index 0000000..0323625
--- /dev/null
+++ b/abs/core/lsdvd/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 150946 2012-02-24 09:46:48Z pierre $
+# Maintainer: Aaron Griffin <aaron@archlinux.org>
+
+pkgname=lsdvd
+pkgver=0.16
+pkgrel=6
+pkgdesc="A C application for reading the contents of a DVD and printing the contents to your terminal"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/lsdvd/"
+depends=('libdvdread')
+license=('GPL2')
+#Special thanks to Mathieu Clabaut <mathieu.clabaut@gmail.com> for patches
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ 'stdint_usage.patch')
+md5sums=('340e1abe5c5e5abf7ff8031e78f49ee7'
+ '6cbcbfde873f894bd3c784f65141b2fc')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/stdint_usage.patch"
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/abs/core/lsdvd/stdint_usage.patch b/abs/core/lsdvd/stdint_usage.patch
new file mode 100644
index 0000000..67b9ee8
--- /dev/null
+++ b/abs/core/lsdvd/stdint_usage.patch
@@ -0,0 +1,22 @@
+--- a/lsdvd.c 2006-03-02 07:48:11.000000000 -0600
++++ b/lsdvd.c 2007-09-27 19:15:28.000000000 -0500
+@@ -13,6 +13,7 @@
+ * 2003-04-19 Cleanups get_title_name, added dvdtime2msec, added helper macros,
+ * output info structures in form of a Perl module, by Henk Vergonet.
+ */
++#include <stdint.h>
+ #include <dvdread/ifo_read.h>
+ #include <string.h>
+ #include <sys/stat.h>
+--- a/configure 2005-12-12 14:22:45.000000000 -0600
++++ b/configure 2007-09-27 19:15:13.000000000 -0500
+@@ -2887,8 +2887,8 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+-#include <dvdread/ifo_read.h>
+ #include <stdint.h>
++#include <dvdread/ifo_read.h>
+ int
+ main ()
+ {