summaryrefslogtreecommitdiffstats
path: root/abs/core/lsof
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/lsof
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/lsof')
-rw-r--r--abs/core/lsof/PKGBUILD30
-rw-r--r--abs/core/lsof/license.txt27
2 files changed, 57 insertions, 0 deletions
diff --git a/abs/core/lsof/PKGBUILD b/abs/core/lsof/PKGBUILD
new file mode 100644
index 0000000..1fdedc0
--- /dev/null
+++ b/abs/core/lsof/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 2105 2008-05-25 02:46:46Z eric $
+# Maintainer: Aaron Griffin <aaron@archlinux.org>
+# Contributor: Jochem Kossen <j.kossen@home.nl>
+
+pkgname=lsof
+pkgver=4.80
+pkgrel=1
+pkgdesc="lsof (LiSt Open Files) lists information about files that are open by the running processes"
+arch=(i686 x86_64)
+license=(custom)
+depends=('glibc')
+url="http://people.freebsd.org/~abe/"
+#source=(ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/${pkgname}_${pkgver}.tar.bz2 license.txt)
+source=(ftp://sunsite.ualberta.ca/pub/Mirror/lsof/${pkgname}_${pkgver}.tar.bz2 license.txt)
+md5sums=('18d124d063619eeee147a8d638e2b8fd' '1b63c76bd10437cabf890508c8e58d36')
+
+build() {
+ cd $startdir/src/${pkgname}_${pkgver}
+ tar xf ${pkgname}_${pkgver}_src.tar
+ cd ${pkgname}_${pkgver}_src
+ sed "s|/\* #define\tHASSECURITY\t1 \*/|#define\tHASSECURITY\t1|" -i dialects/linux/machine.h
+
+ ./Configure -n linux
+ make || return 1
+ install -D -m0755 -o root -g root lsof $startdir/pkg/usr/sbin/lsof
+ install -D -m0644 -o root -g root lsof.8 $startdir/pkg/usr/share/man/man8/lsof.8
+
+ install -D -m0644 -o root -g root $startdir/src/license.txt \
+ $startdir/pkg/usr/share/licenses/lsof/license.txt
+}
diff --git a/abs/core/lsof/license.txt b/abs/core/lsof/license.txt
new file mode 100644
index 0000000..6d241dd
--- /dev/null
+++ b/abs/core/lsof/license.txt
@@ -0,0 +1,27 @@
+Copyright 2002 Purdue Research Foundation, West Lafayette,
+Indiana 47907. All rights reserved.
+
+Written by Victor A. Abell
+
+This software is not subject to any license of the American
+Telephone and Telegraph Company or the Regents of the
+University of California.
+
+Permission is granted to anyone to use this software for
+any purpose on any computer system, and to alter it and
+redistribute it freely, subject to the following
+restrictions:
+
+1. Neither the authors nor Purdue University are responsible
+ for any consequences of the use of this software.
+
+2. The origin of this software must not be misrepresented,
+ either by explicit claim or by omission. Credit to the
+ authors and Purdue University must appear in documentation
+ and sources.
+
+3. Altered versions must be plainly marked as such, and must
+ not be misrepresented as being the original software.
+
+4. This notice may not be removed or altered.
+