summaryrefslogtreecommitdiffstats
path: root/abs/core/make
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-02-15 23:01:50 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-02-15 23:01:50 (GMT)
commit30be9c81192a331e5f61d131aa83912d9b39fcb1 (patch)
tree744afd62ad2db8f49648427f15f0df348d45c11a /abs/core/make
parentfaaf15cb537521ada2831b2351c0081fc33d0c4f (diff)
downloadlinhes_pkgbuild-30be9c81192a331e5f61d131aa83912d9b39fcb1.zip
linhes_pkgbuild-30be9c81192a331e5f61d131aa83912d9b39fcb1.tar.gz
linhes_pkgbuild-30be9c81192a331e5f61d131aa83912d9b39fcb1.tar.bz2
make: 4.2.1-2
Diffstat (limited to 'abs/core/make')
-rw-r--r--abs/core/make/PKGBUILD15
-rw-r--r--abs/core/make/guile-2.2.patch15
2 files changed, 26 insertions, 4 deletions
diff --git a/abs/core/make/PKGBUILD b/abs/core/make/PKGBUILD
index 91f2da8..4d6b494 100644
--- a/abs/core/make/PKGBUILD
+++ b/abs/core/make/PKGBUILD
@@ -4,18 +4,25 @@
pkgname=make
pkgver=4.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="GNU make utility to maintain groups of programs"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.gnu.org/software/make"
license=('GPL3')
groups=('base-devel')
depends=('glibc' 'guile')
-source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.bz2{,.sig})
+source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.bz2{,.sig}
+ guile-2.2.patch)
md5sums=('15b012617e7c44c0ed482721629577ac'
- 'SKIP')
+ 'SKIP'
+ '89bbbe3f806f208608e117665feb562b')
validpgpkeys=('3D2554F0A15338AB9AF1BB9D96B047156338B6D4') # Paul Smith
+prepare() {
+ cd ${pkgname}-${pkgver}
+ patch -p1 -i ${srcdir}/guile-2.2.patch
+ autoreconf -fi
+}
build() {
cd ${pkgname}-${pkgver}
diff --git a/abs/core/make/guile-2.2.patch b/abs/core/make/guile-2.2.patch
new file mode 100644
index 0000000..8e4cbc0
--- /dev/null
+++ b/abs/core/make/guile-2.2.patch
@@ -0,0 +1,15 @@
+diff --git a/configure.ac b/configure.ac
+index 64ec870..eb1139f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -168,8 +168,8 @@ AC_ARG_WITH([guile], [AS_HELP_STRING([--with-guile],
+ # comes with it's own PC file so we have to specify them as individual
+ # packages. Ugh.
+ AS_IF([test "x$with_guile" != xno],
+-[ PKG_CHECK_MODULES([GUILE], [guile-2.0], [have_guile=yes],
+- [PKG_CHECK_MODULES([GUILE], [guile-1.8], [have_guile=yes],
++[ PKG_CHECK_MODULES([GUILE], [guile-2.2], [have_guile=yes],
++ [PKG_CHECK_MODULES([GUILE], [guile-2.0], [have_guile=yes],
+ [have_guile=no])])
+ ])
+