summaryrefslogtreecommitdiffstats
path: root/abs/core/man-db
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-03 03:26:25 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-03 03:26:25 (GMT)
commit9e1bbb32ae25fef6111d95205614a612ed9f70ec (patch)
treeed42f7b1c991416b177e9fa6f6b852f48812b7ad /abs/core/man-db
parent4004c7c21e83a7f90db802b5f603fd510304e81e (diff)
downloadlinhes_pkgbuild-9e1bbb32ae25fef6111d95205614a612ed9f70ec.zip
linhes_pkgbuild-9e1bbb32ae25fef6111d95205614a612ed9f70ec.tar.gz
linhes_pkgbuild-9e1bbb32ae25fef6111d95205614a612ed9f70ec.tar.bz2
man-db: upgrade
Diffstat (limited to 'abs/core/man-db')
-rw-r--r--abs/core/man-db/PKGBUILD52
-rw-r--r--abs/core/man-db/convert-mans11
-rwxr-xr-xabs/core/man-db/man-db.cron.daily39
-rw-r--r--abs/core/man-db/man-db.install18
4 files changed, 120 insertions, 0 deletions
diff --git a/abs/core/man-db/PKGBUILD b/abs/core/man-db/PKGBUILD
new file mode 100644
index 0000000..05265fd
--- /dev/null
+++ b/abs/core/man-db/PKGBUILD
@@ -0,0 +1,52 @@
+# $Id: PKGBUILD 99794 2010-11-17 19:07:22Z andyrtr $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Sergej Pupykin <sergej@aur.archlinux.org>
+
+pkgname=man-db
+pkgver=2.5.9
+pkgrel=1
+pkgdesc="A utility for reading man pages"
+arch=('i686' 'x86_64')
+url="http://www.nongnu.org/man-db/"
+license=('GPL' 'LGPL')
+groups=('base')
+depends=( 'bash' 'gdbm' 'zlib' 'groff')
+optdepends=('less' 'gzip')
+backup=('etc/man_db.conf'
+ 'etc/cron.daily/man-db')
+conflicts=('man')
+provides=('man')
+replaces=('man')
+install=${pkgname}.install
+source=(http://savannah.nongnu.org/download/man-db/$pkgname-$pkgver.tar.gz
+ #http://launchpad.net/man-db/main/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz
+ convert-mans man-db.cron.daily)
+md5sums=('9841394f5c5fe7e2dd2e0c5fb4766d0f'
+ '2b7662a7d5b33fe91f9f3e034361a2f6'
+ 'd30c39ae47560304471b5461719e0f03')
+options=('!libtool')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
+ --with-db=gdbm --disable-setuid --enable-mandirs=GNU \
+ --with-sections="1 n l 8 3 0 2 5 4 9 6 7"
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install || return 1
+
+ # part of groff pkg
+ rm -f ${pkgdir}/usr/bin/zsoelim
+
+ # script from LFS to convert manpages, see
+ # http://www.linuxfromscratch.org/lfs/view/6.4/chapter06/man-db.html
+ install -D -m755 ${srcdir}/convert-mans ${pkgdir}/usr/bin/convert-mans
+
+ #install whatis cron script
+ install -D -m744 ${srcdir}/man-db.cron.daily ${pkgdir}/etc/cron.daily/man-db
+}
+
diff --git a/abs/core/man-db/convert-mans b/abs/core/man-db/convert-mans
new file mode 100644
index 0000000..58a0224
--- /dev/null
+++ b/abs/core/man-db/convert-mans
@@ -0,0 +1,11 @@
+#!/bin/sh -e
+FROM="$1"
+TO="$2"
+shift ; shift
+while [ $# -gt 0 ]
+do
+ FILE="$1"
+ shift
+ iconv -f "$FROM" -t "$TO" "$FILE" >.tmp.iconv
+ mv .tmp.iconv "$FILE"
+done
diff --git a/abs/core/man-db/man-db.cron.daily b/abs/core/man-db/man-db.cron.daily
new file mode 100755
index 0000000..53e66e1
--- /dev/null
+++ b/abs/core/man-db/man-db.cron.daily
@@ -0,0 +1,39 @@
+#!/bin/sh
+
+# nicenesses range from -20 (most favorable scheduling) to 19 (least favorable)
+NICE=19
+
+# 0 for none, 1 for real time, 2 for best-effort, 3 for idle
+IONICE_CLASS=2
+
+# 0-7 (for IONICE_CLASS 1 and 2 only), 0=highest, 7=lowest
+IONICE_PRIORITY=7
+
+UPDATEMANDB="/usr/bin/mandb --quiet"
+
+# Update the "whatis" database
+#/usr/sbin/makewhatis -u -w
+
+# taken from Debian
+# man-db cron daily
+set -e
+
+if ! [ -d /var/cache/man ]; then
+ # Recover from deletion, per FHS.
+ mkdir -p /var/cache/man
+ chmod 755 /var/cache/man
+fi
+
+# regenerate man database
+
+if [ -x /usr/bin/nice ]; then
+ UPDATEMANDB="/usr/bin/nice -n ${NICE:-19} ${UPDATEMANDB}"
+fi
+
+if [ -x /usr/bin/ionice ]; then
+ UPDATEMANDB="/usr/bin/ionice -c ${IONICE_CLASS:-2} -n ${IONICE_PRIORITY:-7} ${UPDATEMANDB}"
+fi
+
+${UPDATEMANDB}
+
+exit 0
diff --git a/abs/core/man-db/man-db.install b/abs/core/man-db/man-db.install
new file mode 100644
index 0000000..6a0f36b
--- /dev/null
+++ b/abs/core/man-db/man-db.install
@@ -0,0 +1,18 @@
+post_install() {
+ echo "it's recommended to create an initial"
+ echo "database running as root:"
+ echo "\"/usr/bin/mandb --quiet\""
+}
+
+post_upgrade() {
+ if [ "`vercmp $2 2.5.3-2`" -lt 0 ]; then
+ echo "systemuser \"man\" is no more required"
+ echo "run \"userdel man\". please also"
+ echo "chown root:root /var/cache/man"
+ fi
+}
+
+post_remove() {
+ rm -rf /var/cache/man
+}
+