summaryrefslogtreecommitdiffstats
path: root/abs/core/man-pages
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-11-14 22:16:13 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-11-14 22:16:13 (GMT)
commit5cff5de5042ab11e00e08bf56e27dca2dbe42b10 (patch)
tree6aaf82589e2e14dbe94ba7c75b25e3c47bd2d057 /abs/core/man-pages
parent5c246b413cfd03fd9cab2ed282aa95334e810a12 (diff)
downloadlinhes_pkgbuild-5cff5de5042ab11e00e08bf56e27dca2dbe42b10.zip
linhes_pkgbuild-5cff5de5042ab11e00e08bf56e27dca2dbe42b10.tar.gz
linhes_pkgbuild-5cff5de5042ab11e00e08bf56e27dca2dbe42b10.tar.bz2
man-pages: update to 4.08
Diffstat (limited to 'abs/core/man-pages')
-rw-r--r--abs/core/man-pages/PKGBUILD32
1 files changed, 22 insertions, 10 deletions
diff --git a/abs/core/man-pages/PKGBUILD b/abs/core/man-pages/PKGBUILD
index c4c6ab8..baa2eba 100644
--- a/abs/core/man-pages/PKGBUILD
+++ b/abs/core/man-pages/PKGBUILD
@@ -1,20 +1,24 @@
-# $Id: PKGBUILD 158918 2012-05-13 07:19:23Z andyrtr $
+# $Id$
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
pkgname=man-pages
-pkgver=3.41
-_posixver=2003-a
+pkgver=4.08
+_posixver=2013-a
pkgrel=1
pkgdesc="Linux man pages"
arch=('any')
-license=('GPL')
+license=('GPL' 'custom')
url="http://man7.org/linux/man-pages/index.html"
groups=('base')
depends=()
-source=(http://www.kernel.org/pub/linux/docs/man-pages/$pkgname-$pkgver.tar.xz
- http://www.kernel.org/pub/linux/docs/man-pages/man-pages-posix/$pkgname-posix-${_posixver}.tar.bz2)
-md5sums=('7395d284fa1b9e112006d736865781b0'
- '7c78aff03c0a6767ba483d34f19e4b09')
+source=(http://www.kernel.org/pub/linux/docs/man-pages/$pkgname-$pkgver.tar.{xz,sign}
+ http://www.kernel.org/pub/linux/docs/man-pages/man-pages-posix/$pkgname-posix-${_posixver}.tar.{xz,sign})
+# https://www.kernel.org/pub/linux/docs/man-pages/sha256sums.asc
+sha256sums=('2c6e7db4d76014dc21b1068df372f325e863318c32056369eca2f169519c62b4'
+ 'SKIP'
+ '19633a5c75ff7deab35b1d2c3d5b7748e7bd4ef4ab598b647bb7e7f60b90a808'
+ 'SKIP')
+validpgpkeys=('E522595B52EDA4E6BFCCCB5E856199113A35CE5E') #Michael Kerrisk (Linux man-pages maintainer) <mtk.manpages@gmail.com>
build() {
cd ${srcdir}/$pkgname-$pkgver
@@ -31,9 +35,13 @@ package() {
cd ${srcdir}/$pkgname-$pkgver
make prefix=${pkgdir}/usr install
-
+
+ # posix pages have a custom license
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 ${srcdir}/$pkgname-posix-${_posixver}/POSIX-COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/POSIX-COPYRIGHT"
+
cd ${pkgdir}/usr/share/man
- # these are included in coreutils || return 1
+ # these are included in coreutils
rm -f man1/{chgrp,chmod,chown,cp,dir,dd}.1
rm -f man1/{df,dircolors,du,install,ln,ls}.1
rm -f man1/{mkdir,mkfifo,mknod,mv,rm,rmdir}.1
@@ -45,4 +53,8 @@ package() {
rm -f man1/diff.1
# this is included in xf86-input-mouse
rm -f man4/mouse.4
+ # this is included in attr
+ rm -f man5/attr.5
+ # this is included in lirc
+ rm -f man4/lirc.4
}