summaryrefslogtreecommitdiffstats
path: root/abs/core/mesa-demos
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2011-01-03 23:46:44 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2011-01-03 23:46:44 (GMT)
commitb84192583f3f18cd45e976c76d62741f09ef40f0 (patch)
tree49852633ecfd8f8f598b6b6ca4f10b8954234ba3 /abs/core/mesa-demos
parent1134708f1cf2458008410dea8cfc8ff33bd4df1d (diff)
downloadlinhes_pkgbuild-b84192583f3f18cd45e976c76d62741f09ef40f0.zip
linhes_pkgbuild-b84192583f3f18cd45e976c76d62741f09ef40f0.tar.gz
linhes_pkgbuild-b84192583f3f18cd45e976c76d62741f09ef40f0.tar.bz2
mesa-demos: initial include. Dep of xbmc
Diffstat (limited to 'abs/core/mesa-demos')
-rw-r--r--abs/core/mesa-demos/LICENSE83
-rw-r--r--abs/core/mesa-demos/PKGBUILD31
2 files changed, 114 insertions, 0 deletions
diff --git a/abs/core/mesa-demos/LICENSE b/abs/core/mesa-demos/LICENSE
new file mode 100644
index 0000000..26a04af
--- /dev/null
+++ b/abs/core/mesa-demos/LICENSE
@@ -0,0 +1,83 @@
+Disclaimer
+
+Mesa is a 3-D graphics library with an API which is very similar to
+that of OpenGL*
+To the extent that Mesa utilizes the OpenGL command syntax or state
+machine, it is being used with authorization from Silicon Graphics,
+Inc.(SGI). However, the author does not possess an OpenGL license
+from SGI, and makes no claim that Mesa is in any way a compatible
+replacement for OpenGL or associated with SGI. Those who want a
+licensed implementation of OpenGL should contact a licensed
+vendor.
+
+Please do not refer to the library as MesaGL (for legal
+reasons). It's just Mesa or The Mesa 3-D graphics
+library
+
+* OpenGL is a trademark of Silicon Graphics Incorporated.
+
+License / Copyright Information
+
+The Mesa distribution consists of several components. Different copyrights
+and licenses apply to different components. For example, GLUT is copyrighted
+by Mark Kilgard, some demo programs are copyrighted by SGI, some of the Mesa
+device drivers are copyrighted by their authors. See below for a list of
+Mesa's main components and the license for each.
+
+The core Mesa library is licensed according to the terms of the MIT license.
+This allows integration with the XFree86, Xorg and DRI projects.
+
+The default Mesa license is as follows:
+
+Copyright (C) 1999-2007 Brian Paul All Rights Reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the "Software"),
+to deal in the Software without restriction, including without limitation
+the rights to use, copy, modify, merge, publish, distribute, sublicense,
+and/or sell copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included
+in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+BRIAN PAUL BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
+AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+Attention, Contributors
+
+When contributing to the Mesa project you must agree to the licensing terms
+of the component to which you're contributing.
+The following section lists the primary components of the Mesa distribution
+and their respective licenses.
+
+
+Mesa Component Licenses
+
+Component Location Primary Author License
+----------------------------------------------------------------------------
+Main Mesa code src/mesa/ Brian Paul Mesa (MIT)
+
+Device drivers src/mesa/drivers/* See drivers See drivers
+
+Ext headers include/GL/glext.h SGI SGI Free B
+ include/GL/glxext.h
+
+GLUT src/glut/ Mark Kilgard Mark's copyright
+
+Mesa GLU library src/glu/mesa/ Brian Paul GNU-LGPL
+
+SGI GLU library src/glu/sgi/ SGI SGI Free B
+
+demo programs progs/demos/ various see source files
+
+X demos progs/xdemos/ Brian Paul see source files
+
+SGI demos progs/samples/ SGI SGI copyright
+
+RedBook demos progs/redbook/ SGI SGI copyright
+
diff --git a/abs/core/mesa-demos/PKGBUILD b/abs/core/mesa-demos/PKGBUILD
new file mode 100644
index 0000000..8961103
--- /dev/null
+++ b/abs/core/mesa-demos/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id$
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=('mesa-demos')
+pkgver=8.0.1
+pkgrel=1
+arch=(i686 x86_64)
+pkgdesc="Mesa demos and tools"
+url="http://mesa3d.sourceforge.net"
+license=('custom')
+depends=('glew>=1.5.6')
+conflicts=('mesa<7.9')
+source=(ftp://ftp.freedesktop.org/pub/mesa/demos/${pkgver}/mesa-demos-${pkgver}.tar.bz2
+ LICENSE)
+
+build() {
+ cd "${srcdir}/mesa-demos-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/mesa-demos-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -m755 -d "${pkgdir}/usr/share/licenses/mesa-demos"
+ install -m755 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/mesa-demos/"
+}
+
+md5sums=('320c2a4b6edc6faba35d9cb1e2a30bf4'
+ '10a9d94c27477a9f9afed27f7d1c4476')