summaryrefslogtreecommitdiffstats
path: root/abs/core/mesa
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-10-30 19:42:45 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-10-30 19:42:45 (GMT)
commit1ac8c7303657d8a15ab356f392c5fa23d7303441 (patch)
tree97ee6001f3cddcd83dfbc131f782c88fc2ddddb1 /abs/core/mesa
parent0b5ac212468b7ab376d3e08cef4b79d839891959 (diff)
downloadlinhes_pkgbuild-1ac8c7303657d8a15ab356f392c5fa23d7303441.zip
linhes_pkgbuild-1ac8c7303657d8a15ab356f392c5fa23d7303441.tar.gz
linhes_pkgbuild-1ac8c7303657d8a15ab356f392c5fa23d7303441.tar.bz2
mesa: remove glu files that conflict with glu pkg
Diffstat (limited to 'abs/core/mesa')
-rw-r--r--abs/core/mesa/PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/abs/core/mesa/PKGBUILD b/abs/core/mesa/PKGBUILD
index 7dd7dd2..7e54fe4 100644
--- a/abs/core/mesa/PKGBUILD
+++ b/abs/core/mesa/PKGBUILD
@@ -15,7 +15,7 @@ if [ "${_git}" = "true" ]; then
else
pkgver=8.0.4
fi
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
makedepends=('glproto>=1.4.15' 'libdrm>=2.4.30' 'libxxf86vm>=1.1.1' 'libxdamage>=1.1.3' 'expat>=2.0.1' 'libx11>=1.4.99.1' 'libxt>=1.1.1'
'gcc-libs>=4.6.1' 'dri2proto>=2.6' 'python2' 'libxml2' 'imake' 'llvm' 'udev>=183')
@@ -28,7 +28,7 @@ if [ "${_git}" = "true" ]; then
#source=(${source[@]} 'ftp://ftp.archlinux.org/other/mesa/mesa-1ae00c5960af83bea9545a18a1754bad83d5cbd0.tar.bz2')
source=(${source[@]} "MesaLib-git${_gitdate}.zip"::"http://cgit.freedesktop.org/mesa/mesa/snapshot/mesa-ef9f16f6322a89fb699fbe3da868b10f9acaef98.tar.bz2")
else
- source=(${source[@]} "ftp://ftp.freedesktop.org/pub/mesa/${pkgver}/MesaLib-${pkgver}.tar.bz2"
+ source=(${source[@]} "ftp://ftp.freedesktop.org/pub/mesa/older-versions/8.x/${pkgver}/MesaLib-${pkgver}.tar.bz2"
#source=(${source[@]} "ftp://ftp.freedesktop.org/pub/mesa/8.0/MesaLib-8.0-rc2.tar.bz2"
#source=(${source[@]} "MesaLib-git${_gitdate}.zip"::"http://cgit.freedesktop.org/mesa/mesa/snapshot/mesa-4464ee1a9aa3745109cee23531e3fb2323234d07.tar.bz2"
)
@@ -223,6 +223,13 @@ package_mesa() {
rm -f "${pkgdir}/usr/include/GL/glut.h"
rm -rf ${pkgdir}/usr/include/{GLES,GLES2,EGL,KHR}
+ #remove glu files
+ rm -f "${pkgdir}/usr/include/GL/glu.h"
+ rm -f "${pkgdir}/usr/include/GL/glu_mangle.h"
+ rm -f "${pkgdir}/usr/lib/libGLU.so"
+ rm -f "${pkgdir}/usr/lib/libGLU.so.1"
+ rm -f "${pkgdir}/usr/lib/pkgconfig/glu.pc"
+
install -m755 -d "${pkgdir}/usr/share/licenses/mesa"
install -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/mesa/"
}