summaryrefslogtreecommitdiffstats
path: root/abs/core/mjpegtools
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-13 21:35:22 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-13 21:35:22 (GMT)
commit6e5b49cc743b65672e0a3c385d233827ce51a0d8 (patch)
treee09fee1a0d7673550f1dd4c38fece5290576f77e /abs/core/mjpegtools
parentb3c1f8f3546f92e6be7addaee066e5130678bbc1 (diff)
downloadlinhes_pkgbuild-6e5b49cc743b65672e0a3c385d233827ce51a0d8.zip
linhes_pkgbuild-6e5b49cc743b65672e0a3c385d233827ce51a0d8.tar.gz
linhes_pkgbuild-6e5b49cc743b65672e0a3c385d233827ce51a0d8.tar.bz2
mjpegtools: 2.0
Diffstat (limited to 'abs/core/mjpegtools')
-rw-r--r--abs/core/mjpegtools/PKGBUILD36
-rw-r--r--abs/core/mjpegtools/__changelog2
-rw-r--r--abs/core/mjpegtools/gcc_3.7.patch11
-rw-r--r--abs/core/mjpegtools/mjpegtools-v4l-2.6.38.patch100
-rw-r--r--abs/core/mjpegtools/mjpegtools.install16
5 files changed, 165 insertions, 0 deletions
diff --git a/abs/core/mjpegtools/PKGBUILD b/abs/core/mjpegtools/PKGBUILD
new file mode 100644
index 0000000..3615c32
--- /dev/null
+++ b/abs/core/mjpegtools/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 148854 2012-02-05 11:52:58Z ibiru $
+# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
+# Maintainer: Roberto Carvajal <roberto@archlinux.org>
+
+pkgname=mjpegtools
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Set of tools that can do recording of videos and playback, simple cut-and-paste editing and the MPEG compression of audio and video"
+arch=(i686 x86_64)
+license=('GPL')
+url="http://mjpeg.sourceforge.net/"
+depends=('libjpeg' 'libpng' 'sdl' 'gcc-libs' 'libdv')
+makedepends=('gtk2' 'v4l-utils')
+optdepends=('gtk2: glav GUI')
+options=('!makeflags' '!libtool')
+install=mjpegtools.install
+source=(http://downloads.sourceforge.net/sourceforge/mjpeg/${pkgname}-${pkgver}.tar.gz
+ mjpegtools-v4l-2.6.38.patch gcc_3.7.patch)
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np0 -i "${srcdir}/mjpegtools-v4l-2.6.38.patch"
+ patch -Np1 -i "${srcdir}/gcc_3.7.patch"
+ sed -i -e '/ARCHFLAGS=/s:=.*:=:' configure
+ ./configure --prefix=/usr --enable-largefile
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -m644 mpeg2enc/mpeg2syntaxcodes.h "${pkgdir}/usr/include/mjpegtools/mpeg2enc/"
+}
+md5sums=('903e1e3b967eebcc5fe5626d7517dc46'
+ '44006d6f844017fe57aa123aa43f4508'
+ '7c9b3d4a1f3a10e3263a6a110b0f55cc')
diff --git a/abs/core/mjpegtools/__changelog b/abs/core/mjpegtools/__changelog
new file mode 100644
index 0000000..8244652
--- /dev/null
+++ b/abs/core/mjpegtools/__changelog
@@ -0,0 +1,2 @@
+added gcc 3.7.patch
+https://bugs.gentoo.org/show_bug.cgi?id=409197
diff --git a/abs/core/mjpegtools/gcc_3.7.patch b/abs/core/mjpegtools/gcc_3.7.patch
new file mode 100644
index 0000000..050b33f
--- /dev/null
+++ b/abs/core/mjpegtools/gcc_3.7.patch
@@ -0,0 +1,11 @@
+--- a/y4mdenoise/MotionSearcher.hh
++++ b/y4mdenoise/MotionSearcher.hh
+@@ -2196,7 +2196,7 @@
+ {
+ // This region is too small to be bothered with.
+ // Just get rid of it.
+- DeleteRegion (a_pRegion);
++ this->DeleteRegion (a_pRegion);
+ }
+ else
+ {
diff --git a/abs/core/mjpegtools/mjpegtools-v4l-2.6.38.patch b/abs/core/mjpegtools/mjpegtools-v4l-2.6.38.patch
new file mode 100644
index 0000000..6adeb92
--- /dev/null
+++ b/abs/core/mjpegtools/mjpegtools-v4l-2.6.38.patch
@@ -0,0 +1,100 @@
+Index: lavtools/lavvideo.c
+===================================================================
+--- lavtools/lavvideo.c.orig
++++ lavtools/lavvideo.c
+@@ -63,7 +63,7 @@ Copyright by Gernot Ziegler.
+ * errors here, check your linux/time.h && sys/time.h header setup.
+ */
+ #define _LINUX_TIME_H
+-#include <linux/videodev.h>
++#include <libv4l1-videodev.h>
+
+ #include <videodev_mjpeg.h>
+ #include <frequencies.h>
+Index: lavtools/liblavplay.c
+===================================================================
+--- lavtools/liblavplay.c.orig
++++ lavtools/liblavplay.c
+@@ -68,7 +68,8 @@
+ * errors here, check your linux/time.h && sys/time.h header setup.
+ */
+ #define _LINUX_TIME_H
+-#include <linux/videodev.h>
++#include <libv4l1-videodev.h>
++#define BASE_VIDIOCPRIVATE 192 /* 192-255 are private */
+ #else
+ #define VIDEO_MODE_PAL 0
+ #define VIDEO_MODE_NTSC 1
+Index: lavtools/liblavrec.c
+===================================================================
+--- lavtools/liblavrec.c.orig
++++ lavtools/liblavrec.c
+@@ -63,7 +63,8 @@
+ * errors here, check your linux/time.h && sys/time.h header setup.
+ */
+ #define _LINUX_TIME_H
+-#include <linux/videodev.h>
++#include <libv4l1-videodev.h>
++#define BASE_VIDIOCPRIVATE 192 /* 192-255 are private */
+ #ifdef HAVE_SYS_SOUNDCARD_H
+ #include <sys/soundcard.h>
+ #endif
+Index: lavtools/testrec.c
+===================================================================
+--- lavtools/testrec.c.orig
++++ lavtools/testrec.c
+@@ -89,7 +89,7 @@
+ * errors here, check your linux/time.h && sys/time.h header setup.
+ */
+ #define _LINUX_TIME_H
+-#include <linux/videodev.h>
++#include <libv4l1-videodev.h>
+ #include <linux/soundcard.h>
+
+ /* These are explicit prototypes for the compiler, to prepare separation of audiolib.c */
+Index: configure.ac
+===================================================================
+--- configure.ac.orig
++++ configure.ac
+@@ -164,7 +164,7 @@ AC_ARG_WITH([v4l], AC_HELP_STRING([--wit
+ AS_IF([test "x$with_v4l" != "xno"], [
+ case $host in
+ *-*-linux*)
+- AC_CHECK_HEADER(linux/videodev.h,
++ AC_CHECK_HEADER(libv4l1-videodev.h,
+ [have_video4linux=true
+ AC_DEFINE(HAVE_V4L, 1,
+ [Building for Linux - using the video4linux API])], [])
+@@ -173,7 +173,7 @@ esac])
+
+ AS_IF([test "x$have_video4linux" != "xtrue" && test "x$with_v4l" != "xno"],
+ [have_video4linux=false
+- AC_MSG_WARN([videodev.h not found - please install the linux kernel headers programms needing v4l disabled])])
++ AC_MSG_WARN([libv4l1-videodev.h not found - please install the linux kernel headers programms needing v4l disabled])])
+ AM_CONDITIONAL(HAVE_V4L, test x$have_video4linux = xtrue)
+
+ dnl *********************************************************************
+Index: configure
+===================================================================
+--- configure.orig
++++ configure
+@@ -16392,7 +16392,7 @@ if test "x$with_v4l" != "xno"; then :
+
+ case $host in
+ *-*-linux*)
+- ac_fn_c_check_header_mongrel "$LINENO" "linux/videodev.h" "ac_cv_header_linux_videodev_h" "$ac_includes_default"
++ ac_fn_c_check_header_mongrel "$LINENO" "libv4l1-videodev.h" "ac_cv_header_linux_videodev_h" "$ac_includes_default"
+ if test "x$ac_cv_header_linux_videodev_h" = xyes; then :
+ have_video4linux=true
+
+@@ -16407,8 +16407,8 @@ fi
+
+ if test "x$have_video4linux" != "xtrue" && test "x$with_v4l" != "xno"; then :
+ have_video4linux=false
+- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: videodev.h not found - please install the linux kernel headers programms needing v4l disabled" >&5
+-$as_echo "$as_me: WARNING: videodev.h not found - please install the linux kernel headers programms needing v4l disabled" >&2;}
++ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: libv4l1-videodev.h not found - please install the linux kernel headers programms needing v4l disabled" >&5
++$as_echo "$as_me: WARNING: libv4l1-videodev.h not found - please install the linux kernel headers programms needing v4l disabled" >&2;}
+ fi
+ if test x$have_video4linux = xtrue; then
+ HAVE_V4L_TRUE=
diff --git a/abs/core/mjpegtools/mjpegtools.install b/abs/core/mjpegtools/mjpegtools.install
new file mode 100644
index 0000000..4d12316
--- /dev/null
+++ b/abs/core/mjpegtools/mjpegtools.install
@@ -0,0 +1,16 @@
+infodir=usr/share/info
+file=mjpeg-howto.info
+
+post_install() {
+ [[ -x usr/bin/install-info ]] || return 0
+ install-info $infodir/$file.gz $infodir/dir 2> /dev/null
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [[ -x usr/bin/install-info ]] || return 0
+ install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
+}