summaryrefslogtreecommitdiffstats
path: root/abs/core/mkinitcpio
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
commit2648e999d277eac5c3d331a3609bcc73fafbea71 (patch)
tree40951fb8e7fdbe28a0baa324ae615055203f1e2e /abs/core/mkinitcpio
parentc759b5e0c4aa6fc37412b4dee2cf9ad993fd376d (diff)
parent7e6f7ca174e1af67178dc5293a312a4a733eb095 (diff)
downloadlinhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.zip
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.gz
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.bz2
Merge branch 'testing'
# By James Meyer (1091) and others # Via James Meyer (5) and others * testing: (1148 commits) LinHES-config: during install don't kill off lirc. This keeps the remote active all the way to the finish Change version numbers to 8.0 to match the release number. LinHES-conifg LinHES-system mythdb-initial runit-scripts supplemental-web LinHES-conifig: mv_install.py for the last partition don't go all the way to the end. Gotta leave room for gpt tables. xf86-video-ati: xorg ati driver. LinHES-config: timezip.py add syncing up of parental lvl passwords and starting level with MBE. LinHES-system: correct the logic for breaking out of the wmctrl loop. As written it would break out of the inner loop..but not the 60 iteration loop. e16_theme_settings: remove slide-in prop for new windows. For whatever reason this was preventing mplayer from being positioned correctly for appletrailers. LinHES-config, mythinstall: change case of hd_pvr and serial to all lower refs #902 zilog-firmware: firmware for TX support of the hdpvr and pvr-150 In general I can't recommend anybody using these transmitters but including the firmware just in case someone really wants to linhes-udev-rules: added hdprv_lirc rule. All of these lirc rules are limited to exactly one device. If more then one device is present then only the last device in init will get the symlink runit-scripts: fix logging for igdeamon, add support to remote init script so that the blaster is always the first device in the chain. added support specificly for hd_pvr LinHES-system: add lh_system_restore and lh_system_backup. These scripts are called from the mythmenu. refs #900 iguanair: rebuild with python 2.7 LinHES-system: msg_daemon.py fix init and nasty bug related to timeout. In a nutshell timeout wouldn't work unless a msg without a timeout was called first. linhes-udev-rules: add rules for mce,streamzap,serial lirc devices. mythinstall: recompile for matching libs mythtv: latest .25-fixes and change mythbackup/restore call lh_system_$op to replace mythbackup/mythrestore. mythbackup no longer works correctly with the new windowmanager linhes-scripts: myth2mp3, myth2x264, myth2xvid: use mythutil to get cutlist LinHES-config, supplimental-web: Fix proxy numbering for Ceton infiniTV linhes-system: add additional stuff to the system backup and also introduced an exclude file. The exclude/include files are locate in /home/mythtv/backup_config/ ...
Diffstat (limited to 'abs/core/mkinitcpio')
-rw-r--r--abs/core/mkinitcpio/0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch29
-rw-r--r--abs/core/mkinitcpio/0002-shutdown-don-t-alert-udev-on-disable-VGs.patch28
-rw-r--r--abs/core/mkinitcpio/PKGBUILD33
-rw-r--r--abs/core/mkinitcpio/__changelog8
-rw-r--r--abs/core/mkinitcpio/mkinitcpio.conf.patch20
-rw-r--r--abs/core/mkinitcpio/mkinitcpio.install8
-rw-r--r--abs/core/mkinitcpio/mkinitcpio.patch20
7 files changed, 104 insertions, 42 deletions
diff --git a/abs/core/mkinitcpio/0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch b/abs/core/mkinitcpio/0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch
new file mode 100644
index 0000000..042a0b9
--- /dev/null
+++ b/abs/core/mkinitcpio/0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch
@@ -0,0 +1,29 @@
+From 7cf7ac4eb2c29a2b1aa748dae7658da5fbbc3a18 Mon Sep 17 00:00:00 2001
+From: Brian Parsons <brian@pmex.com>
+Date: Mon, 11 Jun 2012 17:30:10 -0400
+Subject: [PATCH 1/2] Update module filter to be aware of hyphens in the
+ MODULES array
+
+[dave: fix whitespace and re-add needed quoting]
+
+Signed-off-by: Dave Reisner <dreisner@archlinux.org>
+---
+ functions | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/functions b/functions
+index 4a62d8e..e9fb81a 100644
+--- a/functions
++++ b/functions
+@@ -590,7 +590,7 @@ write_image_config() {
+ . "$CONFIG"
+
+ # sanitize of any extra whitespace
+- read -ra modules <<< "$MODULES"
++ read -ra modules <<<"${MODULES//-/_}"
+ for mod in "${modules[@]}"; do
+ in_array "${mod%\?}" "${ADDED_MODULES[@]}" || continue
+ add+=("${mod%\?}")
+--
+1.7.10.4
+
diff --git a/abs/core/mkinitcpio/0002-shutdown-don-t-alert-udev-on-disable-VGs.patch b/abs/core/mkinitcpio/0002-shutdown-don-t-alert-udev-on-disable-VGs.patch
new file mode 100644
index 0000000..7a1aba9
--- /dev/null
+++ b/abs/core/mkinitcpio/0002-shutdown-don-t-alert-udev-on-disable-VGs.patch
@@ -0,0 +1,28 @@
+From c257b0d7b4dd1c3f9b63c6a27b68a27bc246acea Mon Sep 17 00:00:00 2001
+From: Dave Reisner <dreisner@archlinux.org>
+Date: Tue, 12 Jun 2012 19:18:18 -0400
+Subject: [PATCH 2/2] shutdown: don't alert udev on disable VGs
+
+Fixes FS#30271.
+
+Signed-off-by: Dave Reisner <dreisner@archlinux.org>
+---
+ shutdown | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/shutdown b/shutdown
+index ce7de23..fd88105 100644
+--- a/shutdown
++++ b/shutdown
+@@ -25,7 +25,7 @@ stop_device() {
+ read devname <"$1/dm/name"
+ lvm lvdisplay -c "/dev/mapper/$devname" | {
+ IFS=: read _ vgname _
+- lvm vgchange -an "$vgname"
++ lvm vgchange --noudevsync -an "$vgname"
+ }
+ ;;
+ raid*)
+--
+1.7.10.4
+
diff --git a/abs/core/mkinitcpio/PKGBUILD b/abs/core/mkinitcpio/PKGBUILD
index 0631650..e4415be 100644
--- a/abs/core/mkinitcpio/PKGBUILD
+++ b/abs/core/mkinitcpio/PKGBUILD
@@ -1,29 +1,30 @@
+# $Id: PKGBUILD 171244 2012-11-16 22:09:31Z dreisner $
+# Maintainer: Dave Reisner <dreisner@archlinux.org>
# Maintainer: Thomas Bächler <thomas@archlinux.org>
-
pkgname=mkinitcpio
-pkgver=0.7.2
-pkgrel=11
+pkgver=0.11.2
+pkgrel=1
pkgdesc="Modular initramfs image creation utility"
-arch=(any)
+arch=('any')
url="http://www.archlinux.org/"
license=('GPL')
-depends=('mkinitcpio-busybox>=1.16.1-2' 'mkinitcpio-nfs-utils=>0.2' 'module-init-tools' 'util-linux>=2.19' 'libarchive' 'coreutils'
- 'bash' 'findutils' 'sed' 'grep' 'filesystem>=2009.01-2' 'udev>=171-2' 'file' 'gzip'
- 'which')
+depends=('awk' 'mkinitcpio-busybox>=1.19.4-2' 'kmod' 'util-linux>=2.21' 'libarchive' 'coreutils'
+ 'bash' 'findutils' 'grep' 'filesystem>=2011.10-1' 'file' 'gzip' 'systemd-tools')
optdepends=('xz: Use lzma or xz compression for the initramfs image'
'bzip2: Use bzip2 compression for the initramfs image'
'lzop: Use lzo compression for the initramfs image'
'mkinitcpio-nfs-utils: Support for root filesystem on NFS')
-replaces=('mkinitrd' 'mkinitramfs' 'klibc' 'klibc-extras' 'klibc-kbd'
- 'klibc-module-init-tools' 'klibc-udev')
-source=(ftp://ftp.archlinux.org/other/${pkgname}/${pkgname}-${pkgver}.tar.gz mkinitcpio.conf.patch)
-backup=(etc/mkinitcpio.conf)
+backup=('etc/mkinitcpio.conf')
+source=("ftp://ftp.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"{,.sig} "mkinitcpio.patch")
+install=mkinitcpio.install
package() {
- cd $srcdir/${pkgname}-${pkgver}
- patch -p0 < $srcdir/mkinitcpio.conf.patch
- make DESTDIR="${pkgdir}" install
+ make -C "$pkgname-$pkgver" DESTDIR="$pkgdir" install
+ cd $pkgdir/etc
+ patch -Np0 < $srcdir/mkinitcpio.patch || exit 1
}
-md5sums=('e11670a7d4802b2ef20cab4b3815168a'
- '36da3320c907bf3b41b74fc824cbd1d8')
+
+md5sums=('cc437770a2f1a6ae63e14ac3c86defcf'
+ '5521e600fafa99522deb4f112f2e57cb'
+ 'fa758c290731ab535c8d6995f0ff5ef0')
diff --git a/abs/core/mkinitcpio/__changelog b/abs/core/mkinitcpio/__changelog
index c8dbb63..a2eacb9 100644
--- a/abs/core/mkinitcpio/__changelog
+++ b/abs/core/mkinitcpio/__changelog
@@ -1,6 +1,2 @@
-added "usb" and net to the modules line in mkinitcpio.conf
-+HOOKS="base udev usb net autodetect pata scsi sata filesystems usbinput"
-
-MODULES="nfs"
-
-added depends: mkinitcpio-nfs-utils
+modified mkinitcpio.patch to move fsck earlier in the hook
+this is needed so that drives other then / can mount during boot
diff --git a/abs/core/mkinitcpio/mkinitcpio.conf.patch b/abs/core/mkinitcpio/mkinitcpio.conf.patch
deleted file mode 100644
index 800b347..0000000
--- a/abs/core/mkinitcpio/mkinitcpio.conf.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- mkinitcpio.conf.orig 2011-08-06 00:04:15.991131194 +0000
-+++ mkinitcpio.conf 2011-08-06 00:04:02.791130644 +0000
-@@ -4,7 +4,7 @@
- # run. Advanced users may wish to specify all system modules
- # in this array. For instance:
- # MODULES="piix ide_disk reiserfs"
--MODULES=""
-+MODULES="nfs"
-
- # BINARIES
- # This setting includes any additional binaries a given user may
-@@ -54,7 +54,7 @@
- #
- ## This setup loads an lvm2 volume group on a usb device.
- # HOOKS="base udev usb lvm2 filesystems"
--HOOKS="base udev autodetect pata scsi sata filesystems usbinput"
-+HOOKS="base udev usb net autodetect pata scsi sata filesystems usbinput fbsplash"
-
- # COMPRESSION
- # Use this to compress the initramfs image. With kernels earlier than
diff --git a/abs/core/mkinitcpio/mkinitcpio.install b/abs/core/mkinitcpio/mkinitcpio.install
new file mode 100644
index 0000000..d8bbfdb
--- /dev/null
+++ b/abs/core/mkinitcpio/mkinitcpio.install
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+post_upgrade() {
+ if [ "$(vercmp 0.9.0 "$2")" -eq 1 ]; then
+ printf '==> If your /usr is on a separate partition, you must add the "usr" hook\n'
+ printf ' to /etc/mkinitcpio.conf and regenerate your images before rebooting\n'
+ fi
+}
diff --git a/abs/core/mkinitcpio/mkinitcpio.patch b/abs/core/mkinitcpio/mkinitcpio.patch
new file mode 100644
index 0000000..ffc21fc
--- /dev/null
+++ b/abs/core/mkinitcpio/mkinitcpio.patch
@@ -0,0 +1,20 @@
+--- mkinitcpio.conf.orig 2012-08-22 23:26:28.952203845 +0000
++++ mkinitcpio.conf 2012-08-22 23:25:44.408871852 +0000
+@@ -4,7 +4,7 @@
+ # run. Advanced users may wish to specify all system modules
+ # in this array. For instance:
+ # MODULES="piix ide_disk reiserfs"
+-MODULES=""
++MODULES="nfs reiserfs xfs jfs ext4"
+
+ # BINARIES
+ # This setting includes any additional binaries a given user may
+@@ -56,7 +56,7 @@
+ #
+ ## NOTE: If you have /usr on a separate partition, you MUST include the
+ # usr, fsck and shutdown hooks.
+-HOOKS="base udev autodetect pata scsi sata filesystems usbinput fsck"
++HOOKS="base udev fsck autodetect pata scsi sata filesystems usb usbinput resume v86d plymouth"
+
+ # COMPRESSION
+ # Use this to compress the initramfs image. By default, gzip compression