summaryrefslogtreecommitdiffstats
path: root/abs/core/mkinitcpio
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-23 00:19:06 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-23 00:19:06 (GMT)
commit28d700dd62b49c3e6c3b3749a94a8778bf9d287a (patch)
tree670b71e6a244287f9373c90df45de4084196597e /abs/core/mkinitcpio
parentd2e4ca30c0b6ec1a4910f9b368f4755abafea263 (diff)
downloadlinhes_pkgbuild-28d700dd62b49c3e6c3b3749a94a8778bf9d287a.zip
linhes_pkgbuild-28d700dd62b49c3e6c3b3749a94a8778bf9d287a.tar.gz
linhes_pkgbuild-28d700dd62b49c3e6c3b3749a94a8778bf9d287a.tar.bz2
mkinitcpio: added patch for fsck,fbsplash hooks
Diffstat (limited to 'abs/core/mkinitcpio')
-rw-r--r--abs/core/mkinitcpio/PKGBUILD17
-rw-r--r--abs/core/mkinitcpio/__changelog2
-rw-r--r--abs/core/mkinitcpio/mkinitcpio.patch20
3 files changed, 33 insertions, 6 deletions
diff --git a/abs/core/mkinitcpio/PKGBUILD b/abs/core/mkinitcpio/PKGBUILD
index 282b2bb..32b9fdb 100644
--- a/abs/core/mkinitcpio/PKGBUILD
+++ b/abs/core/mkinitcpio/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=mkinitcpio
pkgver=0.9.2
-pkgrel=2
+pkgrel=3
pkgdesc="Modular initramfs image creation utility"
arch=('any')
url="http://www.archlinux.org/"
@@ -18,11 +18,9 @@ optdepends=('xz: Use lzma or xz compression for the initramfs image'
backup=('etc/mkinitcpio.conf')
source=("ftp://ftp.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"
0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch
- 0002-shutdown-don-t-alert-udev-on-disable-VGs.patch)
+ 0002-shutdown-don-t-alert-udev-on-disable-VGs.patch
+ mkinitcpio.patch)
install=mkinitcpio.install
-sha256sums=('1c388ab1df4ecdf6204602c66220a79adc2c564956fdf68deb7dde9bab331c28'
- '5e5f83a2f9805ce1b09602f31fd4aca93fa7085a40c74bc559cf25c29506b057'
- 'e32a7955b94e378698268f9cfd07fb0285a4efbdc4b26ea40714e7f1a54705a1')
package() {
cd "$pkgname-$pkgver"
@@ -31,9 +29,16 @@ package() {
patch -Np1 <"$srcdir"/0002-shutdown-don-t-alert-udev-on-disable-VGs.patch
make DESTDIR="$pkgdir" install
-
+
# compat symlink
install -dm755 "$pkgdir/sbin"
ln -s /usr/bin/mkinitcpio "$pkgdir/sbin/mkinitcpio"
+
+ cd $pkgdir/etc
+ patch -Np0 < $srcdir/mkinitcpio.patch || exit 1
}
+md5sums=('6894147b09012054e025bfbe03445cda'
+ 'e6e2aafa24f6c9d58b483e8df4dafdec'
+ 'ffd144b1c8b3950671dacdc1c4a5e80d'
+ 'e317ad4c65eae59eb75bd8adba8b0b4c')
diff --git a/abs/core/mkinitcpio/__changelog b/abs/core/mkinitcpio/__changelog
new file mode 100644
index 0000000..a2eacb9
--- /dev/null
+++ b/abs/core/mkinitcpio/__changelog
@@ -0,0 +1,2 @@
+modified mkinitcpio.patch to move fsck earlier in the hook
+this is needed so that drives other then / can mount during boot
diff --git a/abs/core/mkinitcpio/mkinitcpio.patch b/abs/core/mkinitcpio/mkinitcpio.patch
new file mode 100644
index 0000000..2b35f81
--- /dev/null
+++ b/abs/core/mkinitcpio/mkinitcpio.patch
@@ -0,0 +1,20 @@
+--- mkinitcpio.conf.orig 2012-08-22 23:26:28.952203845 +0000
++++ mkinitcpio.conf 2012-08-22 23:25:44.408871852 +0000
+@@ -4,7 +4,7 @@
+ # run. Advanced users may wish to specify all system modules
+ # in this array. For instance:
+ # MODULES="piix ide_disk reiserfs"
+-MODULES=""
++MODULES="nfs reiserfs xfs jfs ext4"
+
+ # BINARIES
+ # This setting includes any additional binaries a given user may
+@@ -56,7 +56,7 @@
+ #
+ ## NOTE: If you have /usr on a separate partition, you MUST include the
+ # usr, fsck and shutdown hooks.
+-HOOKS="base udev autodetect pata scsi sata filesystems usbinput fsck"
++HOOKS="base udev fsck autodetect pata scsi sata filesystems usb usbinput resume fbsplash"
+
+ # COMPRESSION
+ # Use this to compress the initramfs image. By default, gzip compression