summaryrefslogtreecommitdiffstats
path: root/abs/core/mlocate
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-09 22:03:48 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-09 22:03:48 (GMT)
commit3da5ea3906e610ff21d9fec77e07e5b781ba3d5e (patch)
tree899e577940436e63bf73517e63adda511070c1f8 /abs/core/mlocate
parent6e266cb2cab769f484532311206e5f548669b49b (diff)
downloadlinhes_pkgbuild-3da5ea3906e610ff21d9fec77e07e5b781ba3d5e.zip
linhes_pkgbuild-3da5ea3906e610ff21d9fec77e07e5b781ba3d5e.tar.gz
linhes_pkgbuild-3da5ea3906e610ff21d9fec77e07e5b781ba3d5e.tar.bz2
mlocate .25
Diffstat (limited to 'abs/core/mlocate')
-rw-r--r--abs/core/mlocate/PKGBUILD35
-rw-r--r--abs/core/mlocate/mlocate.db0
-rw-r--r--abs/core/mlocate/mlocate.install18
-rw-r--r--abs/core/mlocate/updatedb.conf9
4 files changed, 21 insertions, 41 deletions
diff --git a/abs/core/mlocate/PKGBUILD b/abs/core/mlocate/PKGBUILD
index 62f7864..1e863a5 100644
--- a/abs/core/mlocate/PKGBUILD
+++ b/abs/core/mlocate/PKGBUILD
@@ -1,52 +1,51 @@
-# $Id: PKGBUILD 97017 2010-10-26 01:53:05Z allan $
+# $Id: PKGBUILD 162719 2012-06-29 02:14:10Z allan $
# Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: lydgate
pkgname=mlocate
-pkgver=0.23.1
+pkgver=0.25
pkgrel=2
pkgdesc="Faster merging drop-in for slocate"
arch=('i686' 'x86_64')
url="http://carolina.mff.cuni.cz/~trmac/blog/mlocate"
license=('GPL')
-conflicts=('slocate')
-provides=('slocate')
-replaces=('slocate')
depends=('glibc' 'coreutils' 'sh')
backup=('etc/updatedb.conf'
'etc/cron.daily/updatedb')
-install=mlocate.install
source=(https://fedorahosted.org/releases/m/l/mlocate/mlocate-$pkgver.tar.xz
updatedb.conf
updatedb.cron.daily)
-md5sums=('db48f27fae91c754c46d8046919803c5'
- 'c374ff223f2e07b5e602ba22359f2335'
+md5sums=('c6d043b170613b0e327a815b497f680a'
+ 'b56d81de17fe29b01b4b28861acb8fd4'
'cde5da81bebad2de556ef2e43d895e13')
build() {
cd $srcdir/$pkgname-$pkgver
- # Build!
sed -i '/^groupname /s/mlocate/locate/' Makefile.in
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib
make
+
+}
+
+check() {
+ cd $srcdir/$pkgname-$pkgver
make check
}
package() {
cd $srcdir/$pkgname-$pkgver
-
- # Set up a default updatedb.conf and a daily cronjob
- install -Dm644 ${srcdir}/updatedb.conf $pkgdir/etc/updatedb.conf
- install -Dm744 ${srcdir}/updatedb.cron.daily $pkgdir/etc/cron.daily/updatedb
- # Install Mlocate
make DESTDIR=$pkgdir install
- ln -sv locate $pkgdir/usr/bin/slocate
- chgrp -v 21 $pkgdir/usr/bin/locate
- chmod -v 2755 $pkgdir/usr/bin/locate
+ ln -s locate $pkgdir/usr/bin/slocate
+ chgrp 21 $pkgdir/usr/bin/locate
+ chmod 2755 $pkgdir/usr/bin/locate
install -dm755 $pkgdir/var/lib
- install -d -m750 -g21 $pkgdir/var/lib/locate
+ install -dm750 -g21 $pkgdir/var/lib/locate
+
+ # Set up a default updatedb.conf and a daily cronjob
+ install -Dm644 ${srcdir}/updatedb.conf $pkgdir/etc/updatedb.conf
+ install -Dm744 ${srcdir}/updatedb.cron.daily $pkgdir/etc/cron.daily/updatedb
}
diff --git a/abs/core/mlocate/mlocate.db b/abs/core/mlocate/mlocate.db
deleted file mode 100644
index e69de29..0000000
--- a/abs/core/mlocate/mlocate.db
+++ /dev/null
diff --git a/abs/core/mlocate/mlocate.install b/abs/core/mlocate/mlocate.install
deleted file mode 100644
index c7b7f9c..0000000
--- a/abs/core/mlocate/mlocate.install
+++ /dev/null
@@ -1,18 +0,0 @@
-post_install() {
- post_upgrade "$1" "$1"
- echo "mlocate command is technically locate, but slocate is symlinked and still works."
- echo "You should run updatedb as root."
-}
-
-post_upgrade() {
- # This can be removed after {m,x}locate have both been updated
- getent group slocate &>/dev/null && usr/sbin/groupdel slocate &>/dev/null
- getent group mlocate &>/dev/null && usr/sbin/groupdel mlocate &>/dev/null
-
- getent group locate &>/dev/null || usr/sbin/groupadd -g 21 locate &>/dev/null
- chown -R root:locate var/lib/mlocate
-}
-
-pre_remove() {
- getent group locate &>/dev/null && usr/sbin/groupdel locate &>/dev/null
-}
diff --git a/abs/core/mlocate/updatedb.conf b/abs/core/mlocate/updatedb.conf
index 722b042..633c174 100644
--- a/abs/core/mlocate/updatedb.conf
+++ b/abs/core/mlocate/updatedb.conf
@@ -1,5 +1,4 @@
-# directories to exclude from the slocate database:
-PRUNEPATHS="/media /mnt /tmp /var/tmp /var/cache /var/lock /var/run /var/spool"
-
-# filesystems to exclude from the slocate database:
-PRUNEFS="afs auto autofs binfmt_misc cifs coda configfs cramfs debugfs devpts devtmpfs ftpfs iso9660 mqueue ncpfs nfs nfs4 proc ramfs securityfs shfs smbfs sshfs sysfs tmpfs udf usbfs vboxsf"
+PRUNE_BIND_MOUNTS = "yes"
+PRUNEFS = "9p afs anon_inodefs auto autofs bdev binfmt_misc cgroup cifs coda configfs cpuset cramfs debugfs devpts devtmpfs ecryptfs exofs ftpfs fuse fuse.encfs fuse.sshfs fusectl gfs gfs2 hugetlbfs inotifyfs iso9660 jffs2 lustre mqueue ncpfs nfs nfs4 nfsd pipefs proc ramfs rootfs rpc_pipefs securityfs selinuxfs sfs shfs smbfs sockfs sshfs sysfs tmpfs ubifs udf usbfs vboxsf"
+PRUNENAMES = ".git .hg .svn"
+PRUNEPATHS = "/afs /media /mnt /net /sfs /tmp /udev /var/cache /var/lib/pacman/local /var/lock /var/run /var/spool /var/tmp"