summaryrefslogtreecommitdiffstats
path: root/abs/core/mpfr
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/mpfr
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/mpfr')
-rw-r--r--abs/core/mpfr/PKGBUILD26
-rw-r--r--abs/core/mpfr/mpfr.install18
2 files changed, 44 insertions, 0 deletions
diff --git a/abs/core/mpfr/PKGBUILD b/abs/core/mpfr/PKGBUILD
new file mode 100644
index 0000000..ac2ab77
--- /dev/null
+++ b/abs/core/mpfr/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 12992 2008-09-25 17:47:29Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: damir <damir@archlinux.org>
+
+pkgname=mpfr
+pkgver=2.3.2
+pkgrel=2
+pkgdesc="multiple-precision floating-point library"
+arch=(i686 x86_64)
+license=('GPL' 'LGPL')
+url="http://www.mpfr.org/"
+depends=('gmp>=4.2.3' 'texinfo')
+options=('!libtool')
+install=mpfr.install
+#source=(http://www.mpfr.org/mpfr-current/mpfr-${pkgver}.tar.gz)
+
+source=(http://modular.math.washington.edu/home/novocin/tars/mpfr-2.3.2.tar.gz)
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --enable-thread-safe --enable-shared || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+ cd "${pkgdir}/usr/share/info" || return 1
+ rm -f dir
+ gzip * || return 1
+}
diff --git a/abs/core/mpfr/mpfr.install b/abs/core/mpfr/mpfr.install
new file mode 100644
index 0000000..a95dec6
--- /dev/null
+++ b/abs/core/mpfr/mpfr.install
@@ -0,0 +1,18 @@
+info_dir=/usr/share/info
+info_files=(mpfr.info)
+
+post_install() {
+ for f in ${info_files[@]}; do
+ install-info ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ for f in ${info_files[@]}; do
+ install-info --delete ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
+ done
+}