summaryrefslogtreecommitdiffstats
path: root/abs/core/mysql
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-12-10 20:16:25 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-12-10 20:16:25 (GMT)
commit5c9d6e7ec4c9d5c167c5846eabfd717e4b0d6c3a (patch)
treee89fea689c2749a8dbe9989f214d979c3b96f907 /abs/core/mysql
parent8570bfa9cd30521c86e27984f34a3a81456a9c25 (diff)
downloadlinhes_pkgbuild-5c9d6e7ec4c9d5c167c5846eabfd717e4b0d6c3a.zip
linhes_pkgbuild-5c9d6e7ec4c9d5c167c5846eabfd717e4b0d6c3a.tar.gz
linhes_pkgbuild-5c9d6e7ec4c9d5c167c5846eabfd717e4b0d6c3a.tar.bz2
mysql: update to 5.6.22.
adjust some my.cnf options
Diffstat (limited to 'abs/core/mysql')
-rw-r--r--abs/core/mysql/PKGBUILD6
-rwxr-xr-xabs/core/mysql/my.cnf15
2 files changed, 11 insertions, 10 deletions
diff --git a/abs/core/mysql/PKGBUILD b/abs/core/mysql/PKGBUILD
index b65aa04..af83d84 100644
--- a/abs/core/mysql/PKGBUILD
+++ b/abs/core/mysql/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=('mysql' 'libmysqlclient' 'mysql-clients')
pkgbase=mysql
-pkgver=5.6.21
+pkgver=5.6.22
pkgrel=1
pkgdesc="Fast SQL database server, community edition"
arch=('i686' 'x86_64')
@@ -167,9 +167,9 @@ package_mysql(){
rm "${pkgdir}/usr/share/man/man1/mysql-test-run.pl.1"
}
-md5sums=('e47c3a70b8d89db3199a349204b2ae4e'
+md5sums=('3985b634294482363f3d87e0d67f2262'
'b79e65a5aa536e6b5bc60988eb0b78a2'
'2fa6e456964d4ff5e6d4f9ff0126aed6'
'81b62df0f569935109c1b107dfe9f9fa'
- '162238ee0665e68b37136f3e046123a1'
+ '75121ffbbd47367c27ae0448f6282b57'
'f2b34ac2954bb56c4abf08c66a7f840e')
diff --git a/abs/core/mysql/my.cnf b/abs/core/mysql/my.cnf
index f0b87da..da26759 100755
--- a/abs/core/mysql/my.cnf
+++ b/abs/core/mysql/my.cnf
@@ -30,18 +30,19 @@ datadir = /data/srv/mysql
skip-external-locking
net_buffer_length = 8K
-key_buffer_size = 384M
+key_buffer_size = 96M
max_allowed_packet = 1M
-table_open_cache = 256
-tmp_table_size = 32M
-max_heap_table_size = 32M
+tmp_table_size = 128M
+max_heap_table_size = 128M
sort_buffer_size = 2M
read_buffer_size = 2M
-read_rnd_buffer_size = 4M
+read_rnd_buffer_size = 2M
myisam_sort_buffer_size = 64M
thread_cache_size = 8
-query_cache_size = 32M
-join_buffer_size = 128K
+query_cache_type = 1
+query_cache_size = 64M
+query_cache_limit = 2M
+join_buffer_size = 2M
# Don't listen on a TCP/IP port at all. This can be a security enhancement,