summaryrefslogtreecommitdiffstats
path: root/abs/core/mysql
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
commitc4bd4457b5d640e1c8f5afbca7cd54c53691e5fc (patch)
treef4e4f7a91e1d9d90033fd99d89e5e26a2c144528 /abs/core/mysql
parent0e7b327a1ae444233f1308a95420f70540ad74a3 (diff)
downloadlinhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.zip
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.gz
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.bz2
RSYNC CORE:
resync core-testing -> core Signed-off-by: James Meyer <james.meyer@operamail.com>
Diffstat (limited to 'abs/core/mysql')
-rw-r--r--abs/core/mysql/PKGBUILD8
-rw-r--r--abs/core/mysql/__changelog5
-rw-r--r--abs/core/mysql/my.cnf11
3 files changed, 18 insertions, 6 deletions
diff --git a/abs/core/mysql/PKGBUILD b/abs/core/mysql/PKGBUILD
index 11df8fb..c91ac41 100644
--- a/abs/core/mysql/PKGBUILD
+++ b/abs/core/mysql/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: judd <jvinet@zeroflux.org>
pkgname=mysql
pkgver=5.0.75
-pkgrel=3
+pkgrel=4
pkgdesc="A fast SQL database server"
arch=(i686 x86_64)
backup=(etc/my.cnf etc/conf.d/mysqld)
@@ -48,3 +48,9 @@ build() {
install -D -m644 ../mysqld.conf.d ${startdir}/pkg/etc/conf.d/mysqld
rm -f ${startdir}/pkg/usr/bin/mysql_config
}
+
+md5sums=('a234f0a60a7f8c290d9875cba3a2c5a2'
+ 'e892aac36cbeb57f0e003ec0936afb3b'
+ 'cfff3585dd70cde3ac1ce69e64008733'
+ '078f6e824d6097d558bcf7c16d508d92'
+ 'd81d1f51e9ee6941425a63456d07cb21')
diff --git a/abs/core/mysql/__changelog b/abs/core/mysql/__changelog
index 4fa7078..aa066aa 100644
--- a/abs/core/mysql/__changelog
+++ b/abs/core/mysql/__changelog
@@ -1,6 +1,11 @@
my.cnf
-enable networking
-datadir /data/srv/mysql
+-query_cache_size
+-tmp_table_size
+-max_heap_table_size
+-thread_cache_size
+-table_cache
mysqld
-redirect output to /dev/null
diff --git a/abs/core/mysql/my.cnf b/abs/core/mysql/my.cnf
index 7202fcd..e13331e 100644
--- a/abs/core/mysql/my.cnf
+++ b/abs/core/mysql/my.cnf
@@ -1,8 +1,4 @@
-# mysql config file for medium systems.
-#
-# This is for a system with little memory (32M - 64M) where MySQL plays
-# a important part and systems up to 128M where MySQL is used together with
-# other programs (like a web server)
+# mysql config file for LinHES.
#
# One can in this file use all long options that the program supports.
# If you want to know which options a program support, run the program
@@ -28,6 +24,11 @@ table_cache = 64
sort_buffer_size = 512K
net_buffer_length = 16K
myisam_sort_buffer_size = 8M
+query_cache_size = 8M
+tmp_table_size = 36M
+max_heap_table_size = 24M
+thread_cache_size = 4
+table_cache = 96
# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.