summaryrefslogtreecommitdiffstats
path: root/abs/core/mythdb-initial
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-01-09 22:44:26 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-01-09 22:44:26 (GMT)
commit19558d2bbdf4b31e21c7707c86a077d62ab26d3c (patch)
tree131a68dddc1e9fa7c25ab80e5793535816daa6d3 /abs/core/mythdb-initial
parent3177bc9e67077cdaa2769cf44a8d539528ca4a3f (diff)
downloadlinhes_pkgbuild-19558d2bbdf4b31e21c7707c86a077d62ab26d3c.zip
linhes_pkgbuild-19558d2bbdf4b31e21c7707c86a077d62ab26d3c.tar.gz
linhes_pkgbuild-19558d2bbdf4b31e21c7707c86a077d62ab26d3c.tar.bz2
LinHES-system, runit-scripts, mythdb-initial: autocard.py will run when mythbackend starts if /etc/udev/mv-persistent-video.description is not present.
LinHES-system: wait for autocard to finish before stopping the be mythdb-initial: add a dummy tuner, so that myth backend will start. This get around the chicken/egg problem of needing tuners defined before MBE can start. However to add tuners via the API mythbe must be started. refs #892
Diffstat (limited to 'abs/core/mythdb-initial')
-rwxr-xr-xabs/core/mythdb-initial/PKGBUILD4
-rw-r--r--abs/core/mythdb-initial/custom.sql11
2 files changed, 13 insertions, 2 deletions
diff --git a/abs/core/mythdb-initial/PKGBUILD b/abs/core/mythdb-initial/PKGBUILD
index 320ae30..fda32db 100755
--- a/abs/core/mythdb-initial/PKGBUILD
+++ b/abs/core/mythdb-initial/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mythdb-initial
pkgver=2
-pkgrel=47
+pkgrel=48
pkgdesc="setup the initial mythtv database for linhes"
url=""
license=""
@@ -21,4 +21,4 @@ build() {
}
md5sums=('9dcf8c574e69fde6b1b2fa1eed95ded4'
'ad0e57ac5e7c3677808a670e16634bba'
- '993fe1bff5df6005d06bd6fbdf3e6ce1')
+ '814622daded79510217a96da960b24bd')
diff --git a/abs/core/mythdb-initial/custom.sql b/abs/core/mythdb-initial/custom.sql
index 6cc9663..de8e948 100644
--- a/abs/core/mythdb-initial/custom.sql
+++ b/abs/core/mythdb-initial/custom.sql
@@ -147,4 +147,15 @@ INSERT INTO `settings` (`value`, `data`, `hostname`) VALUES
('HostUseALLdata', '1' , 'apheleia'),
('HOSTdatafstype', 'xfs' , 'apheleia');
+-- Add a dummy tuner so BE will at least start
+INSERT INTO `capturecard` (`videodevice`,`cardtype`,`defaultinput`,`hostname`) VALUES
+('file://tmp/demo.mpg' , 'DEMO', 'Television', 'apheleia');
+
+INSERT INTO `videosource` (`name`, `xmltvgrabber`) VALUES
+('DEMO_VIDEO_SOURCE' , '/bin/true');
+
+INSERT INTO `cardinput` (`cardid`,`sourceid`,`inputname`) VALUES
+('1','1','MPEG2TS');
+
+