summaryrefslogtreecommitdiffstats
path: root/abs/core/mythdb-initial
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-02-18 17:09:20 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-02-18 17:09:20 (GMT)
commit83169ccfc4ef74057bcd3310c105a6ff2190b442 (patch)
tree3ddc2e9551f86e62b17d48524990476091b81c45 /abs/core/mythdb-initial
parent64de605c2bbf7fea4c80fe803bb229593d9fafbf (diff)
downloadlinhes_pkgbuild-83169ccfc4ef74057bcd3310c105a6ff2190b442.zip
linhes_pkgbuild-83169ccfc4ef74057bcd3310c105a6ff2190b442.tar.gz
linhes_pkgbuild-83169ccfc4ef74057bcd3310c105a6ff2190b442.tar.bz2
default to Notify update plan. refs #959.
add default user jobs. refs #958.
Diffstat (limited to 'abs/core/mythdb-initial')
-rwxr-xr-xabs/core/mythdb-initial/PKGBUILD4
-rw-r--r--abs/core/mythdb-initial/custom.sql30
2 files changed, 24 insertions, 10 deletions
diff --git a/abs/core/mythdb-initial/PKGBUILD b/abs/core/mythdb-initial/PKGBUILD
index d1566a5..15bdda4 100755
--- a/abs/core/mythdb-initial/PKGBUILD
+++ b/abs/core/mythdb-initial/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mythdb-initial
pkgver=8.1
-pkgrel=1
+pkgrel=2
pkgdesc="setup the initial mythtv database for linhes"
url=""
license=""
@@ -22,4 +22,4 @@ package() {
md5sums=('366c1fe7668739d2d5c1123f9f4ee110'
'ad0e57ac5e7c3677808a670e16634bba'
- '8c5aa22be114fc20298891d37928cd2e')
+ 'ab918fe2b583364d3cbd476234b45c80')
diff --git a/abs/core/mythdb-initial/custom.sql b/abs/core/mythdb-initial/custom.sql
index 99a0452..98a9b33 100644
--- a/abs/core/mythdb-initial/custom.sql
+++ b/abs/core/mythdb-initial/custom.sql
@@ -4,26 +4,26 @@ DELETE FROM `settings` where `value`='HostMyhostname';
INSERT INTO `settings` (`value`,`data`,`hostname`) VALUES ('HostMyhostname','type_hostname_here','apheleia');
--
+-- set default settings for mythinstall/systemconfig
INSERT INTO `settings` (`value`, `data`, `hostname`) VALUES
('Hostpluginmytharchive','1','apheleia'),
('Hostpluginmythbrowser','1','apheleia'),
('Hostpluginmythcontrols','1','apheleia'),
- ('Hostpluginmythflix','1','apheleia'),
('Hostpluginmythgallery','1','apheleia'),
('Hostpluginmythgame','1','apheleia'),
+ ('HostpluginmythgameROMDB','0','apheleia'),
('HostpluginmythgameFceu','1','apheleia'),
('HostpluginmythgameMame','1','apheleia'),
('HostpluginmythgameZsnes','1','apheleia'),
- ('Hostpluginmythmovietime','1','apheleia'),
('Hostpluginmythmusic','1','apheleia'),
('Hostpluginmythnews','1','apheleia'),
('Hostpluginmythphone','1','apheleia'),
- ('Hostpluginmythsmolt','1','apheleia'),
('Hostpluginmythvideo','1','apheleia'),
('Hostpluginmythvideo_dvdcss','0','apheleia'),
('Hostpluginmythweather','1','apheleia'),
('Hostpluginmythappletrailers','1','apheleia'),
('HostBEWait','1','apheleia'),
+ ('Hostupdateplan','Notify','apheleia'),
('HostAudiotype','ALSA','apheleia');
-- Clear out old values because mysql is mysql
@@ -120,13 +120,30 @@ DELETE FROM `settings` where value in
('JobAllowUserJob1',
'JobAllowUserJob2',
'JobAllowUserJob3',
- 'JobAllowUserJob4');
+ 'JobAllowUserJob4',
+ 'UserJob1',
+ 'UserJob2',
+ 'UserJob3',
+ 'UserJob4',
+ 'UserJobDesc1',
+ 'UserJobDesc2',
+ 'UserJobDesc3',
+ 'UserJobDesc4');
+
INSERT INTO `settings` (`value`, `data`, `hostname`) VALUES
('JobAllowUserJob1','1','apheleia'),
('JobAllowUserJob2','1','apheleia'),
('JobAllowUserJob3','1','apheleia'),
- ('JobAllowUserJob4','1','apheleia');
+ ('JobAllowUserJob4','0','apheleia'),
+ ('UserJob1','/usr/LH/bin/mythvidexport.py %JOBID%','apheleia'),
+ ('UserJob2','/usr/LH/bin/myth2mkv "%DIR%/%FILE%" "%CHANID%" "%STARTTIME%" "%TITLE%" "%SUBTITLE%" "%JOBID%" "HP"','apheleia'),
+ ('UserJob3','/usr/LH/bin/myth2mp3 "%DIR%/%FILE%" "%TITLE% - %SUBTITLE%" "%CHANID%" "%STARTTIME%"','apheleia'),
+ ('UserJob4','','apheleia'),
+ ('UserJobDesc1','Copy to Videos','apheleia'),
+ ('UserJobDesc2','Encode to x264 mkv','apheleia'),
+ ('UserJobDesc3','Encode Audio to mp3','apheleia'),
+ ('UserJobDesc4','','apheleia');
--
@@ -164,6 +181,3 @@ INSERT INTO `videosource` (`name`, `xmltvgrabber`) VALUES
INSERT INTO `cardinput` (`cardid`,`sourceid`,`inputname`) VALUES
('1','1','MPEG2TS');
-
-
-