summaryrefslogtreecommitdiffstats
path: root/abs/core/mythinstall
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-05-01 17:32:20 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-05-01 17:32:20 (GMT)
commit9f77bf47533c65bbd18e5b338a963a607853dc93 (patch)
treeaa59bd64b1ee268f0a4c9817969fb14d46135037 /abs/core/mythinstall
parentd042a4cdc749cdef60460ab85168c214f22a8f63 (diff)
downloadlinhes_pkgbuild-9f77bf47533c65bbd18e5b338a963a607853dc93.zip
linhes_pkgbuild-9f77bf47533c65bbd18e5b338a963a607853dc93.tar.gz
linhes_pkgbuild-9f77bf47533c65bbd18e5b338a963a607853dc93.tar.bz2
mythinstall: use audio card name instead of number in case devices move around on boot
Diffstat (limited to 'abs/core/mythinstall')
-rwxr-xr-xabs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp5
-rw-r--r--abs/core/mythinstall/PKGBUILD2
2 files changed, 4 insertions, 3 deletions
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
index 05acc5e..41b67c6 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
@@ -3109,7 +3109,8 @@ void SoundALSAsettings::fillALSAselection()
}
//card 0: I82801DBICH4:q [Intel 82801DB-ICH4], device 0: Intel ICH [Intel 82801DB-ICH4]
alsadescription=line.section( ", " , 0 ,0 );
- alsadescription=alsadescription.section(":",1,1);
+ alsadescription=alsadescription.section(": ",1,1);
+ alsadescription=alsadescription.section(" ",0,0);
alsadescription2=line.section( ", " , 1 ,1 );
//alsadescription2=alsadescription.section(":",0,0);
@@ -3122,7 +3123,7 @@ void SoundALSAsettings::fillALSAselection()
temphwdevice=temphwdevice.section(" ",-1,-1 );
hwdevice.append(",");
hwdevice.append(temphwdevice);
- simpleitem=alsadescription2 + "(plughw:" + hwdevice + ")";
+ simpleitem=alsadescription + " " + alsadescription2 + "(plughw:" + alsadescription + "," + temphwdevice + ")";
if (line.contains("IEC958") || line.contains("Digital") || line.contains("PCM") || line.contains("HDMI"))
HostSoundALSADigital->addSelection(simpleitem);
else
diff --git a/abs/core/mythinstall/PKGBUILD b/abs/core/mythinstall/PKGBUILD
index 901f6ad..e74402e 100644
--- a/abs/core/mythinstall/PKGBUILD
+++ b/abs/core/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jams
pkgname=mythinstall
pkgver=8.3
-pkgrel=6
+pkgrel=7
pkgdesc="LinHES installer/systemconfig GUI."
arch=('i686' 'x86_64')
depends=('mythtv>=0.27')