summaryrefslogtreecommitdiffstats
path: root/abs/core/mythinstall
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-11-26 21:13:24 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-11-26 21:13:24 (GMT)
commitbcb80f9deba36cf51079f1c6fd7992278f91ff7e (patch)
tree57fb103b886c903ee243544dba70c0133fbd8fa0 /abs/core/mythinstall
parentbd75224b904e29eafdd323c655d50cac36d44a8b (diff)
downloadlinhes_pkgbuild-bcb80f9deba36cf51079f1c6fd7992278f91ff7e.zip
linhes_pkgbuild-bcb80f9deba36cf51079f1c6fd7992278f91ff7e.tar.gz
linhes_pkgbuild-bcb80f9deba36cf51079f1c6fd7992278f91ff7e.tar.bz2
mythtv, mythplugins, mythinstall: recompile
Diffstat (limited to 'abs/core/mythinstall')
-rwxr-xr-xabs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp12
-rwxr-xr-xabs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h1
-rw-r--r--abs/core/mythinstall/PKGBUILD2
3 files changed, 14 insertions, 1 deletions
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
index 3592f09..ca809d4 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
@@ -1157,6 +1157,15 @@ static HostCheckBox *HostXBMC()
return gc;
};
+static HostCheckBox *HostPLEXHT()
+{
+ HostCheckBox *gc = new HostCheckBox("HostPLEXHT");
+ gc->setLabel(QObject::tr("Plex Home Theater"));
+ gc->setValue(false);
+ gc->setHelpText(QObject::tr("Plex organizes all of your personal media, wherever you keep it, so you can enjoy it on any device."));
+ return gc;
+};
+
static HostComboBox *Hostfoldingusername()
{
// If there is an old R5.5 style folding directory /myth/folding@home, attempt
@@ -3993,6 +4002,7 @@ void writesettings ()
hostparm.ThisHostHuluDesktop = gCoreContext->GetSetting("HostHuluDesktop");
hostparm.ThisHostwebonlinhes = gCoreContext->GetSetting("HostWebonlinhes");
hostparm.ThisHostXBMC = gCoreContext->GetSetting("HostXBMC");
+ hostparm.ThisHostPLEXHT = gCoreContext->GetSetting("HostPLEXHT");
hostparm.ThisHostfoldingathome = gCoreContext->GetSetting("Hostfoldingathome");
hostparm.ThisHostfoldingusername = gCoreContext->GetSetting("Hostfoldingusername");
@@ -4326,6 +4336,7 @@ void writesettings ()
myfile << "webonlinhes=\"" + hostparm.ThisHostwebonlinhes + "\"\n";
myfile << "huludesktop=\"" + hostparm.ThisHostHuluDesktop + "\"\n";
myfile << "xbmc=\"" + hostparm.ThisHostXBMC + "\"\n";
+ myfile << "plex=\"" + hostparm.ThisHostPLEXHT + "\"\n";
myfile << "foldingathome=\"" + hostparm.ThisHostfoldingathome + "\"\n";
myfile << "foldingusername=\"" + hostparm.ThisHostfoldingusername + "\"\n";
myfile << "foldingworksize=\"" + hostparm.ThisHostfoldingworksize + "\"\n";
@@ -4748,6 +4759,7 @@ MythInstallSettings::MythInstallSettings()
//GridShowPlugin4->addChild(HostMiro());
//GridShowPlugin4->addChild(HostXine());
GridShowPlugin4->addChild(HostHuluDesktop());
+ GridShowPlugin4->addChild(HostPLEXHT());
GridShowPlugin4->addChild(Hostwebmin());
GridShowPlugin4->addChild(Hostwebonlinhes());
GridShowPlugin4->addChild(HostXBMC());
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
index 6ce0eff..cd2983b 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
@@ -524,6 +524,7 @@ struct HostParms
// QString ThisHostMiro;
QString ThisHostwebonlinhes;
QString ThisHostXBMC;
+ QString ThisHostPLEXHT;
QString ThisHostHuluDesktop;
QString ThisHostpluginmythgameMame;
diff --git a/abs/core/mythinstall/PKGBUILD b/abs/core/mythinstall/PKGBUILD
index c37757d..fd0ef2c 100644
--- a/abs/core/mythinstall/PKGBUILD
+++ b/abs/core/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jams
pkgname=mythinstall
pkgver=8.2
-pkgrel=7
+pkgrel=8
pkgdesc="LinHES installer/systemconfig GUI."
arch=('i686' 'x86_64')
depends=('mythtv>=0.27')