summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/old/stable-0.21/mythmusic/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
commitc4bd4457b5d640e1c8f5afbca7cd54c53691e5fc (patch)
treef4e4f7a91e1d9d90033fd99d89e5e26a2c144528 /abs/core/mythtv/old/stable-0.21/mythmusic/PKGBUILD
parent0e7b327a1ae444233f1308a95420f70540ad74a3 (diff)
downloadlinhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.zip
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.gz
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.bz2
RSYNC CORE:
resync core-testing -> core Signed-off-by: James Meyer <james.meyer@operamail.com>
Diffstat (limited to 'abs/core/mythtv/old/stable-0.21/mythmusic/PKGBUILD')
-rw-r--r--abs/core/mythtv/old/stable-0.21/mythmusic/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/abs/core/mythtv/old/stable-0.21/mythmusic/PKGBUILD b/abs/core/mythtv/old/stable-0.21/mythmusic/PKGBUILD
new file mode 100644
index 0000000..b422f34
--- /dev/null
+++ b/abs/core/mythtv/old/stable-0.21/mythmusic/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id: PKGBUILD 5680 2008-07-20 05:15:42Z eric $
+# Maintainer: Juergen Hoetzel <travis@archlinux.org>
+# Contributor: kleptophobiac@gmail.com
+
+pkgname=mythmusic
+pkgver=0.21
+pkgrel=12
+pkgdesc="Music playing plugin for MythTV"
+arch=('i686' 'x86_64')
+url="http://www.mythtv.org"
+license=('GPL')
+depends=("mythtv>=${pkgver}" 'libid3tag' 'libmad' 'libvorbis' 'flac>=1.1.4' 'libcdaudio' \
+ 'cdparanoia' 'fftw2' 'sdl' 'faad2>=2.6.1' 'lame' 'taglib' \
+ 'libvisual-plugins' 'libvisual-projectm')
+source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2")
+md5sums=('1b3e2a97b7ecf7373e162fe20b6faabe')
+groups=('mythtv-extras')
+
+build() {
+ cd $startdir/src/mythplugins
+ . /etc/profile.d/qt3.sh
+
+ # use QT3 qmake
+ export PATH=$QTDIR/bin:$PATH
+ ./configure --prefix=/usr --disable-all --enable-mythmusic --enable-fftw \
+ --enable-sdl --enable-aac --enable-opengl --enable-libvisual
+
+ qmake mythplugins.pro
+ make qmake || return 1
+# make -j 2 || return 1
+ make
+
+ make INSTALL_ROOT=$startdir/pkg install
+}
+