summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/old/stable-0.21/mythweb/patch/mythweb.pl.diff
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
commitb172f79fadb565ecfbcec9508f9377d8618a4f4c (patch)
treebf8823b07e3313c3afa000a9b31e4f9a735cb818 /abs/core/mythtv/old/stable-0.21/mythweb/patch/mythweb.pl.diff
parentf9d54ab7c3853208484e304bc6cf40ab0f79d400 (diff)
parent5e7027c6194237ca1dc5fcbb3648483a970fb500 (diff)
downloadlinhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.zip
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.gz
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core/mythtv/old/stable-0.21/mythweb/patch/mythweb.pl.diff')
-rw-r--r--abs/core/mythtv/old/stable-0.21/mythweb/patch/mythweb.pl.diff23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/core/mythtv/old/stable-0.21/mythweb/patch/mythweb.pl.diff b/abs/core/mythtv/old/stable-0.21/mythweb/patch/mythweb.pl.diff
new file mode 100644
index 0000000..6dcbf99
--- /dev/null
+++ b/abs/core/mythtv/old/stable-0.21/mythweb/patch/mythweb.pl.diff
@@ -0,0 +1,23 @@
+*** mythweb-unpatched.pl 2009-06-02 14:55:24.011861459 -0400
+--- mythweb.pl 2009-06-02 14:56:24.386441304 -0400
+***************
+*** 49,57 ****
+
+ # Connect to the database
+ END { $dbh->disconnect() if ($dbh); }
+! our $dbh = DBI->connect("dbi:mysql:database=$ENV{'db_name'}:host=$ENV{'db_server'}",
+! $ENV{'db_login'},
+! $ENV{'db_password'});
+ unless ($dbh) {
+ print header(),
+ "Cannot connect to database: $!\n\n";
+--- 49,57 ----
+
+ # Connect to the database
+ END { $dbh->disconnect() if ($dbh); }
+! our $dbh = DBI->connect("dbi:mysql:database=$ENV{'DB_NAME'}:host=$ENV{'DB_SERVER'}",
+! $ENV{'DB_LOGIN'},
+! $ENV{'DB_PASSWORD'});
+ unless ($dbh) {
+ print header(),
+ "Cannot connect to database: $!\n\n";