summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-0.24/mythweb
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/core/mythtv/stable-0.24/mythweb
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/core/mythtv/stable-0.24/mythweb')
-rw-r--r--abs/core/mythtv/stable-0.24/mythweb/PKGBUILD46
-rw-r--r--abs/core/mythtv/stable-0.24/mythweb/mythweb.php.patch11
2 files changed, 0 insertions, 57 deletions
diff --git a/abs/core/mythtv/stable-0.24/mythweb/PKGBUILD b/abs/core/mythtv/stable-0.24/mythweb/PKGBUILD
deleted file mode 100644
index cab8fbd..0000000
--- a/abs/core/mythtv/stable-0.24/mythweb/PKGBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-pkgname=mythweb
-pkgver=0.24
-pkgrel=16
-pkgdesc="Web interface for MythTV's backend"
-url="http://www.mythtv.org"
-license="GPL"
-arch=('i686' 'x86_64')
-
-depends=('mythtv>=0.24' 'lighttpd' 'php' 'local-website')
-groups=('mythtv-extras')
-
-patches=()
-source=('ftp://ftp.knoppmyth.net/R6/sources/mythweb-0.24-fixes.tar.bz2' `echo ${patches[@]:0}`)
-
-DOCROOT=/data/srv/httpd/htdocs/mythweb
-_gitroot="https://github.com/mythtv/mythweb.git"
-_gitname="${pkgname}"
-build() {
-
- cd $startdir/src/mythweb
- git pull
-
- echo "--------------------------applying patches----------------------------------------------------"
- for i in `echo ${patches[@]:0} `
- do
- echo applying $i
- echo "-----------------------------"
- patch -Np0 -i ${srcdir}/$i || return 1
- done
- echo "--------------------------done applying patches-----------------------------------------------"
-
- [ "$CARCH" = "i686" ] && ARCH="i686"
- [ "$CARCH" = "x86_64" ] && ARCH="x86-64"
-
- mkdir -p $startdir/pkg/$DOCROOT/{image_cache,php_sessions,data}
- rsync -arp --exclude .git --delete-excluded $startdir/src/mythweb/* $startdir/pkg/$DOCROOT
- rm $startdir/pkg/$DOCROOT/README
- chown -R http:http $startdir/pkg/$DOCROOT
- chmod g+rw $pkgdir/$DOCROOT/{image_cache,php_sessions,data}
-
- # mythweb modules_path fix for 0.24
- # http://code.mythtv.org/trac/ticket/9255
- cd ${pkgdir}/${DOCROOT}
- ln -s modules modules_path
-}
-md5sums=('45703fa3899c4ee84d1b087bfcc6654e')
diff --git a/abs/core/mythtv/stable-0.24/mythweb/mythweb.php.patch b/abs/core/mythtv/stable-0.24/mythweb/mythweb.php.patch
deleted file mode 100644
index 4525e68..0000000
--- a/abs/core/mythtv/stable-0.24/mythweb/mythweb.php.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- mythweb.php.orig 2011-02-01 03:33:56.000000000 +0000
-+++ mythweb.php 2011-02-01 03:34:20.000000000 +0000
-@@ -30,7 +30,7 @@
- if (Modules::getModule($Path[0])) {
- // Add the current module directory to our search path, so modules can
- // define includes, etc.
-- ini_set('include_path', ini_get('include_path').':'.modules_path.'/'.$Path[0]);
-+ ini_set('include_path', ini_get('include_path').':'.modules.'/'.$Path[0]);
- // Load the module handler
- require_once 'handler.php';
- }