summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-0.25/mythplugins
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
commit2648e999d277eac5c3d331a3609bcc73fafbea71 (patch)
tree40951fb8e7fdbe28a0baa324ae615055203f1e2e /abs/core/mythtv/stable-0.25/mythplugins
parentc759b5e0c4aa6fc37412b4dee2cf9ad993fd376d (diff)
parent7e6f7ca174e1af67178dc5293a312a4a733eb095 (diff)
downloadlinhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.zip
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.gz
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.bz2
Merge branch 'testing'
# By James Meyer (1091) and others # Via James Meyer (5) and others * testing: (1148 commits) LinHES-config: during install don't kill off lirc. This keeps the remote active all the way to the finish Change version numbers to 8.0 to match the release number. LinHES-conifg LinHES-system mythdb-initial runit-scripts supplemental-web LinHES-conifig: mv_install.py for the last partition don't go all the way to the end. Gotta leave room for gpt tables. xf86-video-ati: xorg ati driver. LinHES-config: timezip.py add syncing up of parental lvl passwords and starting level with MBE. LinHES-system: correct the logic for breaking out of the wmctrl loop. As written it would break out of the inner loop..but not the 60 iteration loop. e16_theme_settings: remove slide-in prop for new windows. For whatever reason this was preventing mplayer from being positioned correctly for appletrailers. LinHES-config, mythinstall: change case of hd_pvr and serial to all lower refs #902 zilog-firmware: firmware for TX support of the hdpvr and pvr-150 In general I can't recommend anybody using these transmitters but including the firmware just in case someone really wants to linhes-udev-rules: added hdprv_lirc rule. All of these lirc rules are limited to exactly one device. If more then one device is present then only the last device in init will get the symlink runit-scripts: fix logging for igdeamon, add support to remote init script so that the blaster is always the first device in the chain. added support specificly for hd_pvr LinHES-system: add lh_system_restore and lh_system_backup. These scripts are called from the mythmenu. refs #900 iguanair: rebuild with python 2.7 LinHES-system: msg_daemon.py fix init and nasty bug related to timeout. In a nutshell timeout wouldn't work unless a msg without a timeout was called first. linhes-udev-rules: add rules for mce,streamzap,serial lirc devices. mythinstall: recompile for matching libs mythtv: latest .25-fixes and change mythbackup/restore call lh_system_$op to replace mythbackup/mythrestore. mythbackup no longer works correctly with the new windowmanager linhes-scripts: myth2mp3, myth2x264, myth2xvid: use mythutil to get cutlist LinHES-config, supplimental-web: Fix proxy numbering for Ceton infiniTV linhes-system: add additional stuff to the system backup and also introduced an exclude file. The exclude/include files are locate in /home/mythtv/backup_config/ ...
Diffstat (limited to 'abs/core/mythtv/stable-0.25/mythplugins')
-rw-r--r--abs/core/mythtv/stable-0.25/mythplugins/PKGBUILD16
-rw-r--r--abs/core/mythtv/stable-0.25/mythplugins/__changelog1
-rw-r--r--abs/core/mythtv/stable-0.25/mythplugins/mythburn.py.patch288
-rw-r--r--abs/core/mythtv/stable-0.25/mythplugins/mythplugins-mythzoneminder.install10
4 files changed, 152 insertions, 163 deletions
diff --git a/abs/core/mythtv/stable-0.25/mythplugins/PKGBUILD b/abs/core/mythtv/stable-0.25/mythplugins/PKGBUILD
index 2ebe525..e5dea15 100644
--- a/abs/core/mythtv/stable-0.25/mythplugins/PKGBUILD
+++ b/abs/core/mythtv/stable-0.25/mythplugins/PKGBUILD
@@ -12,7 +12,7 @@ pkgname=('mytharchive'
'mythweather'
'mythzoneminder')
pkgver=0.25
-pkgrel=4
+pkgrel=17
arch=('i686' 'x86_64')
url="http://www.mythtv.org"
@@ -49,7 +49,7 @@ build() {
#find . -name '*.py' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
cd ${srcdir}/${pkgbase}
./configure --prefix=/usr \
- --enable-all
+ --enable-all --python=/usr/bin/python2
qmake mythplugins.pro || return 1
make || return 1
@@ -57,11 +57,11 @@ build() {
package_mytharchive() {
pkgdesc="MythTV plugin that lets you create DVDs from or archive your recorded shows"
- depends=("mythtv>=${pkgver}" 'libxmu' 'pil' 'dvdauthor' 'm2vrequantiser')
+ depends=("mythtv>=${pkgver}" 'libxmu' 'pil' 'dvdauthor' 'm2vrequantiser' 'mjpegtools' 'cdrkit' 'dvd+rw-tools')
# replaces=('mytharchive')
cd "${srcdir}/${_gitname}/${pkgbase}/mytharchive"
-# patch mythburn/scripts/mythburn.py < $srcdir/mythburn.py.patch || return 1
+ patch mythburn/scripts/mythburn.py < $srcdir/mythburn.py.patch || return 1
make INSTALL_ROOT="${pkgdir}" install || return 1
}
@@ -99,9 +99,7 @@ package_mythmusic() {
package_mythnetvision() {
pkgdesc="MythNetvision plugin for MythTV"
-
-
- depends=("mythtv>=${pkgver}" 'python-pycurl' 'python-oauth' 'python-lxml' )
+ depends=("mythtv>=${pkgver}" 'python-pycurl' 'python-oauth' 'python2-lxml' 'python2' )
# replaces=('mythnetvision')
cd "${srcdir}/${_gitname}/${pkgbase}/mythnetvision"
make INSTALL_ROOT="${pkgdir}" install || return 1
@@ -127,11 +125,11 @@ package_mythweather() {
package_mythzoneminder() {
pkgdesc="Allows for viewing of CCTV cameras through zoneminder"
- depends=("mythtv>=${pkgver}" zoneminder)
+ depends=("mythtv>=${pkgver}")
# replaces=('mythzoneminder')
# install=mythplugins-mythzoneminder.install
cd "${srcdir}/${_gitname}/${pkgbase}/mythzoneminder"
make INSTALL_ROOT="${pkgdir}" install || return 1
}
-md5sums=('cc7e6887acda167fcc5336af33f29411')
+md5sums=('19446f65722769926bafad220bbc6551')
diff --git a/abs/core/mythtv/stable-0.25/mythplugins/__changelog b/abs/core/mythtv/stable-0.25/mythplugins/__changelog
new file mode 100644
index 0000000..48cdce8
--- /dev/null
+++ b/abs/core/mythtv/stable-0.25/mythplugins/__changelog
@@ -0,0 +1 @@
+placeholder
diff --git a/abs/core/mythtv/stable-0.25/mythplugins/mythburn.py.patch b/abs/core/mythtv/stable-0.25/mythplugins/mythburn.py.patch
index abac7df..380385b 100644
--- a/abs/core/mythtv/stable-0.25/mythplugins/mythburn.py.patch
+++ b/abs/core/mythtv/stable-0.25/mythplugins/mythburn.py.patch
@@ -1,23 +1,32 @@
---- mythburn.py.orig 2011-09-16 13:41:43.000000000 -0500
-+++ mythburn.py 2011-09-17 10:51:36.000000000 -0500
-@@ -38,7 +38,7 @@
- #******************************************************************************
+--- mythburn.py.orig 2012-12-16 15:23:41.000000000 -0600
++++ mythburn.py 2012-12-18 14:23:56.000000000 -0600
+@@ -44,7 +44,7 @@
+
# version of script - change after each update
--VERSION="0.1.20101206-1"
-+VERSION="0.1.20110821-1"
+-VERSION="0.1.20120304-1"
++VERSION="0.1.20121218-1"
# keep all temporary files for debugging purposes
# set this to True before a first run through when testing
-@@ -75,6 +75,7 @@
+@@ -93,6 +93,7 @@
from fcntl import ioctl
import CDROM
from shutil import copy
+from subprocess import Popen, PIPE
- # media types (should match the enum in mytharchivewizard.h)
- DVD_SL = 0
-@@ -606,7 +607,7 @@
+ import MythTV
+ from MythTV.altdict import OrdDict
+@@ -425,7 +426,7 @@
+ os.remove(os.path.join(root, name))
+
+ #############################################################
+-# Romoves all the objects from a directory
++# Removes all the objects from a directory
+
+ def deleteEverythingInFolder(folder):
+ for root, dirs, files in os.walk(folder, topdown=False):
+@@ -615,7 +616,7 @@
# of a video file from its stream info file
def getVideoParams(folder):
@@ -26,7 +35,7 @@
#open the XML containing information about this file
infoDOM = xml.dom.minidom.parse(os.path.join(folder, 'streaminfo.xml'))
-@@ -642,14 +643,14 @@
+@@ -651,14 +652,14 @@
# Gets the aspect ratio of a video file from its stream info file
def getAspectRatioOfVideo(index):
@@ -44,65 +53,85 @@
video = infoDOM.getElementsByTagName("file")[0].getElementsByTagName("streams")[0].getElementsByTagName("video")[0]
if video.attributes["aspectratio"].value != 'N/A':
aspect_ratio = float(video.attributes["aspectratio"].value)
-@@ -1762,6 +1763,37 @@
+@@ -679,7 +680,7 @@
+
+ #error out if its the wrong XML
+ if infoDOM.documentElement.tagName != "file":
+- fatalError("Stream info file doesn't look right (%s)" % os.path.join(getItemTempPath(index), 'streaminfo_orig.xml'))
++ fatalError("Stream info file doesn't look right (%s)" % os.path.join(getItemTempPath(index), 'streaminfo.xml'))
+
+ video = infoDOM.getElementsByTagName("file")[0].getElementsByTagName("streams")[0].getElementsByTagName("video")[0]
+ video_start = float(video.attributes["start_time"].value)
+@@ -1432,9 +1433,23 @@
+
+ data.rating = str(vid.userrating)
+
+- if doesFileExist(vid.coverfile):
+- data.coverfile = vid.coverfile
++ data.coverfile = None
+
++ #Check filename for valid path. If valid return nothing.
++ if os.path.isfile(str(vid.coverfile)):
++ write("Coverart is in local directory: %s" % vid.coverfile)
++ data.coverfile = vid.coverfile
++ else:
++ # iterate through storage group directories to get Coverart
++ for sg in DB.getStorageGroup(groupname='Coverart', hostname=DB.gethostname()):
++ if os.path.isfile(os.path.join(sg.dirname, str(vid.coverfile))):
++ write("Coverart is in Storage Groups: %s%s" % (sg.dirname, vid.coverfile))
++ data.coverfile = os.path.join(sg.dirname, str(vid.coverfile))
++ break
++
++ if data.coverfile == None:
++ write("No Coverart Found")
++
+ elif file.attributes["type"].value=="file":
+ data.type = file.attributes["type"].value
+ data.filename = file.attributes["filename"].value
+@@ -1485,6 +1500,30 @@
#############################################################
-+# Finds the path of a video file from the local video path
-+# or Storage Group
++# Finds the path of a video file from a Storage Group
+
+def getVideoPath(filename):
-+ # connect
-+ db = getDatabaseConnection()
-+ # create a cursor
-+ cursor = db.cursor()
-+ # execute SQL statement
-+ cursor.execute("""SELECT dirname
-+ FROM storagegroup
-+ WHERE groupname='Videos'""")
-+ # get the resultset as a tuple
-+ result = cursor.fetchall()
-+ # make result a list and add local video path if exists
-+ result = [videopath] + list(result)
-+
-+ # iterate through result set
-+ for sg in result:
-+ if doesFileExist(os.path.join("".join(sg), filename)) == True:
-+ filepath = "".join(sg)
-+ write("Video Path: %s" % filepath)
-+ return (filepath)
-+ break
-+
-+ db.close()
-+ del db
-+ del cursor
++
++ filepath = None
+
++ #Check filename for valid path. If valid return nothing.
++ if os.path.isfile(filename):
++ write("Video is in local video directory: %s" % filename)
++ return (filepath)
++ else:
++ # iterate through storage group directories
++ for sg in DB.getStorageGroup(groupname='Videos', hostname=DB.gethostname()):
++ wholepath = os.path.join(sg.dirname, filename)
++ if os.path.isfile(wholepath):
++ write("Video is in Storage Groups: %s" % wholepath)
++ filepath = "".join(sg.dirname)
++ return (filepath)
++ break
++
++ if filepath == None:
++ write("Video is not in local video directory or Storage Groups")
+
+#############################################################
# Pre-process a single video/recording file
def preProcessFile(file, folder, count):
-@@ -1775,11 +1807,11 @@
- #3. Extract a single frame from the video to use as a thumbnail and resolution check
- mediafile=""
-
-- if file.attributes["type"].value == "recording":
-+ if file.attributes["type"].value=="recording":
+@@ -1501,7 +1540,7 @@
+ if file.attributes["type"].value == "recording":
mediafile = file.attributes["filename"].value
-- elif file.attributes["type"].value == "video":
+ elif file.attributes["type"].value == "video":
- mediafile = os.path.join(videopath, file.attributes["filename"].value)
-- elif file.attributes["type"].value == "file":
-+ elif file.attributes["type"].value=="video":
+ mediafile = os.path.join(getVideoPath(file.attributes["filename"].value), file.attributes["filename"].value)
-+ elif file.attributes["type"].value=="file":
+ elif file.attributes["type"].value == "file":
mediafile = file.attributes["filename"].value
else:
- fatalError("Unknown type of video file it must be 'recording', 'video' or 'file'.")
-@@ -1935,9 +1967,39 @@
+@@ -1661,6 +1700,37 @@
+ fatalError("Failed while running mytharchivehelper to get stream information.\n"
+ "Result: %d, Command was %s" % (result, command))
- if result <> 0:
- fatalError("Failed while running mytharchivehelper to get stream information from %s" % filename)
-+
+ #open the XML containing information about this file
+ infoDOM = xml.dom.minidom.parse(xmlFilename)
+
@@ -114,7 +143,7 @@
+ video = infoDOM.getElementsByTagName("file")[0].getElementsByTagName("streams")[0].getElementsByTagName("video")[0]
+
+ #use ffmpeg to get display aspect ratio (DAR) of video
-+ cmd = path_ffmpeg[0] + " -i " + quoteFilename(file.attributes["filename"].value) + " 2>&1"
++ cmd = "mythffmpeg -i " + quoteCmdArg(file.attributes["filename"].value) + " 2>&1"
+ aspect_ratio = Popen(cmd, shell=True, stdout=PIPE).stdout.read()
+ if "DAR" in aspect_ratio:
+ #clean DAR string
@@ -133,74 +162,66 @@
+ video.setAttribute("aspectratio",str(aspect_ratio))
+
+ WriteXMLToFile (infoDOM,xmlFilename)
-
++
# print out the streaminfo.xml file to the log
-- infoDOM = xml.dom.minidom.parse(xmlFilename)
- write("streaminfo.xml :-\n" + infoDOM.toprettyxml(" ", ""), False)
+ infoDOM = xml.dom.minidom.parse(xmlFilename)
+ write(xmlFilename + ":-\n" + infoDOM.toprettyxml(" ", ""), False)
+@@ -1707,7 +1777,7 @@
+ write("Using cutlist: %s" % cutlist_s)
- #############################################################
-@@ -2322,7 +2384,7 @@
+ if (localfile != ""):
+- localfile = quoteFilename(localfile)
++ localfile = quoteCmdArg(localfile)
+ if usecutlist == True:
+ command = "mythtranscode --mpeg2 --honorcutlist %s --infile %s --outfile %s" % (cutlist_s, quoteCmdArg(localfile), quoteCmdArg(destination))
+ else:
+@@ -1973,7 +2043,7 @@
#############################################################
# Re-encodes a file to mpeg2
-def encodeVideoToMPEG2(source, destvideofile, video, audio1, audio2, aspectratio, profile):
+def encodeVideoToMPEG2(source, destvideofile, video, folder, audio1, audio2, aspectratio, profile):
- """Encodes an unknown video source file eg. AVI to MPEG2 video and AC3 audio, use ffmpeg"""
+ """Encodes an unknown video source file eg. AVI to MPEG2 video and AC3 audio, use mythffmpeg"""
profileNode = findEncodingProfile(profile)
-@@ -2347,6 +2409,18 @@
- value = quoteFilename(destvideofile)
+@@ -1998,7 +2068,36 @@
+ value = quoteCmdArg(destvideofile)
if value == "%aspect":
value = aspectratio
+ if value == "720x480" or value == "720x576":
-+ #add padding to correct for aspects > than 1.9:1
+ videores, fps, videoAR = getVideoParams(folder)
++ videoWidth = int(videores.split("x")[0])
++ videoHeight = int(videores.split("x")[1])
++
++ #add padding to correct for aspects > than 1.9:1
+ if float(videoAR) >= 1.9:
++ #check which video type and set the correct height
+ if videomode == "ntsc":
-+ videoheight = 480
++ videoModeHeight = 480
+ else:
-+ videoheight = 576
-+
-+ croppixels = videoheight - (720 / float(videoAR))
-+ write("CropPixels Total: %s" % croppixels)
-+ value = "720x%d -vf pad=720:%d:0:%d:black" % (videoheight - croppixels, videoheight, croppixels / 2)
++ videoModeHeight = 576
++ #calculate the video height based on the aspect ratio of the video
++ #multiply by 1.185 to compensate for dvds non-square pixels
++ calVideoHeight = int(round((720 / float(videoAR)) * 1.185))
++ if calVideoHeight % 2 == 1:
++ calVideoHeight = calVideoHeight + 1
++ #write("calVideoHeight: %s" % calVideoHeight)
++
++ #use original video height if the calculated video height is close
++ if (calVideoHeight + 20 < videoHeight) or (calVideoHeight - 20 > videoHeight):
++ videoHeight = calVideoHeight
++
++ cropPixels = videoModeHeight - videoHeight
++
++ write("Crop Pixels Total: %s" % cropPixels)
++ name = "-vf"
++ value = "\"scale=720:%d, setsar=1:1, pad=720:%d:0:%d:black\"" % (videoModeHeight - cropPixels, videoModeHeight, cropPixels / 2)
++
# only re-encode the audio if it is not already in AC3 format
if audio1[AUDIO_CODEC] == "AC3":
-@@ -2383,12 +2457,12 @@
- command += " -newaudio"
-
- #make sure we get the correct stream(s) that we want
-- command += " -map 0:%d -map 0:%d " % (video[VIDEO_INDEX], audio1[AUDIO_INDEX])
-+ command += " -map 0:%d -map 0:%d" % (video[VIDEO_INDEX], audio1[AUDIO_INDEX])
- if audio2[AUDIO_ID] != -1:
- command += "-map 0:%d" % (audio2[AUDIO_INDEX])
-
- if passes == 1:
-- write(command)
-+ write("Running ffmpeg: %s" % command)
- result = runCommand(command)
- if result!=0:
- fatalError("Failed while running ffmpeg to re-encode video.\n"
-@@ -2399,7 +2473,7 @@
-
- pass1 = string.replace(command, "%passno","1")
- pass1 = string.replace(pass1, "%passlogfile", passLog)
-- write("Pass 1 - " + pass1)
-+ write("Running ffmpeg Pass 1: %s" % pass1)
- result = runCommand(pass1)
-
- if result!=0:
-@@ -2411,7 +2485,7 @@
-
- pass2 = string.replace(command, "%passno","2")
- pass2 = string.replace(pass2, "%passlogfile", passLog)
-- write("Pass 2 - " + pass2)
-+ write("Running ffmpeg Pass 2: %s" % pass2)
- result = runCommand(pass2)
-
- if result!=0:
-@@ -2443,10 +2517,6 @@
+ if name == "-acodec":
+@@ -2094,10 +2193,6 @@
outaudiosamplerate = 48000
outaudiocodec = "ac3"
deinterlace = 0
@@ -211,7 +232,7 @@
qmin = 5
qmax = 31
qdiff = 31
-@@ -2470,14 +2540,6 @@
+@@ -2121,14 +2216,6 @@
outvideores = value
if name == "-deinterlace":
deinterlace = 1
@@ -226,78 +247,39 @@
if name == "-qmin":
qmin = value
if name == "-qmax":
-@@ -2526,7 +2588,6 @@
- command += "-aspect %s -r %s " % (aspectratio, fps)
- if (deinterlace == 1):
- command += "-deinterlace "
-- command += "-croptop %s -cropright %s -cropbottom %s -cropleft %s " % (croptop, cropright, cropbottom, cropleft)
- command += "-s %s -b %s -vcodec mpeg2video " % (outvideores, outvideobitrate)
- command += "-qmin %s -qmax %s -qdiff %s " % (qmin, qmax, qdiff)
- command += "-ab %s -ar %s -acodec %s " % (outaudiobitrate, outaudiosamplerate, outaudiocodec)
-@@ -2543,7 +2604,7 @@
- if (not(doesFileExist(os.path.join(folder, "audout")) and doesFileExist(os.path.join(folder, "vidout")))):
- fatalError("Waited too long for mythtranscode to create the fifos - giving up!!")
-
-- write("Running ffmpeg")
-+ write("Running ffmpeg: %s" % command)
- result = runCommand(command)
- if result != 0:
- os.kill(PID, signal.SIGKILL)
-@@ -4724,7 +4785,7 @@
+@@ -4409,7 +4496,7 @@
elif file.attributes["type"].value=="recording":
mediafile = file.attributes["filename"].value
elif file.attributes["type"].value=="video":
- mediafile=os.path.join(videopath, file.attributes["filename"].value)
-+ mediafile = os.path.join(getVideoPath(file.attributes["filename"].value), file.attributes["filename"].value)
++ mediafile=os.path.join(getVideoPath(file.attributes["filename"].value), file.attributes["filename"].value)
elif file.attributes["type"].value=="file":
mediafile=file.attributes["filename"].value
else:
-@@ -4834,8 +4895,7 @@
- starttime = -1
- usecutlist = -1
-
-- encodeNuvToMPEG2(chanid, starttime, mediafile, os.path.join(folder, "newfile2.mpg"), folder,
-- profile, usecutlist)
-+ encodeNuvToMPEG2(chanid, starttime, mediafile, os.path.join(folder, "newfile2.mpg"), folder, profile, usecutlist)
- mediafile = os.path.join(folder, 'newfile2.mpg')
- else:
- #we need to re-encode the file, make sure we get the right video/audio streams
-@@ -4861,8 +4921,7 @@
- profile = defaultEncodingProfile
+@@ -4547,7 +4634,7 @@
#do the re-encode
-- encodeVideoToMPEG2(mediafile, os.path.join(folder, "newfile2.mpg"), video,
+ encodeVideoToMPEG2(mediafile, os.path.join(folder, "newfile2.mpg"), video,
- audio1, audio2, aspectratio, profile)
-+ encodeVideoToMPEG2(mediafile, os.path.join(folder, "newfile2.mpg"), video, folder, audio1, audio2, aspectratio, profile)
++ folder, audio1, audio2, aspectratio, profile)
mediafile = os.path.join(folder, 'newfile2.mpg')
#remove the old mediafile that was run through mythtranscode
-@@ -4936,7 +4995,7 @@
+@@ -4621,7 +4708,7 @@
elif file.attributes["type"].value=="recording":
mediafile = file.attributes["filename"].value
elif file.attributes["type"].value=="video":
- mediafile=os.path.join(videopath, file.attributes["filename"].value)
-+ mediafile = os.path.join(getVideoPath(file.attributes["filename"].value), file.attributes["filename"].value)
++ mediafile=os.path.join(getVideoPath(file.attributes["filename"].value), file.attributes["filename"].value)
elif file.attributes["type"].value=="file":
mediafile=file.attributes["filename"].value
else:
-@@ -4988,8 +5047,7 @@
- starttime = -1
- usecutlist = -1
-
-- encodeNuvToMPEG2(chanid, starttime, mediafile, os.path.join(folder, "newfile2.mpg"), folder,
-- profile, usecutlist)
-+ encodeNuvToMPEG2(chanid, starttime, mediafile, os.path.join(folder, "newfile2.mpg"), folder, profile, usecutlist)
- mediafile = os.path.join(folder, 'newfile2.mpg')
- else:
- #we need to re-encode the file, make sure we get the right video/audio streams
-@@ -5015,8 +5073,7 @@
- profile = defaultEncodingProfile
+@@ -4701,7 +4788,7 @@
#do the re-encode
-- encodeVideoToMPEG2(mediafile, os.path.join(folder, "newfile2.mpg"), video,
+ encodeVideoToMPEG2(mediafile, os.path.join(folder, "newfile2.mpg"), video,
- audio1, audio2, aspectratio, profile)
-+ encodeVideoToMPEG2(mediafile, os.path.join(folder, "newfile2.mpg"), video, folder, audio1, audio2, aspectratio, profile)
++ folder, audio1, audio2, aspectratio, profile)
mediafile = os.path.join(folder, 'newfile2.mpg')
#remove an intermediate file
diff --git a/abs/core/mythtv/stable-0.25/mythplugins/mythplugins-mythzoneminder.install b/abs/core/mythtv/stable-0.25/mythplugins/mythplugins-mythzoneminder.install
index 142212b..a4e0c0d 100644
--- a/abs/core/mythtv/stable-0.25/mythplugins/mythplugins-mythzoneminder.install
+++ b/abs/core/mythtv/stable-0.25/mythplugins/mythplugins-mythzoneminder.install
@@ -1,3 +1,11 @@
post_install() {
- echo "If you want to use this plugin, install zoneminder from AUR."
+ . /etc/systemconfig
+ if [ $SystemType = Master_backend -o $SystemType = Standalone ]
+ then
+ echo "This looks a zoneminder server install"
+ echo "Installing zoneminder"
+ #for reference the pacman statement below will not work because of a db lock.
+ pacman -S zoneminder
+ fi
+
}