summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-09-30 17:43:43 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-09-30 17:43:43 (GMT)
commit745f038168bd69352eecad08f267bfc4f57dc52a (patch)
tree898557bfcf095a05f5aaf09b485fe958fe28872a /abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
parent1d47d5494777098c42cacadab9be9328f54da407 (diff)
downloadlinhes_pkgbuild-745f038168bd69352eecad08f267bfc4f57dc52a.zip
linhes_pkgbuild-745f038168bd69352eecad08f267bfc4f57dc52a.tar.gz
linhes_pkgbuild-745f038168bd69352eecad08f267bfc4f57dc52a.tar.bz2
mythtv: add tmdb3.py v3.6 and update db to use tmdb3.py
The tmdb v2 api was shutdown on 9/15/13 and the version of tmdb.py that is in .25/fixes has problems
Diffstat (limited to 'abs/core/mythtv/stable-0.25/mythtv/PKGBUILD')
-rw-r--r--abs/core/mythtv/stable-0.25/mythtv/PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD b/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
index 95f2a12..873eb92 100644
--- a/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=mythtv
pkgver=0.25
-pkgrel=28
+pkgrel=29
commit_hash=`cat ../git_src/git_hash`
pkgdesc="A Homebrew PVR project $commit_hash"
arch=('i686' 'x86_64')
@@ -77,7 +77,8 @@ optdepends=('xmltv: to download tv listings')
replaces=('mythvideo' 'myththemes')
conflicts=('mythvideo' 'myththemes')
source=('mythbackend' 'myth.sh' `echo ${patchs[@]:0}`
- 'mythbackend.lr' 'mythfrontend.lr' 'pretty' )
+ 'mythbackend.lr' 'mythfrontend.lr' 'pretty'
+ 'tmdb3.py' 'tmdb3_db_update.py')
build() {
@@ -108,6 +109,9 @@ build() {
#Fix Python DepreciationWarning
sed -i 's/return super(Artwork, cls).__new__(cls, attr, parent, imagetype)/return super(Artwork, cls).__new__(cls)/' ${srcdir}/mythtv/bindings/python/MythTV/dataheap.py
+ #Update tmdb3.py to v3.6 & add tmdb3_db_update.py script
+ cp $srcdir/tmdb3*.py $srcdir/mythtv/programs/scripts/metadata/Movie/
+
ARCH=${CARCH/_/-}
./configure --prefix=/usr --cpu=${ARCH} \
--disable-audio-jack \
@@ -162,4 +166,6 @@ md5sums=('7ef6de58240e7aad389a0b13d91b1cf6'
'ae23e6a8cffbe335fa37bf59978bf7a2'
'f735805a80b0d1180dee01f9df1b7004'
'f407d6af23e74a49540755420f84fa58'
- '5469d9921b726db750b991c87d226158')
+ '5469d9921b726db750b991c87d226158'
+ '187be42b1ffca6badfa539260ffef65e'
+ '561bc8552c9d1f146d02a6febea5e700')