summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-0.25
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-03 17:59:45 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-03 17:59:45 (GMT)
commit4be23d4482a7aec8820be8fa373bc8de5a0272b5 (patch)
tree453c78e84078cb6cfa3da1daa4906050aedb68a2 /abs/core/mythtv/stable-0.25
parent306d9e4bfa29faaa561d54df14a0533d034f9773 (diff)
downloadlinhes_pkgbuild-4be23d4482a7aec8820be8fa373bc8de5a0272b5.zip
linhes_pkgbuild-4be23d4482a7aec8820be8fa373bc8de5a0272b5.tar.gz
linhes_pkgbuild-4be23d4482a7aec8820be8fa373bc8de5a0272b5.tar.bz2
mythweb, mythexport,zoneminder, web_auth: convert packages to use gen_light_include.conf
refs #864 closes #864
Diffstat (limited to 'abs/core/mythtv/stable-0.25')
-rw-r--r--abs/core/mythtv/stable-0.25/mythweb/PKGBUILD9
-rw-r--r--abs/core/mythtv/stable-0.25/mythweb/mythweb.install18
-rw-r--r--abs/core/mythtv/stable-0.25/mythweb/mythweb_gen_light.conf1
3 files changed, 9 insertions, 19 deletions
diff --git a/abs/core/mythtv/stable-0.25/mythweb/PKGBUILD b/abs/core/mythtv/stable-0.25/mythweb/PKGBUILD
index 7c0cc8d..5e1c853 100644
--- a/abs/core/mythtv/stable-0.25/mythweb/PKGBUILD
+++ b/abs/core/mythtv/stable-0.25/mythweb/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mythweb
pkgver=0.25
-pkgrel=5
+pkgrel=6
commit_hash=`cat ../git_src/git_hash_web`
@@ -14,7 +14,7 @@ groups=('mythtv-extras')
install=mythweb.install
#http://code.mythtv.org/trac/ticket/10504
patches=(schedules.php.patch sorting.php.patch tv-schedules.php.patch)
-source=(`echo ${patches[@]:0}` mythweb.include)
+source=(`echo ${patches[@]:0}` mythweb.include mythweb_gen_light.conf)
DOCROOT=/data/srv/httpd/mythweb
build() {
@@ -64,9 +64,12 @@ build() {
#install conf files for lighttpd
mkdir -p $pkgdir/etc/lighttpd
install -D -m 644 $srcdir/mythweb.include $pkgdir/etc/lighttpd/
+ #gen_light_conf
+ install -D -m0744 ${srcdir}/mythweb_gen_light.conf ${pkgdir}/etc/gen_light_conf.d/mythweb.conf
}
md5sums=('392e570594859c026ac12194920246d8'
'53cc59d6a8bf144027b25d5dcbfffc66'
'515e29fda503c199888a91553e1815a0'
- '7645a6399434cbba35639713ac5d88e0')
+ '7645a6399434cbba35639713ac5d88e0'
+ 'df190116b3aba35720fb6631885f973f')
diff --git a/abs/core/mythtv/stable-0.25/mythweb/mythweb.install b/abs/core/mythtv/stable-0.25/mythweb/mythweb.install
index f5abcea..0073499 100644
--- a/abs/core/mythtv/stable-0.25/mythweb/mythweb.install
+++ b/abs/core/mythtv/stable-0.25/mythweb/mythweb.install
@@ -1,13 +1,5 @@
post_install() {
- COUNT=`grep -c "mythweb.include" /etc/lighttpd/conf.include`
- if [ $COUNT == 0 ]
- then
- echo "==> Adding mythweb.include to conf.include"
- echo "include \"/etc/lighttpd/mythweb.include\"" >> /etc/lighttpd/conf.include
- fi
- echo
- echo "==> Forcing a re-read of lighttpd's configuration file."
- echo ""
+ gen_light_include.py
/sbin/sv hup /service/lighttpd
}
post_upgrade() {
@@ -16,13 +8,7 @@ post_upgrade() {
}
post_remove() {
- COUNT=`grep -c "mythweb.include" /etc/lighttpd/conf.include`
- if [ $COUNT -gt 0 ]
- then
- echo "==> Removing mythweb.include from conf.include"
- sed -i 's#include \"/etc/lighttpd/mythweb.include\"##' -i /etc/lighttpd/conf.include
- fi
-
+ gen_light_include.py
echo
echo "==> Forcing a re-read of lighttpd's configuration file."
echo ""
diff --git a/abs/core/mythtv/stable-0.25/mythweb/mythweb_gen_light.conf b/abs/core/mythtv/stable-0.25/mythweb/mythweb_gen_light.conf
new file mode 100644
index 0000000..ddf0d2f
--- /dev/null
+++ b/abs/core/mythtv/stable-0.25/mythweb/mythweb_gen_light.conf
@@ -0,0 +1 @@
+include "/etc/lighttpd/mythweb.include"