summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-0.25
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-21 19:13:01 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-21 19:13:01 (GMT)
commit70ccf2020802a6fee96815b553aea2ea4f9a99be (patch)
treedb2dd4b830f03db8c60b2a793e6062893df1af28 /abs/core/mythtv/stable-0.25
parente9b64edf2af0b1bccea2670e8b5724d2672f5e66 (diff)
downloadlinhes_pkgbuild-70ccf2020802a6fee96815b553aea2ea4f9a99be.zip
linhes_pkgbuild-70ccf2020802a6fee96815b553aea2ea4f9a99be.tar.gz
linhes_pkgbuild-70ccf2020802a6fee96815b553aea2ea4f9a99be.tar.bz2
mythtv: new myth_settings-2.patch. Fix typo when handeling syssettings import. The old file would bail out instead of doing any importing
Diffstat (limited to 'abs/core/mythtv/stable-0.25')
-rw-r--r--abs/core/mythtv/stable-0.25/mythtv/PKGBUILD2
-rwxr-xr-xabs/core/mythtv/stable-0.25/mythtv/myth_settings-2.patch15
2 files changed, 9 insertions, 8 deletions
diff --git a/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD b/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
index 46ee3e6..e8ad430 100644
--- a/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
@@ -141,7 +141,7 @@ package() {
md5sums=('7ef6de58240e7aad389a0b13d91b1cf6'
'2babd4b8e146a7538d18dcd55695b0be'
'c4db7784c5107ae846fd795a4dabe0bc'
- '3513b4ed3d316f603b394607116c85d0'
+ '08634edc00f738b8732bfa7f574e22fd'
'f735805a80b0d1180dee01f9df1b7004'
'f407d6af23e74a49540755420f84fa58'
'5469d9921b726db750b991c87d226158')
diff --git a/abs/core/mythtv/stable-0.25/mythtv/myth_settings-2.patch b/abs/core/mythtv/stable-0.25/mythtv/myth_settings-2.patch
index 5bf0105..4e83473 100755
--- a/abs/core/mythtv/stable-0.25/mythtv/myth_settings-2.patch
+++ b/abs/core/mythtv/stable-0.25/mythtv/myth_settings-2.patch
@@ -1,8 +1,8 @@
diff --git a/mythtv/programs/mythutil/settingsutils.cpp b/mythtv/programs/mythutil/settingsutils.cpp
-index ff7e509..fdb05d6 100644
+index ff7e509..d229f27 100644
--- a/mythtv/programs/mythutil/settingsutils.cpp
+++ b/mythtv/programs/mythutil/settingsutils.cpp
-@@ -382,6 +382,16 @@ static int ImportSettings(const MythUtilCommandLineParser &cmdline)
+@@ -382,6 +382,17 @@ static int ImportSettings(const MythUtilCommandLineParser &cmdline)
else
value_pair_map[record_element.nodeName()] = record_element.text();
}
@@ -10,16 +10,17 @@ index ff7e509..fdb05d6 100644
+ {
+ if ( value_pair_map["value"] == "BackendServerIP")
+ {
-+ out_string = "*sysettings! ignoring backendserver ip record";
++ out_string = "sysettings, ignoring backendserver ip record";
+ cout << out_string.toLocal8Bit().constData() << endl;
-+ continue;
+ }
++ else
++ gCoreContext->import_settings(value_pair_map,table_name);
+ }
+ else
//perform insert
gCoreContext->import_settings(value_pair_map,table_name);
}
-@@ -454,7 +464,6 @@ static int ExportSettings(const MythUtilCommandLineParser &cmdline)
+@@ -454,7 +465,6 @@ static int ExportSettings(const MythUtilCommandLineParser &cmdline)
QDomElement tag = doc.createElement(y.key());
record.appendChild(tag);
QDomText t;
@@ -27,11 +28,11 @@ index ff7e509..fdb05d6 100644
if ( distro_default == TRUE )
{ // If exporting distro_default then change hostname + table
if ( y.key() == "hostname" )
-@@ -500,6 +509,7 @@ static int ExportSettings(const MythUtilCommandLineParser &cmdline)
+@@ -500,6 +510,7 @@ static int ExportSettings(const MythUtilCommandLineParser &cmdline)
}
}
QFile file( export_filename );
+
if( !file.open(QIODevice::WriteOnly) )
return -1;
-
+