summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-11-19 18:19:58 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-11-19 18:19:58 (GMT)
commitae3b752a81135d139c057bb5f060a9ddcb8ab397 (patch)
tree9851fe9d2bf242152d47384643a69fb185184665 /abs/core/mythtv/stable-0.27/mythtv/PKGBUILD
parent02f95477101b1afb1b9d1f54c3999d58eca41b16 (diff)
downloadlinhes_pkgbuild-ae3b752a81135d139c057bb5f060a9ddcb8ab397.zip
linhes_pkgbuild-ae3b752a81135d139c057bb5f060a9ddcb8ab397.tar.gz
linhes_pkgbuild-ae3b752a81135d139c057bb5f060a9ddcb8ab397.tar.bz2
mythtv mythplugins: update to latest .27-fixes. refs #933.
add suggestedstarttime patch for mythweb showing suggested start time of mythfilldatabase
Diffstat (limited to 'abs/core/mythtv/stable-0.27/mythtv/PKGBUILD')
-rw-r--r--abs/core/mythtv/stable-0.27/mythtv/PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD b/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD
index 6af1e2f..6ec4e55 100644
--- a/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mythtv
pkgver=0.27
-pkgrel=2
+pkgrel=3
commit_hash=`cat ../git_src/git_hash`
pkgdesc="A Homebrew PVR project $commit_hash"
arch=('i686' 'x86_64')
@@ -18,10 +18,12 @@ groups=('pvr')
backup=()
install='mythtv.install'
-patches=(#'myth_settings.patch'
- '0001-protect-metadata-loads-from-multiple-threads.patch')
+patches=('myth_settings.patch'
+ '0001-protect-metadata-loads-from-multiple-threads.patch'
#http://code.mythtv.org/trac/ticket/10825 thread safety in video metadata load
-
+ 'suggestedstarttime.patch.v1')
+ #http://code.mythtv.org/trac/ticket/11562 next mythfilldatabase run in mythweb
+
optdepends=()
replaces=('mythvideo' 'myththemes')
conflicts=('mythvideo' 'myththemes')
@@ -41,11 +43,11 @@ build() {
echo "#!/bin/bash" > version.sh
msg "--------------------------applying patches------------------------------"
- for i in `echo ${patches[@]:0} `
+ for i in `echo ${patches[@]:0}`
do
echo applying $i
- echo "-----------------------------"
patch -Np2 -i ${startdir}/src/$i || return 1
+ echo "-----------------------------"
done
msg "--------------------------done applying patches-------------------------"
@@ -97,5 +99,7 @@ package() {
install -m0755 ${srcdir}/recordings ${pkgdir}/etc/cron.hourly/
}
-md5sums=('67f7316c750fba17fa578d10840b9dbd'
+md5sums=('5f3e43567e62afe17bad39f5a9b604cf'
+ '67f7316c750fba17fa578d10840b9dbd'
+ '35a7fd3e3057691e3b1bf355bb9e8b16'
'65a08d8949431ecdeb51a686dc6f9c21')