summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-29/mythplugins/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-30 19:40:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-30 19:40:12 (GMT)
commitf324e0cf4b98c20c509a6d076bfadf88346d09d5 (patch)
tree8e55bfd9d5ba546258b1edc6fe53ad496e04a96f /abs/core/mythtv/stable-29/mythplugins/PKGBUILD
parent8941080f15d473a4ffb2c86aac2cc72bee1ed764 (diff)
downloadlinhes_pkgbuild-f324e0cf4b98c20c509a6d076bfadf88346d09d5.zip
linhes_pkgbuild-f324e0cf4b98c20c509a6d076bfadf88346d09d5.tar.gz
linhes_pkgbuild-f324e0cf4b98c20c509a6d076bfadf88346d09d5.tar.bz2
mythtv & mythplugins: update to latest fixes
Diffstat (limited to 'abs/core/mythtv/stable-29/mythplugins/PKGBUILD')
-rw-r--r--abs/core/mythtv/stable-29/mythplugins/PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/abs/core/mythtv/stable-29/mythplugins/PKGBUILD b/abs/core/mythtv/stable-29/mythplugins/PKGBUILD
index 11e0930..55e70b5 100644
--- a/abs/core/mythtv/stable-29/mythplugins/PKGBUILD
+++ b/abs/core/mythtv/stable-29/mythplugins/PKGBUILD
@@ -9,22 +9,22 @@ pkgname=('mytharchive'
'mythweather'
'mythzoneminder')
pkgver=29.1
-pkgrel=2
-arch=('i686' 'x86_64')
+pkgrel=3
+arch=('x86_64')
url="http://www.mythtv.org"
license=('GPL')
makedepends=('cdrkit' 'dcraw' 'dvdauthor' 'dvd+rw-tools' 'ffmpeg' 'flac' 'libexif'
'libvorbis' 'mesa' 'libgl' 'mplayer' "mythtv>=${pkgver}"
'perl-datetime-format-iso8601' 'perl-date-manip' 'perl-image-size'
'perl-json' 'perl-libwww' 'perl-soap-lite' 'perl-xml-sax'
- 'perl-xml-simple' 'perl-xml-xpath' 'python-oauth' 'python2-pillow'
+ 'perl-xml-simple' 'perl-xml-xpath' 'python2-oauth' 'python2-pillow'
'python2-pycurl' 'zlib')
source=('mythburn.py-aspectratio.patch'
'cdparanoia.patch'
'0317-0336-MythMusic-Fix-Playlist-copyTracks-and-removeAllTrack.patch'
)
-build() {
+prepare() {
if [ -e ${srcdir}/mythplugins ]
then
msg "Removing old mythplugins src"
@@ -38,14 +38,20 @@ build() {
cd ${srcdir}
patch -Np1 -i "$srcdir/0317-0336-MythMusic-Fix-Playlist-copyTracks-and-removeAllTrack.patch"
- msg "Patching configure"
+ msg "Change python to python2"
+ find . -name '*.py' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
+
+ msg "Patching Configure"
cd ${srcdir}/${pkgbase}
patch -Np1 -i "$srcdir/cdparanoia.patch"
+}
+build() {
+ cd ${srcdir}/${pkgbase}
msg "Configuring mythplugins"
./configure --prefix=/usr \
--enable-all \
- --python=/usr/bin/python2
+ --python=python2
msg "Compiling mythplugins"
qmake-qt5 mythplugins.pro || return 1
@@ -93,7 +99,7 @@ package_mythmusic() {
package_mythnetvision() {
pkgdesc="MythNetvision plugin for MythTV"
- depends=("mythtv>=${pkgver}" 'python-pycurl' 'python-oauth'
+ depends=("mythtv>=${pkgver}" 'python2-pycurl' 'python2-oauth'
'python2-lxml' 'python2')
cd "${srcdir}/${_gitname}/${pkgbase}/mythnetvision"
make INSTALL_ROOT="${pkgdir}" install || return 1