summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-29/mythplugins
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-12-08 19:18:59 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-12-08 19:18:59 (GMT)
commite4b0dec19f02e6d8e995b19a22110cac26f07ac4 (patch)
treea78baa8ac9914820a0c470c391772bcdb9e17b4d /abs/core/mythtv/stable-29/mythplugins
parent8d974e65b3f138043d66e699a9bcfb206abf40f5 (diff)
downloadlinhes_pkgbuild-e4b0dec19f02e6d8e995b19a22110cac26f07ac4.zip
linhes_pkgbuild-e4b0dec19f02e6d8e995b19a22110cac26f07ac4.tar.gz
linhes_pkgbuild-e4b0dec19f02e6d8e995b19a22110cac26f07ac4.tar.bz2
mythtv & mythplugins: update translationsR8.5
add some patches
Diffstat (limited to 'abs/core/mythtv/stable-29/mythplugins')
-rw-r--r--abs/core/mythtv/stable-29/mythplugins/0317-0336-MythMusic-Fix-Playlist-copyTracks-and-removeAllTrack.patch50
-rw-r--r--abs/core/mythtv/stable-29/mythplugins/PKGBUILD15
2 files changed, 61 insertions, 4 deletions
diff --git a/abs/core/mythtv/stable-29/mythplugins/0317-0336-MythMusic-Fix-Playlist-copyTracks-and-removeAllTrack.patch b/abs/core/mythtv/stable-29/mythplugins/0317-0336-MythMusic-Fix-Playlist-copyTracks-and-removeAllTrack.patch
new file mode 100644
index 0000000..5c0f623
--- /dev/null
+++ b/abs/core/mythtv/stable-29/mythplugins/0317-0336-MythMusic-Fix-Playlist-copyTracks-and-removeAllTrack.patch
@@ -0,0 +1,50 @@
+From e7c80f43a3ec0fc2024f64e17d13461840429029 Mon Sep 17 00:00:00 2001
+From: Lawrence Rust <lvr@softsystem.co.uk>
+Date: Fri, 17 Jun 2016 18:40:37 +0100
+Subject: [PATCH 336/348] MythMusic: Fix Playlist::copyTracks and
+ removeAllTracks
+
+Correct these 2 functions to call gPlayer->activePlaylistChanged
+
+Signed-off-by: Lawrence Rust <lvr@softsystem.co.uk>
+---
+ mythplugins/mythmusic/mythmusic/playlist.cpp | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/mythplugins/mythmusic/mythmusic/playlist.cpp b/mythplugins/mythmusic/mythmusic/playlist.cpp
+index 79a509a..94146a4 100644
+--- a/mythplugins/mythmusic/mythmusic/playlist.cpp
++++ src/mythplugins/mythmusic/mythmusic/playlist.cpp
+@@ -46,7 +46,7 @@ bool Playlist::checkTrack(MusicMetadata::IdType trackID) const
+
+ void Playlist::copyTracks(Playlist *to_ptr, bool update_display)
+ {
+- disableSaves();
++ to_ptr->disableSaves();
+
+ for (int x = 0; x < m_songs.size(); x++)
+ {
+@@ -58,9 +58,9 @@ void Playlist::copyTracks(Playlist *to_ptr, bool update_display)
+ }
+ }
+
+- enableSaves();
++ to_ptr->enableSaves();
+
+- changed();
++ to_ptr->changed();
+ }
+
+ /// Given a tracks ID, add that track to this playlist
+@@ -94,6 +94,8 @@ void Playlist::removeAllTracks(void)
+ m_shuffledSongs.clear();
+
+ changed();
++
++ gPlayer->activePlaylistChanged(-1, true);
+ }
+
+ void Playlist::removeAllCDTracks(void)
+--
+1.7.9.5
+
diff --git a/abs/core/mythtv/stable-29/mythplugins/PKGBUILD b/abs/core/mythtv/stable-29/mythplugins/PKGBUILD
index 171d9be..35d18e4 100644
--- a/abs/core/mythtv/stable-29/mythplugins/PKGBUILD
+++ b/abs/core/mythtv/stable-29/mythplugins/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=('mytharchive'
'mythweather'
'mythzoneminder')
pkgver=29
-pkgrel=6
+pkgrel=7
arch=('i686' 'x86_64')
url="http://www.mythtv.org"
license=('GPL')
@@ -19,7 +19,10 @@ makedepends=('cdrkit' 'dcraw' 'dvdauthor' 'dvd+rw-tools' 'ffmpeg' 'flac' 'libexi
'perl-json' 'perl-libwww' 'perl-soap-lite' 'perl-xml-sax'
'perl-xml-simple' 'perl-xml-xpath' 'python-oauth' 'python2-pillow'
'python-pycurl' 'zlib')
-source=('mythburn.py-aspectratio.patch' 'cdparanoia.patch')
+source=('mythburn.py-aspectratio.patch'
+ 'cdparanoia.patch'
+ '0317-0336-MythMusic-Fix-Playlist-copyTracks-and-removeAllTrack.patch'
+ )
build() {
if [ -e ${srcdir}/mythplugins ]
@@ -31,9 +34,12 @@ build() {
cd ${startdir}
msg "Copying in mythplugins git_src"
cp -rp ../git_src/mythtv/mythplugins $srcdir
- cd ${srcdir}/${pkgbase}
+
+ cd ${srcdir}
+ patch -Np1 -i "$srcdir/0317-0336-MythMusic-Fix-Playlist-copyTracks-and-removeAllTrack.patch"
msg "Patching configure"
+ cd ${srcdir}/${pkgbase}
patch -Np1 -i "$srcdir/cdparanoia.patch"
msg "Configuring mythplugins"
@@ -118,4 +124,5 @@ package_mythzoneminder() {
}
md5sums=('e98c2a09bcb051fdde959fb4bb2e5ab2'
- '5de8dd79d0b8a2b006f3c3258938b6b7')
+ '5de8dd79d0b8a2b006f3c3258938b6b7'
+ '0299d0214c0d3a452c0284352435d698')