summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-29/mythtv
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-30 19:40:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-30 19:40:12 (GMT)
commitf324e0cf4b98c20c509a6d076bfadf88346d09d5 (patch)
tree8e55bfd9d5ba546258b1edc6fe53ad496e04a96f /abs/core/mythtv/stable-29/mythtv
parent8941080f15d473a4ffb2c86aac2cc72bee1ed764 (diff)
downloadlinhes_pkgbuild-f324e0cf4b98c20c509a6d076bfadf88346d09d5.zip
linhes_pkgbuild-f324e0cf4b98c20c509a6d076bfadf88346d09d5.tar.gz
linhes_pkgbuild-f324e0cf4b98c20c509a6d076bfadf88346d09d5.tar.bz2
mythtv & mythplugins: update to latest fixes
Diffstat (limited to 'abs/core/mythtv/stable-29/mythtv')
-rw-r--r--abs/core/mythtv/stable-29/mythtv/PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/abs/core/mythtv/stable-29/mythtv/PKGBUILD b/abs/core/mythtv/stable-29/mythtv/PKGBUILD
index a6446a6..e3afb4f 100644
--- a/abs/core/mythtv/stable-29/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-29/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mythtv
pkgver=29.1
-pkgrel=2
+pkgrel=3
commit_hash=`cat ../git_src/git_hash`
pkgdesc="A Homebrew PVR project $commit_hash"
arch=('x86_64')
@@ -44,7 +44,7 @@ patches=(
optdepends=()
source=(`echo ${patches[@]:0}` 'recordings')
-build() {
+prepare() {
if [ -e ${srcdir}/mythtv ]
then
msg "Removing old mythtv src"
@@ -61,14 +61,20 @@ build() {
for i in `echo ${patches[@]:0}`
do
echo applying $i
- patch -Np2 -i ${startdir}/src/$i || return 1
+ patch -Np2 -i ${startdir}/src/$i || return 1
echo "-----------------------------"
done
msg "--------------------------done applying patches-------------------------"
+ msg "Change python to python2"
+ find 'bindings/python' 'contrib' 'programs/scripts' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
+
msg "Updating en_us Translation"
cd ${srcdir}/$pkgname/i18n
lrelease -removeidentical mythfrontend_en_us.ts
+}
+
+build() {
cd ${srcdir}/$pkgname
msg "Configuring mythtv"